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1
Welcome to SOLIDWORKS 2017

This chapter includes the following topics:

• Top Enhancements
• Sample Files
• For More Information

SOLIDWORKS® 2017 delivers
many enhancements and
improvements, most created
in direct response to customer
requests. This release focuses
on helping you get your work
done faster and more easily
than ever before by enabling
you to:

• Design. Drive innovation with precise, advanced modeling capabilities. Work faster with
more control and less overhead.

• Validate. Solve complex problems and validate your designs with confidence and ease.
Increase productivity while gaining greater insights into design performance.

• Collaborate. Accelerate new product innovation with efficient content sharing across the
complete supply chain. Leverage existing content and engage all team members more
effectively.

14



• Build. Implement a fully integrated model-based manufacturing strategy. Use your 3D CAD
models, including dimensions, tolerances, annotations, tables, and electrical information to
create all your manufacturing deliverables.

• Manage. Execute a multi-disciplinary product data management workflow. Collect and
manage all design data across your entire enterprise.

Top Enhancements
The top enhancements for SOLIDWORKS 2017 provide improvements to existing products
and innovative new functionality.

Throughout this guide, look for the symbol in these areas:

User Interface • Customizing Configuration Sort Order on page 18

Assemblies • Distance Mates to Cylindrical Components on page 49
• Facility Layout on page 35
• Assembly Performance Improvements on page 34
• Preserving Drawing References on page 52
• SpeedPak Enhancements on page 54
• Treehouse Improvements on page 56

SOLIDWORKS
Costing

• Common Rules for Sheet Metal and Machining Parts on
page 62

• Evaluating the Cost of Assemblies in Nested Tree Mode
on page 65

• Feature Recognition for Operations on page 60
• Rules-based Costing for Parts on page 62
• Subassembly Costing on page 64
• Unique Rules for Sheet Metal Templates on page 64

DimXpert • Multiple Edge Selection on page 70

Drawings and
Detailing

• Jagged Outlines on page 79
• Linking a Note to a Table Cell on page 86
• Mirror Drawing Views on page 83

Import/Export • IFC Entity Classification and Custom Property Export on
page 104

• Exporting SOLIDWORKS files as 3MF Files on page 106

Model Display • Controlling Decals and Scenes by Display States on page
126

• Creating Transparent Section Views on page 132
• PhotoView 360 Network Rendering Supports

Frame-by-Frame Rendering on page 132
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Parts and Features • Bidirectional Circular Patterns on page 141
• Chamfer Enhancements on page 143
• Converting Features to Bodies and Surfaces on page 144
• Advanced Holes on page 136
• Derived Part References are Retained on page 148
• Sweep Profile Selection of Faces, Edges, and Curves on
page 150

• Window Selection for Instances to Skip on page 154
• Wrap Creates Geometry on Any Face on page 155

Routing • Enhancements in Edit Flattened Route on page 192
• Securing Distinct Routes Through Clips on page 196

Sheet Metal • Creating Three Bend Corner Reliefs on page 198

Sketching • Creating Sketch Offsets on 3D Geometry Surfaces on page
216

• Prevention of Accidental Micro Lines on page 219
• Shaded Sketch Contours on page 219
• Extruding Shaded Sketch Contours on page 220

SOLIDWORKSMBD • Comparing 3D PMI Between Parts on page 123

SOLIDWORKSPDM • Generating SOLIDWORKS MBD 3D PDFs on page 160
• Latest Version Overwrite on page 161
• Rolling Back a File with References on page 166
• SOLIDWORKS PDF Task Add-in on page 171
• SOLIDWORKS PDM Web2 Viewer Enhancements on page
181

• Vault Database Replication on page 183

SOLIDWORKS
Simulation

• Improved Arc Length Control Method for Nonlinear Contact
Analysis on page 207

• Editing Multiple Contact Sets on page 206
• Mass Properties in Simulation on page 208
• Offloaded Simulation on page 209
• Remote Loads and Mass for Beams on page 214

SOLIDWORKS
Toolbox

• Purging Inactive Toolbox Configuration Data on page 222

All features are available in SOLIDWORKS Standard, SOLIDWORKS Professional, and
SOLIDWORKS Premium unless otherwise noted.
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Sample Files
Beginning in SOLIDWORKS 2017, sample files are stored in a new location.

The previous location was in the SOLIDWORKS installation folder. The Program Files
folder is restricted from write-access by default on all supported operating systems. Many
users were unable to complete tutorials due to these restrictions. The Public Documents
folder, by default, is writeable and visible to all users.

To open sample files for this book, go to drive letter:\Users\Public\Public
Documents\SOLIDWORKS\SOLIDWORKS 2017\whatsnew\chapter name\filename.

For example, C:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS
2017\whatsnew\sheet metal\bracket.sldprt.

For More Information
Use the following resources to learn about SOLIDWORKS:

This guide is available in PDF and HTML formats. Click:What's New in PDF
and HTML • Help > What's New > PDF

• Help > What's New > HTML

In SOLIDWORKS, click the symbol to display the section of
this manual that describes an enhancement. The symbol appears

Interactive What's
New

next to new menu items and the titles of new and changed
PropertyManagers.

To enable Interactive What's New, click Help > What's New >
Interactive.

What's New Examples are updated at every major release to
provide examples of how to use most top enhancements in the
release.

To open What's New Examples click Help > What's New >
What's New Examples.

What's New
Examples

Contains complete coverage of our products, including details
about the user interface, samples, and examples.

Online Help

Provides information about late changes to our products, including
changes to the What's New book, online help, and other
documentation.

Release Notes
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2
User Interface

This chapter includes the following topics:

• Customizing Configuration Sort Order
• Disabling Selection Accelerator Toolbars
• Dynamic Reference Visualization
• Comment in FeatureManager Design Tree
• Hide All Types
• Interface Updates for SOLIDWORKS Rx, Task Scheduler, and Sustainability
• Property Tab Builder Redesign
• Selection Breadcrumbs
• Shortcut Menus
• Suppressing Configuration and Display State Names in the FeatureManager Design

Tree
• Touch-based Interactions

Customizing Configuration Sort Order
You can specify the order in which configurations are listed in the ConfigurationManager.

To customize configuration sort order:

1. In the ConfigurationManager, right-click the top-level configuration and click Tree
Order.

2. Select one of the following:

DescriptionOption

Sorts by ascending alpha or numeric value.Numeric

Sorts by alphabetical order.Literal

Lets you drag and drop configurations in the configuration
tree. As you drag up or down the tree, each configuration
that you drag over is highlighted. The configuration that you
are moving drops immediately below the currently highlighted
item when you release the pointer.

Manual (Drag and
Drop)

Sorts by the date the configuration was created, from earliest
created at the top of the list to most recently created at the
bottom of the list.

History-Based
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Disabling Selection Accelerator Toolbars
You can disable the selection accelerator toolbars that appear when you select entities
for the Fillet, Move Face, and Delete Face tools.

To disable selection accelerator toolbars:

Do one of the following:

• In the PropertyManager, clear Show selection toolbar.

• Click at the end of the selection toolbar.

The selection is stored for the next feature in the PropertyManager. For example, if
you clear a check box for a fillet, it remains cleared for the next fillet in the
PropertyManager.

To enable accelerator toolbars, select Show selection toolbar.

Dynamic Reference Visualization
Dynamic reference visualization showing parent and child relationships is enhanced to
avoid overlapping text and lines.

Arrows begin from the circle to indicate the feature whose parent and child relationships
you are viewing.
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SOLIDWORKS 2017SOLIDWORKS 2016

Comment in FeatureManager Design Tree
The existing ability to add comments to models has been enhanced. It is easier to view
and edit models based on the comments over the lifecycle of a product's design.

• You can add comments to almost all nodes in the FeatureManager design tree. The
comments extends to the following nodes:

• Mates (all types)
• Mate folder or Mate group
• Folders
• Sensors
• Material
• Annotation views
• Blocks
• Solid bodies folder
• Surface bodies folder
• Sheet metal nodes
• Mate references

• To locate comments more easily, you can turn on the comment indicators.
• You can add standalone comments that are not attached to a feature or node in the
FeatureManager design tree.

• When you create or edit a comment, you can attach an image or a screen capture of
the model.

• You can view feature comments in the PropertyManager.
• When you add a comment to a feature, a timestamp is added automatically to the
comment.

• You can view all comments in one dialog box and export the comments to a Microsoft
Word document.

The ConfigurationManager also shows similar enhancements for comments.

Turning on Comment Indicators
You can turn on comment indicators in the FeatureManager design tree display to locate
the comments more easily.

To turn on comment indicators:

1. In the FeatureManager design tree, right-click the top node.
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2. Click Tree Display > Show Comment Indicator.

Visual indicators appear in the FeatureManager design tree to indicate if a comment
exists.

Adding Standalone Comments
You can add standalone comments that are not attached to a feature or node in the
FeatureManager design tree.

To add standalone comments:

1. Click Add Comment (Standard toolbar).
2. In the Comment box, type the comment and click Save and Close.

The standalone comment is added in the Comments folder in FeatureManager
design tree.

You can also right-click the Comments folder and click Add Comment to add a
standalone comment.

Adding Images and Screenshots to Comments
You can add images and screenshots to comments. When you add a comment to a feature,
a timestamp is added automatically to the comment.

To add images and screenshots to comments:

1. Click Add Comment (Standard toolbar).
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2. In the Comment box, click one or both of the following:

• Insert image . Lets you browse for an image and adds it in the comment with
a preview.

• Insert screenshot . Adds an image of the graphics area in the comment with
a preview.

3. Click Save and Close.

Viewing and Editing Comments in PropertyManagers
You can view and edit the comments of a feature in PropertyManagers.

To view and edit comments in PropertyManagers:

1. Click Tools > Options > System Options > Collaboration.
2. In the dialog box, select Show Comments in PropertyManager.
3. In the graphics area, select a feature that has a comment attached to it and click

Edit Feature .
4. In the PropertyManager, under Comment, click Edit.
5. Modify the comment and click Save and Close.

6. Click .

Hide All Types
You can use the Hide/Show Items tool in the Heads-up View toolbar to hide all items
in one click without leaving the graphics area.

The tool is split into two: . On the left side, you can toggle between hide all types
and show the previous visibility state. On the right side, you can view the existing list of
types to change visibility of one item at a time.

Interface Updates for SOLIDWORKS Rx, Task
Scheduler, and Sustainability

The user interface for SOLIDWORKS Rx, Task Scheduler, and Sustainability have been
updated for consistency with the user interface redesign in SOLIDWORKS 2016.

Improvements include an updated color scheme, icons, tabs, and more readable text.

Property Tab Builder Redesign
The user interface for the Property Tab Builder has been updated to be easier to use.

Improvements include an updated color scheme and icons, and an improved layout of
the areas for creating group boxes, textboxes, lists, and other features of custom tabs.
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The installed version of the SOLIDWORKS software displays in the Property Tab Builder
header. This label is useful when you have users running different versions of the software,
and you want to make sure that you are creating a template that matches what a given
set of users is running on their machines.

You can also drag the border of the Custom Properties panel to make it wider or narrower
relative to the Control Attributes panel.

Selection Breadcrumbs
Selection breadcrumbs have better feedback. When you hover over the items, breadcrumbs
display information only for the mates that are applicable for the selected face, edge,
vertex, feature, or body.

Enhancements include additional feedback for:

• Assembly mates. Mate breadcrumbs are better aligned so you know which mates apply
to the selected parts or subassemblies.

• Failures and errors. Mates with failures or errors appear in breadcrumbs.

• Suppressed states. The suppression state of entities are reflected in breadcrumbs.

When you click a breadcrumb, only the mates that are associated with the entity appear.

Part selectedSubassembly selected

In addition, breadcrumbs provide easy access to a part’s reference planes to let you:

• Control the reference plane visibility.
• Pre-select reference planes for use as sketch planes, use in a feature, or creating an
assembly mate.
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Shortcut Menus
The shortcut menus are enhanced and standardized to provide quick access to the most
commonly used tools.

To increase efficiency, duplicate tools are removed and related tools are moved to flyout
menus. The long Sketch Entities flyout menu uses the compact grid format to avoid
unnecessary mouse travel. You can scroll through the menu using the middle mouse
wheel if the menu runs off the screen.
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Suppressing Configuration and Display State Names
in the FeatureManager Design Tree

In models that contain only one configuration, you can suppress the configuration and
display state information that is appended to assembly and part names in the
FeatureManager design tree.

To suppress configuration and display state names in the FeatureManager design
tree:

In the FeatureManager design tree, right-click the top node and click Tree Display >
Do not show Configuration/Display State Names if only one exists.

If there is only one configuration, the configuration and display state names are
suppressed. You can still access the information in the FeatureManager design tree
by hovering over the component.

If there is more than one configuration, the configuration and display state names
appear after the component name.

Touch-based Interactions
Touch gestures are revised to make the user experience easier and more intuitive. The
software is enhanced to support controls for basic view manipulation on touch screen
devices.

You can work on models using the touch gestures and perform actions like a finger drag
to rotate and a two finger drag to pan. Also, you can use Pan, Roll, and Zoom In/Out
actions concurrently. These updated controls apply to Microsoft Windows 8 and later
versions.
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3
SOLIDWORKS Fundamentals

This chapter includes the following topics:

• Application Programming Interface
• Improved Browse for Folder Dialog Box

Application Programming Interface
See SOLIDWORKS API Help: Release Notes for late-breaking updates.

SOLIDWORKS 2017 API includes the ability to:

• Create and access selection sets.
• Traverse the Manager Pane and activate the FeatureManager design tree,
PropertyManager, ConfigurationManager, DimXpertManager, DisplayManager, or custom
tab. Also, fire a pre-notification and notification when activating a tab in the Manager
Pane.

• Get whether an axis is a temporary axis and get its reference face.
• Set the properties of a selected component in a specific configuration, including whether
the component is an envelope.

• Get the parameterization data of a specific spline in a sketch.
• Get or set the state of a check box on a PropertyManager page.
• Create sweep features using a circular profile or tool body.
• Create bidirectional sweeps.
• Import tables from and export tables to Microsoft Excel files for variable patterns.
• Modify variable patterns.
• Get or set the width or height at which to lock a column or row in a table annotation.
• Offset selected edges to create a 3D sketch on a face or surface.
• Zoom a drawing sheet to its maximum size within a window.
• Make a selected component independent.
• Replace components either by letting SOLIDWORKS attempt to match the configuration
of the old components with a configuration in the replacement component or by using
the specified configuration in the replacement component.

• Isolate components.
• Get or set the routing component grouping options for a BOM table in a drawing of an
assembly containing routing components.

• Get the names of the exploded views for a specific configuration, get the number of
exploded views in a specific configuration, and get the name of the configuration for
a specific exploded view in an assembly.

• Get the name of the exploded view currently shown in the model.

26



• Get the collapsed or exploded transform of a component when the assembly is exploded.
• Expand the specified component in the specified FeatureManager design tree pane.
• Delete either the selected components of a subassembly or the subassembly of the
selected component.

• Get or set the display state of a drawing view.
• Group selected edges or sketch segments into one object for the path for a sweep
feature.

• Get the persistent reference ID of the configuration referenced in a drawing view.
• Get or set whether to display the description of a configuration in a bill of materials.
• Get or set whether to enable cell drop-down lists in design tables.
• Get or set the vertical justification of a standard note.
• Get or set the length of a bent leader.
• Get or set whether to propagate visual properties in a table-driven pattern.
• Synchronize flexible subassemblies when creating a linear or circular pattern of
components in an assembly.

• Get or set whether to propagate visual properties in a derived pattern feature.
• Get or set whether to disable an equation and get the number of disabled equations
in a model.

• Specify a sketch plane, surface/face/plane, vertex, or offset as a start condition when
creating an extruded surface.

• Draft angles, cap ends, delete original faces, and knit the bodies created by deleting
original faces in extruded surfaces.

• Specify multiple drawing sheets whose setups to modify.
• Update SOLIDWORKS Toolbox components in the specified assembly level using the
current information in Toolbox settings.

• Create SpeedPak configurations for subassemblies in an assembly.
• Rebuild all features or rebuild only those features that need to be rebuilt in all
configurations without activating each configuration in a model.

• Create a STEP 242 file from SOLIDWORKS MBD.
• Create a derived pattern feature, get or set which pattern instance to use as the seed
feature for a derived pattern feature, and get or set whether to propagate visual
properties in a derived pattern feature.

• Get the DimXpert name for an annotation.
• Fire a notification when publishing an assembly or part document to SOLIDWORKS
MBD 3D PDF.

Improved Browse for Folder Dialog Box
The Browse for Folder dialog box has been renamed to Select Folder and has been
enhanced for ease of use.

The Browse for Folder dialog box had limited functionality, which made it more
cumbersome to use. In the Select Folder dialog box, you can:

• See the Date created and Date modified information.
• Search for folders.
• Sort folders.
• Select virtual (non-file system) folders such as My Computer.
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The Select Folder dialog box is available in many areas, such as the System Options -
File Locations dialog box when you click Add and in the Design Library when you click

Add File Location .
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4
Installation

This chapter includes the following topics:

• Installation Manager
• Previous Toolbox Detected When Installing or Upgrading
• Uninstall Completes Even When DLLs Cannot Be Unregistered

Installation Manager
The following products are available in the Installation Manager:

• SOLIDWORKS PCB and SOLIDWORKS PCB Services

SOLIDWORKS PCB is part of the Individual installation. On the Serial Number page,
you must enter a serial number for SOLIDWORKS PCB in the Electrical Design section.

SOLIDWORKS PCB Services is part of the Server installation. On the Welcome page,
select Install SOLIDWORKS PCB Services on this computer. SOLIDWORKS PCB Services
requires you to assign a port number. The default port number is 9780.

• SOLIDWORKS Visualize and SOLIDWORKS Visualize Boost

Both products can be installed as part of the Individual installation. For more
information about the Visualize products, see the SOLIDWORKS Visualize section.

Previously, you could only install these products from separate installation packages.

Previous Toolbox Detected When Installing or
Upgrading

If you are upgrading to SOLIDWORKS 2017 or installing SOLIDWORKS 2017 side-by-side
with an earlier major version, the Installation Manager prompts you to decide how to
handle your existing Toolbox/Hole Wizard data.

You can choose to:

• Create a new SOLIDWORKS 2017 Toolbox.
• Use an existing Toolbox with SOLIDWORKS 2017. If the existing data is an older
version, it will be upgraded in-place.

• Create a copy of the existing Toolbox/Hole Wizard and upgrade the copy to 2017. This
option allows you to use a copy for the newer version of the data while preserving the
original for use with earlier versions.
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In previous versions, users had to manually copy their Toolbox folders to preserve the
older Toolbox/Hole Wizard data.

Uninstall Completes Even When DLLs Cannot Be
Unregistered

You can uninstall the SOLIDWORKS software even if some DLLS cannot be unregistered.
At the end of the uninstall process, a dialog box lists which DLLs failed to unregister.
Typically, no further action is necessary.

Previously, uninstalling SOLIDWORKS failed if one or more DLLs could not be unregistered.
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5
Administration

This chapter includes the following topics:

• Pack and Go Improvements
• Preventing Users from Changing System Options
• Reliability Report and Reboot Check in SOLIDWORKS Rx
• Repairing Corrupted Files
• Running Selected Simulation Studies in Task Scheduler

Pack and Go Improvements
If the Flatten to single folder option is not selected, Pack and Go now uses short,
relative folder paths.

Previously, the entire path was used causing problems with the Windows 256 character
limit.

The state of checkboxes in Pack and Go are now also retained. Previously, all checkboxes
were cleared each time you ran Pack and Go; the software required that you check them
again.

To access Pack and Go, in SOLIDWORKS, click File > Pack and Go.

Preventing Users from Changing System Options
You can use the Settings Administrator Tool to set system options that are applied when
deploying or upgrading the SOLIDWORKS software, and to prevent users from changing
those options. This tool replaces the Copy Settings Wizard for deploying settings, although
that wizard is still available for copying settings.

You can start with:

• The default set of options for that release of SOLIDWORKS.
• Options previously applied on that computer.
• Options specified in an existing .sldreg or .sldSettings file.

Two columns of check boxes let you select which of these options to apply, and which of
the applied options to lock so users cannot change them.

When users access the System Options dialog box, the locked options appear unavailable

with a lock icon . However, you can create a password that allows users to unlock
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options. When users hover over a locked option, a tooltip displays your name and email,
so they can contact you and request that password.

You select whether the system options apply only the first time a user starts the software,
or every time the SOLIDWORKS software starts, and whether customizations apply at
the same time. You also select whether the options remain locked when users cannot
access the network location with the .sldSettings file where the lock definitions are
stored.

The Settings Administrator Tool is installed with a SOLIDWORKS administrative image.
You can run the tool from the location where you stored the image.

The Settings Administrator Tool is stored in the following default location: C:\SolidWorks
Admin\SOLIDWORKS <version>\64bit\SOLIDWORKS\Program Files
64\SOLIDWORKS\sldSettingsAdmin.exe.

Reliability Report and Reboot Check in SOLIDWORKS
Rx

SOLIDWORKS Rx provides more data about events causing SOLIDWORKS to terminate
on your machine. This information can help you or your VAR diagnose the root cause of
any persistent reliability problem.

The Diagnostics tab displays the time since the last reboot and whether a reboot is
pending.

The Reliability tab includes a chart listing sessions that have terminated in the past 60
days. The chart indicates whether a session ended normally or with a crash. For crash
events, the call stack displays, along with a count of how many times that call stack
appeared during the past 60 days. The Reliability tab also displays Windows events for
the five minutes preceding each crash, including session termination and installation
events.

When you generate a SOLIDWORKS Rx zip file, information from the Reliability tab is
automatically included in the zip file, so you can share this information with your VAR.

To access the tabs in SOLIDWORKS Rx, from the Windows Start menu, click All
Programs > SOLIDWORKS version > SOLIDWORKS Tools > SOLIDWORKS Rx.

Repairing Corrupted Files
The SOLIDWORKS software provides an option for repairing corrupted files. The auto
repair function attempts to identify which segments are damaged from the corrupted files
and removes them if possible.

When you encounter a file that is corrupted, a dialog box asks if you want to repair the
file. If you answer Yes, the software automatically copies the corrupted file and attempts
to repair the copied file rather than work on the original. If the copied file opens, the
software notifies you that the repair is successful and reports which segment of the
damaged file was removed and the impact that the segment has on the file. You can then
save the repaired file if the result is acceptable.

Assemblies or drawings which reference damaged parts will open without the part files.
To repair these files, you must open the parts in their own window. The original assembly
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or drawing remains unchanged by the repair process. After the repair, you can substitute
the repaired files for the original damaged files.

If a file fails to open or the result is not acceptable, you should retrieve a recent back up
of the file. If a back up is not available or if file damage is a repeated problem, contact
your local support representative for assistance.

Running Selected Simulation Studies in Task
Scheduler

In the Update Simulation task, you can specify selected simulation studies to run for
a file or file type. Previously, you had to run all studies for a file or file type.

To access simulation studies in Task Scheduler, from the Windows Start menu, click All
Programs > SOLIDWORKS version > SOLIDWORKS Tools > SOLIDWORKS Task
Scheduler > Update Simulation.
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6
Assemblies

This chapter includes the following topics:

• Assembly Performance Improvements
• Automatic Browsing when Inserting Components
• Disabling Previews of Hidden Components
• Facility Layout
• Support for Path Mates
• Grouping Components
• Improved Shortcut Menu for Configurations
• Loading Documents in Memory Only
• Mate Controller Enhancements
• Mates
• Options to Improve Performance in Large Assembly Mode
• Preserving Drawing References
• Searching for Externally Referenced Documents
• Sorting Components by Their Opening Time
• SpeedPak Enhancements
• Treehouse Improvements

Assembly Performance Improvements
Assembly performance has improved when you drag components, rebuild assembly
features, and show hidden components.

• Dragging components. In assemblies that contain hundreds or thousands of mates,
the performance when you drag components is faster and smoother. Additionally,
performance when dragging components in an assembly that has a center of mass
feature is improved. After you drag the components, you need to update the center

of mass. Click Rebuild (Standard toolbar) or Edit > Rebuild.
• Rebuilding assembly features. Performance while rebuilding assembly features has
improved.

• Showing hidden components. In large assemblies, when you use Show Hidden
Components to toggle the display of shown and hidden components, the time to
complete the process is reduced.
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Automatic Browsing when Inserting Components
When you create a new assembly or open the Insert Components PropertyManager and
no components are available under Open documents, the Open dialog box opens
automatically so that you can browse for components to insert.

Previously, you had to click Browse to open the dialog box.

To disable this behavior for the Begin Assembly PropertyManager, clear the Automatic
browse when creating new assembly option.

Disabling Previews of Hidden Components
You can turn off the functionality that causes previews to appear when you select hidden
components in the FeatureManager design tree.

The previews can cause performance issues in large assemblies, especially when previewing
complex components.

To turn off the preview behavior, click Tools > Options > System Options >
FeatureManager and select or clear Enable preview of hidden components.

Facility Layout
You can use special tools and workflows when you work with very large models such as
plant layouts.

You can define connection points and a ground face in part and assembly models and
publish the models as assets. When you insert an asset into an assembly, magnetic mates
snap the asset into position relative to other assets.

You can create a SpeedPak configuration of an asset directly in the Asset Publisher
PropertyManager. Using SpeedPak configurations can greatly enhance performance,
especially in very large assemblies. However, you cannot use entities from an existing
SpeedPak when creating an asset.

Publishing an Asset
You can publish a model as an asset. You define connection points that enable the asset
to snap into position relative to other assets in an assembly. Optionally, you define a
ground plane, and you can create a SpeedPak configuration.

To publish an asset:

1. In a part or assembly, click Tools > Asset Publisher.
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2. (Optional.) In the Asset Publisher PropertyManager, under Ground Plane, set the
following:

DescriptionOption

Defines which face of the model to attach to the ground
plane when you insert the asset into an assembly. Select
a model face.

Ground Plane

(Optional.) Defines the offset distance for the selected model
face from the ground plane. Enter a value.

Ground Plane
Distance

(Optional.) Controls the alignment of the ground face

relative to the ground plane. Click Reverse Direction ,
or click the handle in the graphics area.

Reverse Direction

3. Under Connecting Points, set the following:

DescriptionOption

Defines the name of the connecting point you are creating.
Enter a name or use the default.

Connect Reference
Name

Defines a point for snapping to other assets in an assembly.
Based on your selection the point is positioned as follows:

Point PositionSelection

Connect Point

At the vertexVertex

At the midpointLinear edge

At the center pointCircular edge

Defines the direction in which to snap when you drag the
asset near another asset's connection point in an assembly.
Select a face.

Connect Direction

4. Click Add Connector.

The connection point and direction are indicated on the model.

5. Repeat steps 3 and 4 to add more connection points.
6. (Optional.) Under Option, select Create SpeedPak.

A SpeedPak configuration is created as a child of the original configuration. No
components appear in the FeatureManager design tree. In the graphics area, when
you move the pointer over the asset, only the connection points, their direction faces,
and the ground face are visible in the region surrounding the pointer.

7. Click .
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Defining a Ground Plane
You can define a ground plane in an assembly. When you insert a published asset into
the assembly, the asset's ground face snaps to the assembly's ground plane.

To define a ground plane:

1. In an assembly, click Insert > Reference Geometry > Ground Plane.
2. In the PropertyManager, in Ground Plane, select a face in the assembly.

3. (Optional.) Click Reverse Direction , or click the handle in the graphics area.

4. Click .

Ground Plane appears in the FeatureManager design tree. When you insert an
asset, the asset's ground face snaps to the assembly's ground plane.

Using Magnetic Mates
In this exercise, you publish two models as assets by setting their ground planes and
adding connecting points for the magnetic mates. Then, in an assembly, you create a
ground plane and insert the assets into the assembly. Finally, you use magnetic mates
to connect the assets.

Publishing the First Asset
In this step, you use a straight train track to define the ground plane and add connection
points for the magnetic mates.

To publish the first asset:

1. Open drive letter:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS
2017\whatsnew\assemblies\straight_track.SLDPRT.

2. Click Tools > Asset Publisher .
3. In the graphics area, select the face shown for Ground Plane.
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4. Select the edge shown for Connect point under Connecting Points.

When you select a linear edge, the midpoint is chosen.

5. Select the face shown for Connect direction.

You can improve workflow by right-clicking in the graphics area.

6. Right-click to add the connector to Connecting Points or click Add Connector.

7. Rotate the part and select the edge shown for Connect point.
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8. Select the face shown for Connect direction.

9. Click Add Connector.

10. Click .

The FeatureManager design tree updates to include Published References containing
Ground Plane, Connector1, and Connector2.

Publishing the Second Asset
In this step, you use a curved train track to define the ground plane and add connection
points for the magnetic mates. Additionally, you select a different configuration.

To publish the second asset:

1. Open drive letter:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS
2017\whatsnew\assemblies\turn.SLDPRT.

2. Click Tools > Asset Publisher .
3. In the graphics area, select the face shown for Ground Plane.

39

Assemblies



4. Select the edge shown for Connect point under Connecting Points.

5. Select the face shown for Connect direction.

6. Right-click to add the connector to Connecting Points.

7. Rotate the part and select the edge shown for Connect point.
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8. Select the face shown for Connect direction.

9. Click Add Connector.

10. Click .

The FeatureManager design tree updates to include Published References containing
Ground Plane, Connector1, and Connector2.

Creating a Ground Plane
In this step, you use an assembly that will be the floor for the train tracks and define its
top face as the ground plane.

To create a ground plane:

1. Open drive letter:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS
2017\whatsnew\assemblies\playground.SLDASM.

2. Click Insert > Reference Geometry > Ground Plane .
3. In the graphics area, click the top face for Ground Plane.

4. Click .

The FeatureManager design tree updates to include Ground Plane.
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Inserting the Assets into the Assembly
In this step, you insert the train tracks into the floor assembly and select an alternate
configuration.

To insert the assets into the assembly:

1. Click Insert Components (Assembly toolbar) or Insert > Component > Existing
Part/Assembly.

2. In the PropertyManager, in Open documents, select straight_track and drag the
pointer with the attached track to the graphics area as shown.

3. Click to place the track on the floor.

The track mates to the floor because ground mates are included.

4. In the PropertyManager:
a) In Open documents, select turn.
b) Under Configuration, select 0 (U turn).
c) Drag the pointer with the attached track to the graphics area as shown, but do

not release it.
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5. Drag the curved track toward the straight track and notice the magnetic mate snap
line that appears as you drag the curved track closer to straight track.

If you release the curved track when the snap line is displayed, the tracks will mate.

6. Click to release the curved track so that it snaps to the straight track.

Magnetic Mates Toy Chest
Use this set of toy train components to experiment with magnetic mates.

In addition to the straight and curved tracks that you use in the magnetic mates example,
there are additional parts and assemblies you can use to try the magnetic mates
functionality. These components are located in drive letter:\Users\Public\Public
Documents\SOLIDWORKS\SOLIDWORKS 2017\whatsnew\assemblies\.

File NameDescriptionComponent

straight_track.SLDPRTStraight track

Configurations: 50, 100,
150, 200, 250, 300
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File NameDescriptionComponent

turn.SLDPRTCurved track

Configurations: 90º,
120º, U turn

station.SLDPRTStation

bridge.SLDPRTBridge

cross.SLDPRTCross track

playground.SLDASMPlayground

bridgelayout.SLDASMBridge layout

Support for Path Mates
Path mate (Distance Along Path, Percent Along Path) is now a supported mate type.

The Mate Controller does not support path, width, or slot mates created with the Free
constraint.
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Grouping Components
In the FeatureManager design tree, you can automatically group the same components
with the same configuration into a folder-like structure.

Grouping can greatly condense the length of the FeatureManager design tree and make
it easier to find components, especially in large assemblies.

In the FeatureManager design tree, right-click the top-level assembly and click Tree
Display > Group Component Instances.
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Grouped componentsUngrouped components

Improved Shortcut Menu for Configurations
In the ConfigurationManager, when you right-click the top node of a part or assembly,
the shortcut menu lists only the most commonly used tools. Unnecessary tools have been
removed.

The following tools are displayed:

• Add Configuration…
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• Configuration Publisher
• Purge Unused Features
• Comment
• Tree Display
• Tree Order
• Collapse Items
• Customize Menu

Loading Documents in Memory Only
You can load referenced documents in memory only, rather than opening them in separate
windows.

The option, Load documents in memory only, lets you keep references up to date
without opening windows for documents that you do not need to see. This option is useful
when you open an assembly containing many component parts that have external
references.

Click Tools > Options > System Options > External References and select Load
documents in memory only.

Mate Controller Enhancements

Creating Configurations from Positions
You can create a configuration from a position using the Mate Controller.

This example uses a path mate as the mate type.

To create configurations from positions in Mate Controller:

1. Open drive letter:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS
2017\whatsnew\assemblies\mate_controller\path_mate_config.sldasm.

2. Click Mate Controller (Assembly toolbar) or Insert > Mate Controller.

3. In the PropertyManager, under Mates, click Collect All Supported Mates .
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4. Leave Position 1 at 0.00mm and click Add Configuration .

Add Configuration automatically adds the model to the ConfigurationManager,
without you having to add more information.

5. Add Position 2 by doing the following:
a) In PathMate1, enter 70.00mm.

b) Under Mate Positions, click Add Position and click OK.

c) Click Add Configuration .

6. Add Position 3 by doing the following:
a) In PathMate1, enter 140.00mm.

b) Under Mate Positions, click Add Position and click OK.

c) Click Add Configuration .
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7. Adjust Position 2 by entering 80.00mm and click Add Configuration .
8. In the Mate Controller Notification dialog box, click Update.

Updates automatically propagate in the ConfigurationManager.

9. Click .

Mates

Better Component Placement While Mating
When adding concentric or coincident mates to components that have all degrees of
freedom unconstrained, components are placed in more logical positions on the screen
and relative to other components.

In previous releases, the coincident or concentric mate was added correctly, but one
component was often placed off screen or hidden behind or within other components.
Then, to continue your work, you needed to zoom in and out, rotate the view, or hide
other components.

In SOLIDWORKS 2017, to improve the placement of the components being mated, the
mate software takes into account where you click on each of the components to mate.
The components are placed so that those clicked regions are near each other. The software
also avoids or minimizes interference with other components.

Distance Mates to Cylindrical Components
When you add a distance mate between two cylindrical faces, four options are available
for placement of the distance.

The new options are also available when you add a distance mate between a cylindrical
face and an axis, edge, line, vertex, or point.

Initially, the default option is Center to Center. Subsequently, the software remembers
your last used option from session to session.

Previously, the specified distance was applied at the minimum distance between the
cylinders and no other options were available.

The distance placement options include the following:

Applies the distance between the cylinder axes.Center to Center
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Applies the distance where the cylinders are closest to each
other.

Minimum
Distance

Applies the distance where the cylinders are farthest from
each other. This option is not available if the distance is
less than the sum of the radii of both cylinders.

Maximum
Distance

Applies the distance to the combination of conditions you
select. Specify a condition for each cylinder:

• Center
• Min
• Max

For example, you can select Center for the cylinder on the
left and Min for the cylinder on the right.

The lower limit for the applied distance is calculated based
on the selected options.

The applied distance has a lower limit
that is equal to the radius of the
cylinder that has Max selected.

Max and Center

The applied distance has a lower limit
that is equal to one of the following
radii:

Max and Min

• Max radius minus the Min radius
if the Max radius is greater than
the Min radius

• Min radius

CustomDistance
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Driven Mate Dimensions
You can set mate dimensions as driven, so that the value is influenced by other moving
components in the assembly.

By default, mate dimensions are driving dimensions. For the following mate types you
can change the dimensions to driven:

• Distance and distance limit
• Angle and angle limit
• Width (Distance and Percentage options)
• Slot (Distance and Percentage options)
• Path (Distance and Percentage options)

To use driven mate dimensions:

Do one of the following:

• In the graphics area, right-click the mate dimension and click Driven.
• In the FeatureManager design tree, in the Mates folder, right-click the mate and
select Driven.

• In the graphics area, select the mate dimension. Then in the PropertyManager, on
the Other tab, select Driven.

You can change the mate dimension back to driving by repeating one of the methods
above and clearing Driven.

Over Defined Mates
The dialog box for over defined mates has been redesigned for ease of use.

The options in the dialog box are better defined so you know exactly how the mate will
behave:

• Add this mate and break other mates to satisfy it
• Add this mate and over define the assembly

If you press ESC, the mate is not created.

Options to Improve Performance in Large Assembly
Mode

When you are working on large assemblies, you can select system options that reduce
the number of rebuilds and other time-consuming operations.

Suspend automatic rebuild
You can control the existing option, Suspend automatic rebuild, for Large Assembly
Mode (LAM).

To suspend automatic rebuilds for LAM:

1. Click Tools > Options > System Options > Assemblies.
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2. Under When Large Assembly Mode is active, select Suspend automatic rebuild.

Verification on Rebuild
You can control the existing option, Disable verification on rebuild, for LAM.

To disable verification on rebuild for LAM:

1. Click Tools > Options > System Options > Assemblies.
2. Under When Large Assembly Mode is active, select Disable verification on rebuild.

Maximum Time to Update Center of Mass and Equations
In an active assembly, operations for the center of mass and equations linked to mass
properties are updated only when they take 0.5 seconds or less. If the update takes more

than 0.5 seconds, the center of mass and equations are marked with , and are not
updated until you initiate a rebuild manually.

Preserving Drawing References
Drawing references (such as dimensions, notes, and annotations) are maintained when
you replace a subassembly with a multibody part created from the subassembly.

Searching for Externally Referenced Documents
When you open assembly or drawing documents, new search options provide more control
over where the software searches for missing referenced documents.

The options also help to reduce the opening time by reducing the number of folders to
be searched.

To search for externally referenced documents:

1. Click Tools > Options > External References.
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2. Under Search external references in, select or clear options.

DescriptionOption

Searches for missing referenced documents in the
Referenced Documents folders specified in System
Options > File Locations.

Otherwise, the standard recursive search routine is used.

ReferencedDocuments
specified in File
Locations

Searches subfolders of the
Referenced Documents
folders.

Include

Blocks the software from
searching open folders and
folders where you have
recently saved items.

Exclude active folders
and recent save
locations

Opens the File Locations section of the Options dialog box.Go To Referenced
Documents

Sorting Components by Their Opening Time
A property stores the time taken to open each of an assembly’s components the last time
you opened the assembly. You access the property, SW-Open Time, in Assembly
Visualization.

The property shows you which components take the longest to open. You could then
simplify or remove those components to decrease the time needed to open the assembly.

To sort components by their opening time:

1. In an assembly, click Assembly Visualization (Tools toolbar) or Tools >
Evaluate > Assembly Visualization.

2. On the Assembly Visualization tab , click the arrow to the right of a column header.
3. On the flyout list, click More.
4. In the Custom Column dialog box, in Properties, select SW-Open Time.
5. Click OK.

SW-Open Time becomes the column header, and the opening time for each
component appears.

6. Click the column header to sort the components by opening time. Click again to
reverse the sort order.
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SpeedPak Enhancements
You can include reference geometry and curves in a SpeedPak. You can select sketches
from any level of the assembly to include in a SpeedPak.

Previously, all top-level unabsorbed sketches were included in the SpeedPak. You had to
suppress top-level sketches that you wanted to exclude, and you could not select sketches
in subassemblies.

To include reference geometry and sketches in a SpeedPak:

1. Open drive letter:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS
2017\whatsnew\assemblies\speedpak\gearbox.sldasm.

2. On the ConfigurationManager tab, right-click the Default configuration and click
Add SpeedPak.
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3. In the graphics area, select the four faces shown for Faces to Include .

Three of the faces are on the SHAFT - DRIVE component.

4. In the PropertyManager, under Include, click in Reference Geometries, Sketches,

and Curves to Include .
5. In the graphics area, select the Axis of Rotation, Lube Only text, and Lube Arrow

sketch shown.

6. In the PropertyManager, under Options, select Remove ghost graphics.
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7. Click .
The sketches and axis are included in the SpeedPak.

Treehouse Improvements

Including Drawings When Importing Structures
When you import a structure into Treehouse, you can also import any associated drawing
files.

To include drawings when importing structures:

1. In Treehouse, click Treehouse Options.
2. In the dialog box:

a) Under Import options, select Import drawings with models.
b) Under Search in folder locations, click Add, browse to a folder, and click OK.
c) Click OK.

The next time you import a Treehouse structure that contains a drawing, the drawing
node is included in the structure.

Opening Structures in Microsoft Excel
You can open Treehouse structures in Microsoft Excel. This helps you to use a spreadsheet
to capture the parts and assemblies that comprise a model.

To open structures in Microsoft Excel:

1. Open a structure in Treehouse.

2. Click Open in Excel .
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3. In the dialog box, select an option:

• Open Structure. Opens the entire Treehouse structure in Microsoft Excel. Parts
and assemblies appear in an indented list.

• Open Parts Only. Opens only parts from a Treehouse structure in Microsoft Excel.

4. Click OK.

Microsoft Excel opens with a spreadsheet of the entire structure or parts. The columns
included in the spreadsheet are Document Name, Active Configuration, and
Quantity. Each file property is displayed in its own column. The Quantity value for
duplicate parts is shown for each instance in the structure.

Printing Structures
You can print Treehouse structures on paper or to PDF.

In Treehouse, click Print and set options in the dialog box. The system prints to the
extents of the structure.

User Interface
User interface improvements include:

• Redesigned interface consistent with the SOLIDWORKS software user interface.

• Removed animations when you click Show Document Properties on a node.

• Changed icons for drawings. Click to minimize a drawing. Previously you had to click
to minimize display of a drawing in the structure. This icon change eliminates

confusion about what happens to the drawing reference.
• Editable document names in the structure. Double-click any document name to edit
the text. Previously you had to click Show Document Properties to change a
document name.
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7
SOLIDWORKS Composer

This chapter includes the following topics:

• SOLIDWORKS Composer
• SOLIDWORKS Composer Player

SOLIDWORKS Composer
SOLIDWORKS® Composer™ software streamlines the creation of 2D and 3D graphical
contents for product communication and technical illustrations.

Advanced Features Available in Composer Built-in Samples
Advanced features are available in Composer built-in samples without the Player Pro
license.

A Composer Player Pro license is necessary to use advanced features in published
Composer files. However, if you are using a Composer built-in sample, advanced features
are now available even without the Player Pro license. When opening a Composer HTML
file without a Player Pro license, an information message appears to inform you about
this. See About the HTML Output in the Composer help.

Enhancement of Translate and Scale Motions
The Translate and Scale motions of the Animation Library workshop have been enhanced
to support mirroring of animations.

See Animation Library Workshop in the Composer help.

Mirror Animation
You can now mirror animations.

Technically, this reproduces in inverted order the keys of selected animation blocks. For
example, mirroring a Screw step creates an Unscrew step. See Creating Pre-defined
Animations and Custom Animation XML Example in the Composer help.
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ProfilesLoadOnDemand
This new advanced preference lets you specify whether workshop profiles should be loaded
on demand, or all at once.

Loading profiles on demand only can be useful when many profiles are defined, or for
profiles stored on a network. See Advanced Settings in the Composer help.

Loading of profiles on demand was the existing behavior for all workshops that use
profiles, except for the Technical Illustration and the Styles workshops (for which all
profiles used to be loaded when selecting one in the Profile list). This new preference
makes the loading of profiles homogeneous throughout all workshops.

Sorting Profiles Alphabetically or By Category
Two new options are now available for workshop profiles.

You can specify whether profiles should be sorted alphabetically or by category of location,
that is Composer default path profiles, user-defined path profiles, or other path profiles
(such as network locations). See About Profiles for Workshop Settings in the Composer
help.

SOLIDWORKS Composer Player

Advanced Features Available in Composer Built-in Samples
Advanced features are available in Composer built-in samples without the Player Pro
license.

A Composer Player Pro license is necessary to use advanced features in published
Composer files. However, if you are using a Composer built-in sample, advanced features
are now available even without the Player Pro license. When opening a Composer HTML
file without a Player Pro license, an information message appears to inform you about
this. See About the HTML Output in the Composer help.
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8
SOLIDWORKS Costing

This chapter includes the following topics:

• Bounding Box Nesting Preview for Last Sheet
• Feature Recognition for Operations
• MySOLIDWORKS Costing Template Integration
• Rules-based Costing for Parts
• Subassembly Costing
• Template Enhancements
• Time-based Support for Costing

SOLIDWORKS Costing is available in SOLIDWORKS Professional and SOLIDWORKS Premium.
Costing for assemblies is only available in SOLIDWORKS Premium only.

Bounding Box Nesting Preview for Last Sheet
You can view the bounding box nesting layout on the last sheet when you have multiple
sheets in the lot and you can change between the first and last page. You can also resize
and scale the Bounding Box Nesting Preview while maintaining the original aspect ratio.

To change between the first and the last page when you have multiple sheets, in Bounding

Box Nesting Preview , click First Page or Last Page.

Feature Recognition for Operations
The performance of feature recognition to handle special geometry cases is enhanced.
New tools and workflow improvements are introduced to streamline and speed up the
costing process.

The following new tools are added:

• Split operation. To split a coaxial hole, right-click the entity in the CostingManager
and click Split Operation.

• Combine operations. To rejoin split holes, right-click either of the resulting holes
generated from the Split Operation in the CostingManager and click Combine
Operations.

• Turning features. You can convert an ID Turn operation to a hole and automatically
assign threading operations if the information exists in the template. No Convert
operation is necessary.
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• Facing operation. You can convert a face mill operation to an end cutting operation for
block, cylinder, and plate stock bodies by right-clicking the entity and clicking the
option.

• Boring operation. You can right-click a Simple Hole to add a boring operation and
then select a tool.

Multi-selection capability is provided in the CostingManager for the following features and
operations in single body mode:

• Hole features. Convert to circular pockets, splitting hole chains, and Move To.
• Hole operations. Select tools for drill, counter-bore, counter-sink, tap operations, and
additional hole operations.

• Mill features. Convert to holes or volume features, and Move To.
• Mill operations. Select tools for mill operations, additional operations, and remove
additional operations.

• Volume features. Change machines, processing, convert to mill, drill, or turn tools,
and Move To.

• Volume operations. Select tools for drill, mill, or turn.
• Facing features. Convert facing to end cut features, and Move To.
• Facing operations. Select a common tool for facing operations.
• End cut features. Apply Run No Cost, Apply Cost Override, Edit Cost Override and
Remove Cost Override. Convert end cut features to facing features, and Move To.

• Machining Cut Path features. Apply Run No Cost, Apply Cost Override, Edit Cost
Override, and Remove Cost Override. Select cut path features and apply a cutting
machine.

• Sheet metal bend features. Select edge and hem bend and apply a cutting feature.
• Turning features. Select turning features and apply a machine, select ID turning features
and apply a drill tool, Move To.

You can add stock in X, Y and, Z directions of Plate stock body types similar to the Block
stock body type.

You can apply part settings for an assembly in the CostingManager instead of modifying
them in the Costing Task Pane.

Cost Estimation Progress Dialog Box Enhancements
You can view the Cost Estimation Progress dialog box while costing machining and sheet
metal parts. You can click Skip this part button in the Progress dialog box while costing
assemblies.

• Cost Estimation Progress dialog box and Cancel button. The Cost Estimation Progress
dialog box is available for single body parts. When a single body part is costed, you
can view the Cost Estimation Progress dialog box that includes a progress bar and
a Cancel button. You can use the Cancel button to abort the Costing process for a
single operation or multiple operations. When you cancel a process:

• The Task Pane and CostingManager remain active.
• You can return to the costing operation for the cancelled operation at a later stage.

• The canceling process for single body parts, multi-body parts, and assemblies is faster.
• Skip this part. This button is in the Cost Estimation Progress dialog box while costing
assemblies. You can use this to skip the costing process for time-consuming components
and move on to the next component in the queue. The skipped components remain
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uncosted with no cost value assigned. This button provides a convenient way to skip
or cancel one or more components as opposed to aborting the entire costing process
for the assembly.

MySOLIDWORKS Costing Template Integration
Manufacturers on the MySOLIDWORKS Manufacturing Network can upload their sheet
metal templates so that users can access them in the SOLIDWORKS software. Users
seeking to cost their sheet metal parts can also view the manufacturer information and
contact them.

The Costing Task Pane for sheet metal is modified to include two new options under
Costing Template:

• Local. Displays templates saved on your system.
• MySolidWorks. Displays manufacturers' templates from MySolidWorks Manufacturing
Network.

Costing with Manufacturer Information on MySolidWorks
To cost with manufacturer information on MySolidWorks:

1. In a sheet metal part, in the Costing Task Pane, under Costing Template, click
MySolidWorks.

2. Under Manufacturer, select a manufacturer from the drop-down list.
3. Under Template, select a template from the drop-down list.
4. Click Begin Cost Estimation.

Rules-based Costing for Parts
You can customize machining and sheet metal templates to more accurately reflect the
manufacturing process for creating parts. You can use unique sheet metal rules, unique
machining rules, or common sheet metal and machining rules for handling special geometry
cases.

Previously, you could only customize machining templates for rules-based Costing.

You can use additional rules for machining and also customize sheet metal templates for
special geometry cases.

Common Rules for Sheet Metal and Machining Parts
The list of Rules visible under the Rules tab common to sheet metal templates and
machining templates are:

DescriptionOption

Sets a predefined cost for the chosen
material.

IF a material is chosen, THEN add a
cost
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DescriptionOption

Sets a cost as a percentage of the total,
material, or manufacturing cost for the
selected material.

IF a material is chosen, THEN add a
cost as % of calculated cost

Sets a markup/discount as a percentage of
the total or material cost for the selected
material.

IF a material is chosen, THEN add a
markup/discount to the total/material
cost

Sets a custom operation for the selected
material.

IF a material is chosen, THEN add a
custom operation

Sets a cost if the model weight is between
two predefined weight values.

IF model weight is a certain size, THEN
add a cost

Sets a cost as a percentage of the total,
material, or manufacturing cost, if the
model weight is between two predefined
weight values.

IF model weight is a certain size, THEN
add a cost as % of calculated cost

Sets a markup/discount as a percentage of
the total or material cost, if the model
weight is between two predefined weight
values.

IF model weight is a certain size, THEN
add a markup/discount to the
total/material/manufacturing cost

Sets a custom operation if the longest edge
of the stock machining bounding box (X, Y,
or Z axis) is between two predefined length
values.

IF the longest edge of the stock
bounding box is a certain size, THEN
add a custom operation

Sets a cost if the longest edge of the stock
bounding box (X, Y, or Z axis) is between
two predefined length values.

IF the longest edge of the stock
bounding box is a certain size, THEN
add a cost

Sets a cost as a percentage of the total,
material, or manufacturing cost, if the
longest edge of the stock bounding box (X,
Y, or Z axis) is between two predefined
length values.

IF the longest edge of the stock
bounding box is a certain size, THEN
add a cost as % of calculated cost

Sets a markup/discount as a percentage of
the selected total or material cost, if the
longest edge of the stock bounding box (X,
Y, or Z axis) is between two predefined
length values.

IF the longest edge of the stock
bounding box is a certain size, THEN
add a markup/discount to the
total/material cost

Sets a custom operation, if a part weight is
between two predefined values.

IF a part weight is between X and Y
Weight, THEN add a custom operation
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Unique Rules for Machining Templates
The list of Rules unique to machining templates are:

DescriptionOption

Multiplies the step-over percentage of
feedrate by a predefined value, if you select
a milling operation.

IF milling operation is selected THEN
multiply Step Over Percentage of
feedrate (f)

Performs an additional operation if a
DimXpert Hole tolerance is between two
predefined tolerance values.

If DimXpert Hole tolerance is in certain
range then add additional operation

Uses the plate stock body type if the
smallest dimension of a part bounding box
is less than a predefined weight value.

USE the plate stock body type IF the
bounding box is a certain size

Unique Rules for Sheet Metal Templates
The Rule unique to sheet metal template is:

DescriptionOption

Sets a bend setup operation from the
available bend setup operations for the part,
if its weight is between two predefined
values.

IF model weight is a certain size, THEN
use this bend operation

Subassembly Costing
While costing an assembly, you can either use a Flat Treemode or a Nested Treemode.
You can also cost subassemblies or apply purchased cost to them.

The two modes of Costing are:

Costs top assemblies without costing subassemblies. The Flat
Tree option costs assemblies as per the existing behavior.

Flat Tree

Costs the top assembly and its subassemblies or applies purchased
cost to subassemblies.

Nested Tree

With assembly costing, you can:

You can cost the assembly in Nested Tree mode and apply
cost overrides to individual subassemblies by using the

Apply Purchased Cost

option Use Purchased Cost on the shortcut menu. If you
apply purchased cost to any subassembly then all
components in this subassembly are greyed out in the
CostingManager.
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When you change the cost of a component having multiple
instances within or outside of subassemblies, the cost
change is applied across all instances in the assembly.

Apply component cost
changes to multiple
instances across the
whole assembly.

Costing preference. Following is the order of preference for Costing for an uncosted
assembly:

1. Custom property cost. If a custom property cost is defined for a subassembly or
component and the custom property is defined in the Costing template, then this cost
is considered over the cost defined in the template.

2. Calculated cost. If both, custom property cost and cost in template are not defined,
then the costs are calculated individually. If a subassembly is already saved with
Costing data, then saved cost is considered over other type of costs.

Options in CostingManager:

DescriptionOption

Applies cost defined in templateUse Cost from Template

Applies cost override on existing costUse Purchased Cost

Applies cost defined as a Custom Property.Use Custom Property Cost

Applies calculated cost of components and
subassemblies

Use Calculated Cost

Evaluating the Cost of Assemblies in Nested Tree Mode
To evaluate the cost of subassemblies in an assembly:

1. Open drive Letter:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS
2017\whatsnew\Costing\PunchingMachine\PunchingMachine.sldasm.

2. Copy the template Punch data.sldctc from \Users\Public\Public
Documents\SOLIDWORKS\SOLIDWORKS 2017\whatsnew\Costing\PunchingMachine
to C:\ProgramData\SOLIDWORKS\SOLIDWORKS 2017\lang\english\Costing
templates.

3. Click Tools > Options > File Locations and do the following:
a) Under Show folders for select Costing Templates from the drop-down list.
b) Click Add and provide the file path C:\ProgramData\SOLIDWORKS\SOLIDWORKS

2017\lang\english\Costing templates.

4. Click Tools > SOLIDWORKS Applications > Costing .
5. In the Costing Task Pane, under Costing Templates, in Main template, select the

template Punch data.
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6. Under Part List:
a) Click Nested Tree.
b) Select parts for:

• Costs to be calculated
• Cost Defined

You can view only parts and not assemblies in the above sections.

7. To set or change a predefined cost, select the part in Cost defined and type the
cost.

8. Under Toolbox Parts, select parts and set one of the following:

• Exclude. Excludes the selected bodies from cost calculations.
• Include. Includes the selected bodies for cost calculations.

9. Click Begin Cost Estimation.
10. Click Yes.

When you click Yes, the subassemblies that are saved with a cost calculated with
a flat tree method may change.

11. In the CostingManager, right-click the subassembly cost and click one of these options
on the shortcut menu:

• Use Cost from Template
• Use Purchased Cost
• Use Custom property Cost
• Use Calculated Cost

You can change between Use Cost from Template/ Use custom property Cost,
Use Purchased Cost and Use Calculated Cost options. If a custom property is
defined for a subassembly, then the option Use Cost from Template is not visible
on the shortcut menu.

The assembly cost is updated.

Template Enhancements

Microsoft Excel Template for Reports
You can customize the Costing Excel report template to rearrange the position of specific
input tags in the report. You can also create multiple Microsoft Word or Excel templates
and store them in one location.

Previously, you could customize only the Word report template. You can customize the
Excel report template and also add your own styling.

You can also:

• Select a template in the defined location from Report Options.
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• Open an Excel report template when:

• A Word report template is open.
• Another Excel template is open.
• Both Word and Excel templates are open.

Multi-quantity Quote Support in Report Templates
You can provide five alternate quantities of cost values in a Microsoft Excel or Word report
while costing a part to show the customer how the cost per part may reduce as the
manufacturing quantities are increased.

You can choose between two report types:

• Simple Estimate Report. Covers the following information:

• Model name
• Company information
• Quote information
• Estimated time per part
• Estimated cost per part
• Alternate quantities

• Detailed Report. Covers the information covered in a Simple Quote Report and also
the following:

• Cost breakdown
• Manufacturing cost breakdown - Setup Costs and Setup Operations Costs (parts
only)

• Setup operations (parts only)
• No cost features (parts only)
• Baseline sections (parts only):

• Manufacturing cost breakdown - Setup Costs and Setup Operations Costs
• Setup operations
• No cost features

Multiple Instances of the Costing Template Editor
You can open a second instance of the same template in the Costing Template Editor in
read-only mode.

Previously, you received a warning message if you tried to open another instance of the
same template in the Costing Template Editor.

This functionality is useful when you modify information in a tab in the Costing Template
Editor and you want to compare the information.

67

SOLIDWORKS Costing



Sorting Tables in the Costing Template Editor
You can sort tables alphabetically in the Costing Template Editor by clicking the column
headers once.

Previously you had to double-click column headers to sort the tables.

To sort tables in the Costing Template Editor:

1. In a sheet metal or machined part, click Costing (Tools toolbar) or Tools >
SOLIDWORKS Applications > Costing).

2. In the Task Pane, under Costing Template, click Launch Template Editor.
3. In the Costing Template Editor, click any tab with columns and click any column

header.

The table is alphabetically sorted according to the selected column.

Using Copy As and Modify in Costing Templates
You can use the Copy As and Modify tools for some Operations tabs in sheet metal and
machining templates, for copying and reusing multiple rows of information.

To access Copy As and Modify in Costing templates:

1. In a sheet metal or machining part, click Costing (Tools toolbar or Tools >
SOLIDWORKS Applications > Costing).

2. In the Costing Task Pane, under Costing Template, click Launch Template Editor.
3. In the Costing Template Editor, under Operations:

• For sheet metal parts, click Cut or Bend.
• For machined parts, click Cut, Mill, Drill, or Turn.

4. Select rows, right-click the selected rows and click Copy As or Modify.

You can manage options from the cell menus in the Operations tabs.

Time-based Support for Costing
You can switch to a time-based Costing method in the sheet metal template for the cut
operations. You have more flexibility for data input and you can also calculate the time
taken to manufacture a sheet metal part using the input parameters.
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9
DimXpert

This chapter includes the following topics:

• Creating Basic Size Dimensions
• General Block Tolerance
• Multiple Edge Selection
• Use of Reference Geometry with DimXpert Dimensions
• Using Datums in Auto Dimension Schemes
• Using Polar Dimension Schemes for Geometrically Toleranced Parts

Creating Basic Size Dimensions
You can create basic size dimensions manually.

To create basic size dimensions:

1. In a part, click Basic Size Dimension (DimXpert toolbar) or Tools > DimXpert >
Basic Size Dimension.

2. Select entities in the graphics area.
3. Place the dimension.
4. In the PropertyManager, set options.

5. Click .

General Block Tolerance
You can include a default tolerance for dimensions when insignificant decimal places are
not used to determine tolerance, such as when the unit of measure is metric.

To set the General Block Tolerance option:

1. In a part or assembly, click Tools > Options > Document Properties > DimXpert.
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2. Under Methods, select General Block Tolerance.
3. Under General block tolerance, set Length tolerance and Angle tolerance.
4. Click OK.

Multiple Edge Selection
You can create dimensions between two planes by selecting two edges when the
corresponding planes are parallel.

Use of ReferenceGeometry with DimXpert Dimensions
You can create DimXpert dimensions using reference planes, axes, points, and center of
mass symbols.
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Using Datums in Auto Dimension Schemes
The DimXpert Auto Dimension Scheme tool lets you select existing datums for the
reference features.

To use datums in Auto Dimension Schemes:

1. Click Auto Dimension Scheme (DimXpert toolbar) or Tools > DimXpert > Auto
Dimension Scheme.

2. In the PropertyManager, under Datum Selection, select the primary datum symbol
and optionally select the secondary and tertiary datum symbols to use when generating
geometric tolerances.

You can select existing datums.

3. Set options.

4. Click .
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Using Polar Dimension Schemes for Geometrically
Toleranced Parts

The DimXpert Auto Dimension Scheme tool supports polar dimensioning schemes.

To use polar dimension schemes for geometrically toleranced parts:

1. Click Tools > Options > Document Properties > DimXpert > Geometric
Tolerance.

2. In the dialog box, under Basic dimensions, select Create basic dimensions and
Polar.

3. Click OK.

4. Click Auto Dimension Scheme or Tools > DimXpert > Auto Dimension
Scheme.

5. In the PropertyManager, in Settings, under Pattern Dimensioning, select Polar.
6. Set options.

7. Click .
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10
Detailing and Drawings

This chapter includes the following topics:

• Dimensions
• Drawing Views
• Model Detailing
• Notes and Balloons
• Performance in Drawings
• Sheets
• Tables

Dimensions

Arc Extension Line or Opposite Side
The Arc extension line or opposite side setting lets you control the radial dimension
leader.

The Dimension to inside of arc option is removed from Witness/Leader Display on
the Leaders tab of the Dimension PropertyManager. It is replaced by Arc extension line
or opposite side, which lets you control the radial dimension leader:

• Where possible, it is applied to an arc extension line.
• If not possible, it is attached to the opposite side of the arc.

Arc extension line or opposite side
cleared

Arc extension line or opposite side
selected
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Changing the Origin Circle Size in DIN Ordinate Dimensions
You can control the origin circle size for ordinate dimensions when using the DIN standard.

To support the current DIN 406 standard and previous DIN standards, you can set the
origin circle size in ordinate dimensions.

SOLIDWORKS 2016SOLIDWORKS 2017

To change the origin circle size in DIN ordinate dimensions:

1. Open drive letter:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS
2017\whatsnew\drawings\knob-1.SLDDRW.

2. Select the ordinate baseline that contains the origin circle.

3. In the PropertyManager, click the Leaders tab.
4. Under Witness/Leader Display, click Size.
5. In the Circle Size dialog box, clear Use document size.
6. Type 5 for the diameter of the origin circle and click OK.

7. Click .

To set a document property for the origin circle size in a DIN ordinate dimension, click
Tools > Options > Document Properties > Dimensions > Ordinate and click Size.
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Dimension and Geometric Tolerances in General Tables
When linking the value of a dimension or geometric tolerance to a cell in a general table,
the dimension or geometric tolerance in the cell displays the same elements as the original
annotation, including tolerance, dual dimensions, and additional text.

Hole Callout Instance Count for Mirrored Holes
When you use the Hole Callout tool on a hole pattern that includes a mirror on the same
body, the instance count includes the mirrored holes.

SOLIDWORKS 2017

SOLIDWORKS 2016
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Short Leader Radius Dimensions
The Smart arrows attach to arcs and point away from dimension option supports
radial dimensions with short leaders.

To set the option, click Tools > Options > Document Properties > Dimensions >
Radius and under Arrow placement, select Smart arrows attach to arcs and point
away from dimension.

Tolerance Font Size
You can set the tolerance font size for individual dimensions using options in Text Font
on the Other tab in the Dimension PropertyManager.

Drawing Views

Creating Crop and Details Views with No Outline
Crop and detail views support no outline.

Crop view with no outline

Crop view with full outline
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Detail view with no outline

Detail view with full outline

To create a crop view with no outline:

1. In a drawing view, sketch a closed sketch profile, such as a circle.

2. Select the circle.
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3. Click Crop View (Drawing toolbar) or Insert > Drawing View > Crop.

4. Select the drawing view.
5. In the PropertyManager, under Crop View, select No outline.

6. Click .

Emphasizing Outlines
In section views, you can emphasize the outline of cut faces in compliance with ISO
128-50. Typically, this means setting the outline of the faces thicker than other model
lines in the section view.

Emphasizing the Outline in a Section View
To emphasize the outline in a section view:

1. Select a section view in a drawing.
2. In the PropertyManager, under Section View, select Emphasize Outline.

3. Click .
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Setting the Line Font for Emphasized Outlines
To set the line font for emphasized outlines:

1. In a drawing, click Tools > Options > Document Properties > Line Font.
2. In the dialog box, in Type of edge, select Emphasized Section Outline.
3. Set options.
4. Click OK.

Jagged Outlines
Crop and detail views support jagged outlines. Break views support jagged cut break line
styles.

Crop view with jagged outline

Detail view with jagged outline
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Break view with jagged cut

Creating Crop Views with Jagged Outlines
To create crop views with jagged outlines:

1. In a drawing view, sketch a closed profile for the crop view, for example, a circle.

2. Click Crop View (Drawing toolbar) or Insert > Drawing View > Crop.

The view outside the profile disappears.

3. Select the drawing view.
4. In the PropertyManager, under Crop View, select Jagged outline.
5. Under Shape Intensity, move the slider to define the intensity of the jagged outline.

6. Click .

Creating Detail Views with Jagged Outlines
To create detail views with jagged outlines:

1. In a drawing view, click Detail View (Drawing toolbar) or Insert > Drawing
View > Detail.

The Circle tool is active.
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2. Sketch a circle.

3. In the PropertyManager, under Detail View, select Jagged outline.
4. Under Shape Intensity, move the slider to define the intensity of the jagged outline.
5. Click to place the view.

Creating Break Views with Jagged Cut Break Line Styles
To create break views with jagged cut break line styles:

1. In a drawing view, click Break View (Drawing toolbar) or Insert > Drawing
View > Break.
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2. In the PropertyManager, in Break line style, under Break View Settings, click

Jagged Cut .

3. Under Shape Intensity, move the slider to define the intensity of the jagged cut.
4. Click to place the first break line.
5. Click to place the second break line.

6. Click .
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Mirror Drawing Views
You can display model, relative to model, and predefined drawing views as mirror views
without creating the mirror components. Projected and other derived views use the mirror
state from their parent view.

Original view

Mirror view
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To mirror drawing views:

1. In a drawing, select a model, relative to model, or predefined drawing view.
2. In the PropertyManager, under Orientation, select Mirror view.
3. Under Mirror view, select Horizontal or Vertical.

4. Click .

Scale Hatch Pattern
Scale Hatch Pattern is available for section views and drawing views that include
broken-out section views.

Scale Hatch Pattern clearedScale Hatch Pattern selected

When you select Scale Hatch Pattern in the Section View PropertyManager, hatches
within this view apply the view’s scale to the hatch pattern. Previously, only detail views
had this option.

Model Detailing

Custom Text Scale
You can set a custom text scale for text annotations in parts and assemblies.

To set a custom text scale:

1. Click Tools > Options > Document Properties > Detailing.

Alternatively, in the FeatureManager design tree, right-click the Annotations
folder and click Details to display the Annotation Properties dialog box

2. In the dialog box, clear Always display text at the same size.
3. In Text scale, select Custom.
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4. In the two fields, enter the first and second value of the custom scale. For example,
enter 3 and 10 to set the scale to 3:10.

Drawings Maintained When Parts are Converted
When you purge a part of its features using Convert to Bodies, the original drawing file
still references the part's geometry.

Managing Notes Areas
You can create multiple notes area annotation views in parts and assemblies, and you
can delete and rename notes areas. You can also specify which notes area to display
when opening the document.

The notes areas are placed in the Notes folder, which is under the Annotations
folder in the FeatureManager design tree. Multiple notes areas let you create various sets
of notes and place them on specific note areas that you can activate.

To create a notes area:

• In the FeatureManager design tree, in the Annotations folder, right-click Notes
and click Insert Notes Area.

A notes area is added to the Notes folder with a sequential number following the
name, for example, Note area3.

To delete a notes area:

• In the FeatureManager design tree, in the Annotations folder, right-click a Note
area and click Delete.

To rename a notes area:

1. In the FeatureManager design tree, in the Annotations folder, click-pause-click
the Note area to rename.

2. Type the new name.
3. Press Enter.

To specify a notes area to display when opening a part or assembly:

• In the FeatureManager design tree, in the Annotations folder, right-click the Note
area and click Show on Open.

To change the notes area to display on open, you must first clear the selected notes
area to display. Right-click the notes area and clear Show on Open.
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Reorder Annotation Views
Using drag and drop, you can reorder annotation views, and you can reorder notes area
annotation views within the Notes folder.

Notes and Balloons

Linking a Note to a Table Cell
You can link a note to the contents of any BOM or hole table cell.

To link a note to a table cell:

1. In a drawing with a table, insert a note.
a) Click Insert > Annotation > Note.
b) Click to place the note.
c) Click to edit the note.

2. In the PropertyManager, under Text Format, select Link Table Cell .
3. In the table, select a cell.

4. Click .

Because the note is linked to a table cell, when the cell value changes, the note updates.
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Linking Part Numbers in Drawings and the Property Tab Builder
You can create a note in a drawing that links to a part number. You can place this note
typically in the title block of a drawing sheet. You can also make a part number display
in the Property Tab Builder. When you click on a part or component of an assembly, the
part number appears in the Property Tab.

To create this note in a drawing sheet, in the Notes PropertyManager, under Text Format,

click Link to Property . Then in the Link to Property dialog box, for Property name,
select SW-BOM Part Number(BOM Part Number). If this note is in the title block,
when you update the part number in the drawing, the model automatically updates the
part number, and vice versa.

Previously, this feature was only available in balloons.

To display a part number in the Property Tab Builder, you need to add a textbox control
and set the value to SW-BOM Part Number. If you already have a template, you can
reference the file in Tools > Options > File Locations > Custom Property Files.

Location Label Zone
The Display zone of counterpart location label option displays the zone of the
counterpart location label of the associated parent or child view.

Location label displaying the zone of the associated view's centroid
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Location label displaying the zone of the counterpart location label of the associated
parent or child view

To set this option, click Tools > Options > Document Properties > Annotations >
Location Label and select Display zone of counterpart location label.

New Symbols for Tolerancing
New symbols are available for tolerancing.

To access the tolerancing symbols:

1. For parts, click Geometric Tolerance (DimXpert toolbar) or Tools >
DimXpert > Geometric Tolerance.

•

• For drawings, click Geometric Tolerance (Annotation toolbar) or Insert >
Annotations > Geometric Tolerance.

2. In the PropertyManager, under Text, click More.
3. In the Symbol Library, in Categories, select ISO Tolerancing.

New Tolerancing Symbols

Average sizeTwo-point size

Median sizeSpherical size

Mid-range sizeLeast-squares

Range of sizesMaximum
inscribed

Envelope requirementMaximum
circumscribed
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Free stateCircumference
diameter

Any cross sectionArea diameter

Specified cross sectionVolume diameter

Common toleranceMaximum size

Minimum size

To access the new modifying symbol, in the Symbol Library, in Categories, select
Modifying symbols.

New Modifying Symbol

Conical taper

Symbol Kern Spacing
BOUND is a control variable for symbols in the GTOL.SYM file. BOUND controls horizontal
spacing of a symbol within a row of text in notes and dimensions.

Performance in Drawings

Auto Insertion of Center Marks Optimization
Creating drawing views with auto insertion of center marks is optimized for performance.

Automatically Populate View Palette
You can use the Automatically populate View Palette with views option to control
whether time-consuming View Palette operations are initiated.

To turn off the automatic population of the View Palette, in Tools > Options > System
Options > Drawings, clear Automatically populate View Palette with views.
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Lightweight Drawing Open Time
The software no longer performs unnecessary operations associated with appearances
when opening a drawing as lightweight.

Sheets

Change Sheet Format for Multiple Sheets at the Same Time
You can set sheet properties, including sheet formats and zone parameters, for multiple
drawing sheets at the same time.

To change the sheet format for multiple sheets at the same time:

1. In the FeatureManager design tree, right-click a drawing sheet and click Properties.
2. In the Sheet Properties dialog box, on the Sheet Properties tab, click Select Sheets

to Modify.
3. In the Sheet Selection dialog box, select the sheets to change.
4. Click OK.
5. On the Sheet Properties and Zone Parameters tabs, set the properties.
6. Click Apply Changes.

Tables

Lock Column Width in Table Templates
Table templates properly store and apply the Lock Column Width setting for entire
tables and individual columns within a table.

Replaced Component Item Numbers in BOMs
When replacing one component with another in an assembly, in the BOM you can assign
a new item number to the replaced component while keeping it in the same row as the
removed component.

To assign a new item number to the replaced component and keep it in the same row,
in the Bill of Materials PropertyManager, select Keep Missing Item and Assign new
item number and do not keep replaced component.
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Retrieval of Sheet Metal Components on Drawings
In drawings, you can retrieve sheet metal information from the parent component in
mirrored or derived sheet metal components.

For example, if you create a drawing view of a mirrored sheet metal part, any forming
tools or library features in the mirrored part are available in punch tables.

When creating a derived part, you need to select Sheet metal information in the Insert
Part PropertyManager.
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11
eDrawings

This chapter includes the following topics:

• Opening Files as Read-Only
• Password-protected Files
• Supported File Types in eDrawings

eDrawings® Professional is available in SOLIDWORKS Professional and SOLIDWORKS Premium.

Opening Files as Read-Only
You can set an option to always open files in eDrawings as read-only.

In Tools > Options, on the General tab, select Open files read-only.

When selected, this option also selects the Open as read-only option in the Open dialog
box. Clearing the option in the Open dialog box does not affect the option in the Options
dialog box.

Password-protected Files
The free version of eDrawings supports password-protected files.

When you publish an eDrawings file from your CAD application, you can assign a password
to protect the eDrawings file. Previously this functionality was limited to eDrawings
Professional.

Supported File Types in eDrawings
eDrawings supports additional file types.

Additional file types you can open in eDrawings include:

• STEP AP242
• IGES
• CATIA® V5
• Autodesk® Inventor™

• 3DXML
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12
SOLIDWORKS Electrical

This chapter includes the following topics:

• Associating a Data File Shortcut to a Project
• Associating External SOLIDWORKS Assemblies
• Automatically Update Project Level Reports
• Copying and Pasting with Anchor Points
• Creating Links in Design Rule Check Reports
• Changing Attribute Visibility
• Creating Cable Mark Formulas
• Importing and Exporting Drawings with Microsoft Excel
• Mark Wires with the Same Value as I/O Address Connected
• Other Enhancements for SOLIDWORKS Electrical
• Properties Panel Graphical Enhancement

SOLIDWORKS Electrical is available as a separately purchased product.

Associating a Data File Shortcut to a Project
You can maintain folder structures according to your company standards by creating
shortcuts to data files inside the SOLIDWORKS Electrical project folders.

When you associate an external data file, a shortcut is added in the document tree and
project folder. The shortcuts created in the SOLIDWORKS Electrical project folders let
you maintain company folder structures. The data files are not copied to the project folder.

To associate a data file shortcut to a project:

1. Do one of the following:

• Right-click Document book > New and click Data file shortcuts .

• Click the Project tab > New and click Data file shortcuts .

2. In the dialog box, select one or more files to add to the project.

The software creates a shortcut in the document tree and project folder. If you delete
the data file shortcut, the shortcut is removed from the project, and the data file
remains untouched in its current location.
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3. Do one of the following:

• Double-click the shortcut to open it.

• Right-click the shortcut and click Properties . The target file has an internal ID
name; the path is grayed out in the property dialog boxes and cannot be changed.

If you move the target file, the database path updates. When you include shortcuts
in an archive, the file targeted is copied into the project folder and the existing link
is replaced.

Associating External SOLIDWORKS Assemblies
You can add existing SOLIDWORKS assemblies to SOLIDWORKS Electrical projects and
create shortcuts to the files in the SOLIDWORKS Electrical project folder.

When you associate external assemblies, the software creates a shortcut to the assembly
in the document tree, the SOLIDWORKS Electrical project folder, and the SOLIDWORKS
assembly dialog box. These shortcuts let you maintain company folder structures. The
associated files are not copied to the project folder.

The SOLIDWORKS cabinet layout tool in the Process tab is renamed to SOLIDWORKS
assembly.

To associate external SOLIDWORKS assemblies:

1. Click the Process tab and click SOLIDWORKS assembly .
2. In the dialog box, in Select existing file, select the assembly to add to the project.

A shortcut is created in the document tree and project folder.

3. After the associated assembly shortcut is created:

• Double-click the shortcut in the document tree to open it.

• Right-click the shortcut and click Properties . The external assembly file has
an internal ID name; the path is grayed out in the property dialog boxes and cannot
be changed.

If you move the external assembly file, the database path updates. When you
include shortcuts in an archive, the external assembly file is copied into the project
folder and the existing link is replaced.

Automatically Update Project Level Reports
When printing, exporting, or archiving reports and terminal strips, you can ensure that
the project data is up to date automatically.

Use Update generated drawings in the Projects configuration dialog box lets to
automatically update data in reports and terminal strip drawings before printing, exporting,
or archiving.
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To automatically update project level reports:

1. Click Project tab > Configurations > Projects .
2. In the dialog box, click the General tab > Options section.
3. From the Update generated drawings menu, select an option.

Processes reports, design rules, and
terminal strip drawings in the current
state. Any recently made changes might
be absent from the output.

Never

Displays a message with the following
options:

Updates all reports,
design rules, and
terminal strip
drawings before
running this
command.

Update drawings

Runs the command
without updating
drawings.

Continue action
without updating

Exits the current
command.

Cancel

Ask me (default)

Automatically updates the files before
processing the command (no message is
displayed).

Always

Copying and Pasting with Anchor Points
When copying a set of objects in a drawing, you can define an anchor or reference point
and use that reference point to paste the objects into a new drawing.

To copy and paste with anchor points:

1. Do one of the following:

• On the Edit tab, select Copy with insertion point .

• In the graphics area, right-click and click Copy with insertion point .
• Press Ctrl + Shift + C.

2. Select the objects to copy.
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3. To enter a reference point, do one of the following:

• Click a location in the graphics area to be the reference point. This sets the X and
Y coordinates and closes the dialog box.

• In Enter Coordinates, type the X and Y coordinates and click . On the Command

tab, click .

4. Open a drawing where you want to paste the contents.
5. Do one of the following:

• On the Edit tab, click Paste .

• Right-click in the graphics area and click Paste .
• Press Ctrl + V.

6. Position the pointer where you want to insert the content and click.

The content is inserted away from the pointer at the distance specified by the reference
point.

Creating Links in Design Rule Check Reports
You can navigate to any entity in the design rule check (DRC) reports or normal reports
using the Report Manager dialog box.

Contextual menus in the table cells of the Design rules and Report dialog box link to data
in the Report Manager.

To create links in design rule check reports:

1. Do one of the following on the Project tab:

• Click Configurations and select Design rule check or Report.

• Click Design rule check or Report.

You need to go to Project > Configuration > Design rule check or Report to access
all the reports, or go to Project > Design rule check or Report to access the selected
reports.

2. Select a particular report.
3. Click Properties.
4. On the Columns tab, click Go to link.
5. Select Field name and Link type from the list.

IDs under Field name correspond to the property for which you set the Go to link.

6. Click OK and Apply.
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7. In the Report manager, right-click in a cell to view the Go to link result(s).

LinkReport Entry

Links to the drawing.Document

Displays the component with links to the
component tree.

Displays all associated symbols with links
to the drawing.

Component

Links to the symbol in the drawing,
zooming around the symbol.

Symbol

Displays a line diagram, where reserved,
and links to the cable entity in the line
diagram.

Displays list of cable cores in the scheme
and links to the text entity in the scheme.

Cable

Links to text entity in the scheme.Cable core

Links to the start of the equipotential in
the scheme.

Equipotential

Displays the wire in the scheme and links
to the text entity.

Displays from and to symbols, and links
to symbols in the scheme.

Wire

No link.Wire style

Displays the referenced symbol and links
to the 2D footprint, wiring label, and 3D
component.

Manufacturer parts

No link.Harness

Changing Attribute Visibility
You can change the attribute visibility while defining or editing drawings symbols or title
blocks.

To change attribute visibility:

1. On the Documents browser tab, under Document book, right-click any document
and click Tittle block > Open.
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2. On the Edit title block tab, click Show attributes and select an option.
You can also access Show attributes by right-clicking a symbol in the graphics area
and clicking Symbol > Open symbol > Edit symbol > Show attributes.

Creating Cable Mark Formulas
You can define cable mark formulas through project configuration.

To create cable mark formulas:

1. On the Project tab, click Configurations and select Project.
2. In the dialog box, on the Font tab, click Edit formula to edit the cable mark formula.

You can type the formula under in Formula: Scheme cable core.

3. Click OK twice.

Importing and Exporting Drawings with Microsoft Excel
You can use the Excel Automation option to generate schematics automatically from a
Microsoft Excel file by adding data and macros.

The contents of the Microsoft Excel file needs to be in a specific SOLIDWORKS Electrical
format. The Excel Automation option lets you:

• Automatically create and insert a drawing from a Microsoft Excel file. You can redefine
any macros later.

• Provide information on where to insert macros. For example, you may want to insert
a macro in one or multiple drawings, or insert various macros in several drawings.

• Insert file and book descriptions, define the location and function of each macro.
• Define variables such as symbols or new marks. The respective properties of these
symbols or marks are part of the macros and are associated with the drawings.

To import or export drawings with Microsoft Excel:

1. Click Excel Automation (Export/Import toolbar).

Alternatively, you can click Excel Automation > Create new Excel file for
automation to open a template and make a new file.

2. In the dialog box, select the custom Excel file and click Open.
3. Select an option:

• Change book association. Creates a new association as mentioned in the selected
Microsoft Excel file. For example, if the Excel file creates a new location, a new
book is created and appears in the document tree. The drawings are associated
with the newly created book.

• Do not change book association. Keeps the association with the current book
in the project.

• Cancel. Exits the current command.

Selecting either of the first two options creates the drawings and displays a summary
dialog box.
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For additional information, see SOLIDWORKS Electrical Help.

Mark Wires with the Same Value as I/O Address
Connected

You can set the same values/tags between various connected objects like wire,
equipotentials; terminal and PLCs.

To set values, click Process > Propogate data to connected objects.

You can update these marks for the Whole project, Current book, Current scheme,
Current folder, Objects selected in the scheme, and Choose scheme.

Other Enhancements for SOLIDWORKS Electrical
For additional information on these enhancements, see SOLIDWORKS Electrical Help.

SOLIDWORKS Electrical enhancements include:

• You can use the Super Part tool to create catalog parts using several parts/assemblies
and several manufacturer parts.

• You can create the Super Part from the Manufacturer parts manager and add
properties/information from the properties dialog box. The Super Part is then added
to the database.

• Report enhancements:

• You can generate reports specific to each Project book.
• You can display the description of a wire group on top of the report table.
• You are notified to update outdated drawing reports when you print them.
• You can include the location and function descriptions in reports.
• You can use the '|' character as a line breaker in reports.

To access the line breaker click Project > Configuration > Report > Properties
> Layout.

• You can show connection dots on symbols as Always, Never, or only When
connected.

• You can view current, selected, and opened document highlighted in the document
browser.

Properties Panel Graphical Enhancement
The Graphical Properties tab shows the graphical properties of any CAD entity, symbol,
or wire element.

The Graphical properties tab in the Properties Panel lets you segregate the
contents of a selection. When you select a CAD entity, symbol, or wire element, all of its
associated properties are listed with its graphical entity.
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The Properties Panel is dockable on the side panels.

When you select a group of entities, all common properties are displayed. When you
select specific entities, the related properties are displayed. Uncommon properties are
hidden. Changing uncommon properties does not affect the CAD entity because it is driven
at the application level.

The Graphical properties tab includes:

DescriptionItem

Graphical properties tab in the Properties
panel.

1

Graphical icons corresponding to the listed
property.

2

Drop-down menu listing the segregate
contents or various entities of the selection,
letting you choose a group of objects to edit.

3

Tooltip information such as why some
properties are grayed out or cannot be
edited.

4
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13
SOLIDWORKS Flow Simulation

This chapter includes the following topics:

• Korean Language Support
• Multiparameter Optimization
• Postprocessing Performance
• Transient Simulation Performance
• Using Conditions from Low-level Components
• Mesh Settings for Flow Simulation

Available as a separately purchased product that can be used with SOLIDWORKS Standard,
SOLIDWORKS Professional, and SOLIDWORKS Premium.

Korean Language Support
SOLIDWORKS Flow Simulation is available in Korean.

Multiparameter Optimization
Multiparameter Response Surface-based optimization is added to the Parametric Study.

You can conduct an optimization study for more than one input variable. You can select
geometry or simulation parameters as variables.

The target optimization function can be maximizing, minimizing, or matching a value of
a goal or a sum of goals. You can set different weighting factors for each goal to consider
the importance of each goal for the objective function.

To conduct multiparameter optimization, create a Design of Experiments and
Optimization parametric study, run calculation of design points, and click Find Optimum.

Postprocessing Performance
Postprocessing performance has been improved for surface plots and loading results.

Surface plots of a very complex geometry shape displayed with
the Use CAD geometry option or comprising hundreds of faces
are created much faster.

Surface plots

Goal plots and XY plots can now be displayed in the graphics
area. The plots are updated in accordance with the loaded

Goal plot and surface
plot widgets

101



transient results so you can track how the goal and XY plot
parameters are changing in time.

Transient Simulation Performance
Transient simulation performance has been improved for saving data and viewing transient
results.

You can minimize transient data saved by saving selected
parameters only instead of saving the whole field. In the

Saving data

Calculation Options dialog box, on the Saving tab, you can
define when to save Full Results, and you can define time
moments to save as Selected Parameters.

The Transient Explorer mode available for selected saved
parameters lets you see transient results without waiting as
long to load. Move a slider and results update immediately.

Instant switching
between transient
time moments

Using Conditions from Low-level Components
You can import conditions from a model for other projects (such as material properties
and heat power). This can simplify the project definition by creating a library of models
with predefined conditions.

A Flow Simulation project is saved in the model. If the model is used in an assembly, you
can apply the conditions defined in this low-level component to the higher level assembly
without recreating the condition.

For example, you may want to analyze a printed circuit board (PCB), then analyze the
full electronics enclosure with fewer parts of the PCB installed. Instead of re-creating
conditions for all parts inside the assembly, you can link the assembly's project to the
conditions defined in the PCB.

By default, the conditions are linked, so changing conditions in the component
automatically updates conditions in the assembly. However, you can break the link so
imported conditions are not linked to the original component.

To use conditions from low-level components:

1. In the Import from Model dialog box, select the project from which you want to use
data.

2. Import the project.

By default, conditions appear in the Analysis tree linked to the conditions in the
component.

You can break the link and move conditions to the main assembly's project.

Mesh Settings for Flow Simulation
The new Dependent on Channel Height option allows you to easily achieve necessary
mesh in channels of different height by setting the refinement level depending on channel
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height. The option is available under the Channels group of the mesh settings dialog
box.
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14
Import/Export

This chapter includes the following topics:

• IFC Entity Classification and Custom Property Export
• Importing and Exporting 3MF Files
• Importing Mesh Files
• SOLIDWORKS 3D Interconnect
• System Options for Interoperability

IFC Entity Classification and Custom Property Export

You can save a SOLIDWORKS file as an IFC file with IFC entity classification. You can
then export it with custom properties that include the IFC metadata along with other
properties.

Classifying SOLIDWORKS files as IFC Entities
You can save a SOLIDWORKS file as an .ifc file with .ifc entity classification.

To classify SOLIDWORKS files as .ifc entities:

1. Open a SOLIDWORKS part or assembly file.
2. Click File > Properties.
3. In the dialog box, on the Custom tab:

a) In Property Name, select IFC.
b) In Value/Text Expression, select the appropriate taxonomy.
c) Click OK.

Exporting to IFC Format
You can export an IFC file with custom properties that include the IFC metadata along
with other properties.

To export to IFC format:

1. With a model open, click Save As (Standard toolbar) or File > Save As.
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2. In the Save As dialog box:
a) In Save as type, select IFC 2x3 (*.ifc) or IFC 4 (*.ifc).
b) Click Options.

3. In the System Options dialog box, set options:

DescriptionOption

Exports the classification metadata with the
IFC entity if it is specified in the file.

OmniClass™ or UniClass2015

Exports properties for the SOLIDWORKS file.Custom Properties or Material and
Mass Properties

4. If you are exporting as IFC 4, save as one of the following:

• BREP

• BREP and Tessellation
• Tessellation

5. Click OK.
6. Click Save.

Importing and Exporting 3MF Files
You can import 3D Manufacturing Format (3MF) files and export SOLIDWORKS part and
assembly files as 3MF files. Dassault Systemes is a founding member of the 3MF industry
consortium, whose goal is to eliminate interoperability issues with 3D printing formats.

Importing 3MF files in SOLIDWORKS
To import 3MF files in SOLIDWORKS:

1. Click Open (Standard toolbar) or File > Open.
2. In the dialog box, in Files of type, select 3D Manufacturing Format (*.3mf).
3. Browse to a file to open.
4. Click Options.
5. In the dialog box, set Import as to one of the following and click OK.

• Graphics Body

• Solid Body

• Surface Body

6. Click Open.

The file is imported in SOLIDWORKS.
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Exporting SOLIDWORKS files as 3MF Files
You can export SOLIDWORKS part and assembly files as 3MF files.

To export SOLIDWORKS files as 3MF files:

1. With a model open, click Save As (Standard toolbar) or File > Save As.
2. In the dialog box:

a) Set Save as type to 3D Manufacturing Format (*.3mf).
b) Click Options.
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3. In the dialog box, set these options:

DescriptionOption

Displays the selected file format.File Format

For Unit, select the unit of measure.Output as

Controls the tessellation of non-planar surfaces for 3MF output.
A lower deviation setting produces a more-finely-tessellated 3MF
file. Files generated with higher accuracy settings (increased
tessellation) are larger in size and slower to generate.

Resolution

Preset resolutions.Coarse or
Fine

Custom • Move the Deviation slider to adjust the
deviation Tolerance, which controls
whole-part tessellation. Lower numbers
generate files with greater whole-part
accuracy.

• Move the Angle slider to adjust the angle
Tolerance, which controls small-detail
tessellation. Lower numbers generate files
with greater small-detail accuracy, but those
files take longer to generate.

As you move the two sliders, the
corresponding concentric circles adjust
accordingly. The circles show approximately
how the tessellation will vary as a result of the
settings. (See Preview below.)

Displays this information: Triangles (number),
File Size, File Format, and the directory path
and file name.

Show 3MF
info before
saving file

Displays a faceted model preview and displays
the Triangles (number) and File size
information in the System Options dialog box.

Preview
before saving
file

Includes base materials with the exported file.Include
materials

Includes appearances with the exported file. Only surface-mapped
textural appearances are exported to 3MF.

Include
appearences

Select a coordinate system to apply for export. If you select --
default --, no transformation matrix is applied.

Output
coordinate
system

4. Click OK.
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5. Click Save.

Importing Mesh Files
You can import a scanned file with mesh data into the SOLIDWORKS software without
using the ScanTo3D add-in. The software imports the file and associated mesh data into
a solid or surface body. You can select and reference the converted facets, verticals, and
facet edges. You can also maintain the mesh as a mesh model in SOLIDWORKS that
allows graphical viewing of the mesh model.

To import mesh files:

1. Click Open (Standard toolbar) or File > Open.
2. In the dialog box, in Files of type, select Mesh Files (*.stl,

*.obj;*.off;*.ply;*.ply2).
You can also import *.3mf and *.wrl file formats as graphics bodies, solid bodies,
and surface bodies.

3. Browse to a file to open.
4. Click Options.
5. In the dialog box, set Import as to one of the following and click OK.

• Graphics Body

• Solid Body

• Surface Body

The software can import and create multiple solid bodies from the mesh file, provided
the mesh is closed. If the mesh is not closed, the Import as Solid Body option
automatically creates surface bodies for all bodies that cannot be imported as solid
bodies.

6. Click Open.

The file is imported.

SOLIDWORKS 3D Interconnect
3D Interconnect replaces SOLIDWORKS current translation capabilities with new technology
and workflows for working with third-party native CAD data in SOLIDWORKS 2017.

You can perform the following:

• Insert proprietary CAD data directly into a SOLIDWORKS assembly without converting
it to a SOLIDWORKS file.

• Open the proprietary 3D CAD format in the SOLIDWORKS software with its associative
link to the original part.

• Update changes in the SOLIDWORKS file if you update the proprietary CAD data in its
authoring application by maintaining all downstream features created in SOLIDWORKS.

The following formats and their versions are supported in 3D Interconnect:
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• CATIA® V5: .CATPart, .CATProduct for V5R8 – 5–6R2016

• Autodesk® Inventor: .ipt for V6 – V2016, .iam for V11 – V2016

• PTC®: .prt, .prt.*, .asm, .asm.* for Pro/ENGINEER® 16 – Creo 3.0

• Solid Edge®: .par, .asm, .psm for V18 – ST8

• NX™ software: .prt for UG 11 – NX 10

CATIA® V5-SOLIDWORKS Translator is available with SOLIDWORKS Premium license.

Turning 3D Interconnect On or Off
You can turn on and turn off the 3D Interconnect functionality in the SOLIDWORKS
software. It is turned on by default.

To turn 3D Interconnect on or off:

1. Click Tools > Options > System Options > Import.
2. In the dialog box, set File Format to Inventor/Catia V5/Creo/NX/Solid Edge.
3. Select or clear Enable 3D Interconnect.
4. Click OK.

Inserting a Third-Party Native CAD File into a SOLIDWORKS
Assembly

You can insert a third-party native CAD file into a SOLIDWORKS assembly using the
Insert Component tool.

To insert a third-party native CAD file into a SOLIDWORKS assembly:

1. Open drive letter:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS
2017\whatsnew\import_export\gear box_1.sldasm.

2. Click Insert Component (Assembly toolbar).
3. In the dialog box, browse to drive letter:\Users\Public\Public

Documents\SOLIDWORKS\SOLIDWORKS 2017\whatsnew\import_export\Round
Cover Plate_2.ipt.

4. Click Open and assemble it in the SOLIDWORKS assembly.

5. Click Insert Component (Assembly toolbar) and browse to drive
letter:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS
2017\whatsnew\import_export\wormgear.asm.1.

6. Click Open and assemble it in the SOLIDWORKS assembly.

The third-party Autodesk® Inventor and PTC® Creo® files are inserted in the
SOLIDWORKS assembly.
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Opening a Third-Party Native CAD File into SOLIDWORKS
You can use the Open dialog box to open a third-party native CAD file in the SOLIDWORKS
software. When you open a third-party part, a new SOLIDWORKS part is created and the
third-party file is inserted as a derived or a base part in it.

To open a third-party native CAD file into SOLIDWORKS:

1. Click Open (Standard toolbar) or File > Open.
2. In the dialog box, browse to drive letter:\Users\Public\Public

Documents\SOLIDWORKS\SOLIDWORKS 2017\whatsnew\import_export\Round
Cover Plate_2.ipt.

3. Make changes to the part using SOLIDWORKS features.
4. Update the part with the second version of the part.

Any modifications you made to the base part are updated in the SOLIDWORKS part
without losing the downstream features.

System Options for Interoperability
The Import/Export options have moved to the System Options dialog box. Previously,
you accessed them from the Open and Save As dialog boxes.

Click Tools > Options > System Options and click Import or Export. Under File
Format, set the type of file.
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15
SOLIDWORKS Inspection

This chapter includes the following topics:

• SOLIDWORKS Inspection Add-in
• SOLIDWORKS Inspection Standalone

SOLIDWORKS Inspection Add-in

Usability Improvements
All icons previously located in the PropertyManager are moved to the CommandManager to
simplify the user interface.

These icons are modified:

IconsTool Name

Edit Inspection Project

Add/Edit Balloons

Update Inspection Project

Manually Ballooning Drawings
Manually ballooning drawings gives you more control over how SOLIDWORKS Inspection
adds balloons to drawings.

When you select automatic ballooning, the software balloons all characteristics in the
drawing, using the specified sort order (clockwise or counter-clockwise).

If you select manual ballooning, the software:

• Balloons only the specific characteristics you identify.
• Orders the balloons based on the order in which you select them.

111



To manually balloon drawings:

1. Click New Inspection Project (SOLIDWORKS Inspection CommandManager).
2. Select a project template.
3. On the General Settings tab of the Create Inspection Project PropertyManager, under

Characteristic Info, for Extraction, select Manual.

4. Click to validate the project settings.

5. Click Add Characteristic (SOLIDWORKS Inspection CommandManager).
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6. In the graphics area, use one of the following techniques to select the characteristics
to balloon:

• Select individual characteristics.

The characteristics are added to the Characteristic Tree in the order in which you
select them.

• Box select a set of characteristics.

All the characteristics within the box are added to the Characteristic Tree.

To remove a characteristic, click it in the graphics area.

If you want to balloon most but not all characteristics, you can box select the entire
drawing and then remove characteristics you do not want to balloon.
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7. Click Add/Edit Balloons (SOLIDWORKS Inspection CommandManager).

The software creates balloons for the characteristics you selected, in the order in
which you selected them.

This step is not needed if you selected Auto Balloon in the Inspection Project
Settings.

Choosing a VDA Balloon Shape
VDA balloons, which were available in standalone SOLIDWORKS Inspection, are now
available in the SOLIDWORKS Inspection add-in.

VDA balloons are characterized by a drop shape and are frequently used in the German
automotive industry.

To choose a VDA balloon shape:

1. Click Add/Edit Balloons (SOLIDWORKS Inspection CommandManager).
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2. In the Balloon Settings PropertyManager, under Regular Format, for Shape, select
VDA.

3. Click .

Preventing Balloon Renumbering by Locking Balloons
Prevent Automatic Renumbering lets you add or remove balloons without affecting
the arrangement and numbering of the balloons that remain.

When you revise a SOLIDWORKS Inspection project by deleting or adding characteristics
and then refresh it, by default the software renumbers the balloons in the document. If
you specified a clockwise or counterclockwise sort order, when the balloons are
renumbered, that order is maintained.

For example, if you remove the characteristic that is represented by balloon 3, the next
sequential characteristic is renumbered to balloon 3. Depending on the version of the
inspection report, the features to measure are different. This can create confusion and
lead to costly mistakes.

Original balloon numbering
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Balloons renumbered after removing characteristic 3

You can override this behavior by using Prevent Automatic Renumbering. When to
use prevent automatic renumbering:

• If you remove a balloon, its number is removed from the sequence without affecting
the other balloon numbers.

• If you add new characteristics, they are added at the end of the balloon number
sequence.

To prevent balloon renumbering:

1. Click New Inspection Project (SOLIDWORKS Inspection CommandManager).
2. Select a project template.
3. On the General Settings page, under Characteristic Info, select Prevent Automatic

Renumbering and click .
4. To remove a balloon, do one of the following:

• In the Characteristic Tree, select the balloon. Under Properties, clear the
Selected check box.

The characteristic is no longer selected for inspection; however, the balloon number
remains associated with the characteristic.

If you use this method, you can restore the balloon if needed by re-selecting
the check box.

• In the graphics area, delete the characteristic that is associated with the balloon,

then click Update Inspection Project .

The software removes the balloon number from the sequence, while maintaining the
original numbering of the remaining balloons.

Original balloon numbering maintained
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SOLIDWORKS Inspection Standalone

Mouse Wheel Zoom in SOLIDWORKS Inspection
MouseWheel Zoom lets you navigate an inspection project with controls that are similar
to those in the SOLIDWORKS software.

Mouse Wheel Zoom is selected by default on the Application Options tab of the Options
dialog box.

To use mouse wheel zoom:

• Scroll upward to zoom out.
• Scroll downward to zoom in.
• Press and hold the middle mouse button to pan.

In addition, you can use the following to navigate:

Go to the previous sheet.Alt + Left

Go to the previous sheet.Page Down

Go to the next sheet.Alt + Right

Go to the next sheet.Page Up

Scroll up.Alt + Up

Scroll down.Alt + Down

Go to the first sheet.Home

Go to the last sheet.End
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16
SOLIDWORKS MBD

This chapter includes the following topics:

• 3D PDF Accuracy
• 3D PDF Template Editor Improvements
• Annotation Display Orientation
• Attaching Files to 3D PDFs
• Comparing 3D PMI Between Parts
• Exporting PMI Annotations to STEP 242
• Names Match in 3D PDFs
• Reordering 3D Views
• Sketches Display in 3D PDFs

SOLIDWORKS MBD is available as a separately purchased product that you can use with
SOLIDWORKS Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium.

3D PDF Accuracy
When you save or publish as 3D PDF, you can set the level of accuracy for a 3D PDF.

To set 3D PDF accuracy:

1. Click Publish to 3D PDF (SOLIDWORKS MBD toolbar).
2. In the PropertyManager, under Accuracy, select an option:

DescriptionLevel of Accuracy

No lossy compression (may result in very
large file size).

Maximum

0.001mm tolerance (low compression,
high accuracy) Low lossy compression
may result in large file size.

High

0.01mm tolerance (medium compression,
medium accuracy) Medium lossy
compression may result in moderate file
size.

Medium
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DescriptionLevel of Accuracy

0.1mm tolerance (high compression, low
accuracy) High lossy compression may
result in smaller file size.

Low

3. To apply lossy compression to the polygons in the model, select Use lossy
compression on tessellation.

For more information, see Lossy Compression.

3D PDF Template Editor Improvements
The 3D PDF Template Editor gives you more control of the layout and formatting of the
templates.

Aligning Elements
You can align two or more template elements by top, bottom, left, right, center, or middle.

To align elements:

1. In the 3D PDF Template Editor, select two or more elements, for example, an image
and a text area.

2. Click Align and click either Left , Center , Right , Top , Middle , or

Bottom .

Copying and Pasting Between Pages
Tabs are now called pages. You can copy an element from one page to another.

To copy and paste between pages:

1. Select the item to copy.
2. Click CTRL + C.
3. Select a page.
4. Click CTRL + V.

Formatting Text
You can format text using the styles bold, italic, and underline, and you can align text
left, right, center, and justify.

To format text:

1. In the 3D PDF Template Editor, click Text .
2. Click to place the text area placeholder on the template.
3. In the PropertyManager, under Properties, set the formatting options.
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4. Click outside of the text block.

Using Format Painter
Format Painter copies a text style to another text element.

To use Format Painter:

1. Select the text whose style (font, size, bold, italics, underline, strikethrough, color,
and alignment) you want to copy.

2. Click Format Painter .
3. Click the text where you want to place the style.

The original text style is applied to the selected text.

Grouping and Ungrouping Elements
You can group and ungroup elements on a template page.

To group elements:

1. Press Ctrl and select two or more elements.

2. Click Group > Group .

To ungroup elements:

1. Select a set of grouped elements.

2. Click Group > Ungroup .

Inserting Elements at Pointer Location
When you insert an element such as text or a rectangle in a 3D PDF template, it is placed
at the pointer location.

Inserting Rectangles
You can insert a rectangle in a 3D PDF template.

To insert rectangles:

1. In the 3D PDF Template Editor, click Rectangle .
2. Place the rectangle on the page.

You can position and resize the rectangle.

3. Set options such as fill color and border, border thickness, and corner radius.

4. Click .
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Locking Elements
You can lock elements on a template page so that they cannot be moved or resized.

• To lock an element, select the element and click Lock .

• To unlock an element, select the element and click Unlock .

Ordering Elements
You can set the order of elements from front to back.

To order elements:

1. Select an element and click Order .
2. Click an option:

DescriptionOption

Moves element to the first position.Bring to front

Moves element to the front by one position.Bring forward

Moves element to the last position.Send to back

Moves element to the back by one position.Send backward

Renaming Pages
You can rename pages in a template.

To rename pages:

1. Double-click the page name.
2. Type the new name.
3. Click off of the name to save the new name.

Repositioning Pages
You can change the position of the pages in a template by dragging and dropping the
page tab to a new location. This lets you begin a document with a cover page or other
introductory information such as a disclaimer or regulation statements.
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Initial position of page tabs

Repositioned page tabs

Resizing Rows and Columns in Generic Tables
To resize rows or columns, position the pointer over the row or column divider and drag
the divider.

Annotation Display Orientation
When publishing to 3D PDF, annotations are oriented so that they are readable in the
default orientation of each 3D view.

Attaching Files to 3D PDFs
When you publish to 3D PDF, you can attach files.

To attach files to 3D PDFs:

1. Click Publish to 3D PDF .
2. In the PropertyManager, under Attachments, click Attach Files.
3. Browse to the file to include and click Open.

The file is included as an attachment.
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Comparing 3D PMI Between Parts
You can use the 3D PMI Compare tool to compare DimXpert annotations, reference
dimensions, and other annotations between two part documents.

Reference document

Modified document

To compare 3D PMI between parts:

1. Click Tools > Compare > 3D PMI.
2. In the Task Pane, select the Reference document and Modified document.
3. Click Run Comparison.
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Exporting PMI Annotations to STEP 242
You can export SOLIDWORKS parts and assemblies with PMI annotations to STEP 242
format.

To export PMI annotations to STEP 242:

1. Click Publish STEP 242 File (SOLIDWORKS MBD toolbar).
2. In the dialog box, type a file name.
3. Click Save.

Names Match in 3D PDFs
Names assigned to DimXpert PMI in 3D PDFs match the original names in the SOLIDWORKS
software.

Reordering 3D Views
You can reorder 3D views on the 3D Views tab by using drag and drop or Sort Order.

Reordering 3D Views Using Drag and Drop
To reorder 3D views using drag and drop:

1. Select a 3D view.
2. Drag and drop it to a location.

When you reorder views using drag and drop, the reordered view is called Custom.

Reordering 3D Views Using Sort Order
To reorder 3D views using Sort Order:

On the 3D Views tab, under Sort order, select an option.

Sorting OrderOption

Alphabetical by 3D view name.Name

Alphabetical by configuration, then by 3D view name.Configuration

Alphabetical by display state, then by 3D view name.Display State

Order saved from drag and drop reorganization.Custom

Order created.History
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Sketches Display in 3D PDFs
Sketches that are visible in 3D Views display in 3D PDFs within the same 3D View.
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17
Model Display

This chapter includes the following topics:

• Controlling Decals and Scenes by Display States
• Displaying SOLIDWORKS Simulation Results in the Graphics Area
• Evaluating Models for 3D Printing
• PhotoView 360 Network Rendering Supports Frame-by-Frame Rendering
• Section Views

Controlling Decals and Scenes by Display States
You can define display states to use different instances of decals and scenes.

You can also configure light sources for all light types including sunlight. This feature
requires PhotoView 360.

To control decals and scenes by display states:

1. Open drive letter:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS
2017\whatsnew\model_display\usb_drive1\usb_drive1.sldasm.

2. In the FeatureManager design tree, right-click usb_case1 and click Open Part .
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3. Add a display state named Barcode and customize it:
a) Click at the top of the FeatureManager design tree.

The Display Pane appears.

b) Right-click in the Display Pane and click Add Display State .
c) Type Barcode for the name of the field that appears at the top.

d) Select the DisplayManager tab.

e) Click View Decals and click Open Decal Library.
f) In the Task Pane, drag the Barcode decal to the Case_body.

When you drag the decal and place it on your component, a manipulator appears
above the decal. You can change the direction and alignment of the decal using
the manipulator.

g) In the Decals PropertyManager, under Display States, select This display state

and click .

h) In the graphics area, right-click and click Edit Scene .
i) In the Task Pane, click Presentation Scenes and drag the Kitchen Background

scene to the graphics area.

j) Click .
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4. Add another display state named Designed_with_SOLIDWORKS and customize it.

a) Right-click in the Display Pane and click Add Display State .
b) Type Designed_with_SOLIDWORKS for the name of the field that appears at the

top.

c) In the DisplayManager, right-click barcode1 and click Delete.
d) In the Decals PropertyManager, click Open Decal Library.
e) In the Task Pane, drag the Designed with SOLIDWORKS decal to the

Case_body.
f) In the Decals PropertyManager, under Display States, select This display state

and click .

g) In the graphics area, right-click and click Edit Scene .
h) In the Task Pane, click Presentation Scenes and drag the Factory Background

scene to the graphics area.

i) Click .

5. In the ConfigurationManager tab, under Display States, double-click Barcode
and Designed_with_SOLIDWORKS to change between display states.

6. In the Render Tools CommandManager, click Display States Target .
The Display State Target dialog box appears.

When you change between display states, the active display state is selected in the
Display State Target dialog box. This is useful for deleting or customizing the decals
and scenes in the active display state.

Displaying SOLIDWORKS Simulation Results in the
Graphics Area

You can display SOLIDWORKS Simulation results in the SOLIDWORKS graphics area along
with other components or bodies in the model that are not part of the simulation.

This way, you do not have to switch between the simulation results and the modeling
environment. It is not ideal to display simulation results on bodies and components. This
display helps with marketing purposes and predictive design. Previously, if you ran a
simulation on a component in an assembly, only the component was shown with the
results and all other components were hidden.
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An example of predictive design is making model changes based on simulation results.

Available with SOLIDWORKS Simulation licenses.

To display SOLIDWORKS Simulation results in the graphics area:

1. Open drive letter:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS
2017\whatsnew\model_display\sunglasses.sldasm.
If the Resolve Lightweight Components dialog box appears, click OK. The assembly
has a simulation study saved with it.

2. Click the Static 1 tab.

3. In the Simulation Study tree, right-click Static 1 and click Run.
4. Click the Model tab.

5. Click Simulation Display (View toolbar) or View > Display > Simulation
Display.

If the Simulation Display dialog box appears, click OK.
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6. In the PropertyManager:
a) Under Selected Result, select Displacement1.

b) Click .
The assembly is displayed with the simulation results in the context of the assembly.

The Simulation Display command only lists result plots for the studies for which
you have loaded all simulation data. To load all simulation data, click Simulation >
Options > System Options > General and select Load all Simulation Studies
when opening the model (requires more time to open a model). You can
also load simulation data for a specific study by clicking individual simulation tabs.

Evaluating Models for 3D Printing
Before printing a model using a 3D printer, you can evaluate the thickness and gaps in
a model to see if they can be printed using Fused Deposition Modeling (FDM) 3D printing
technology.

Based on the layer height and the selected thermoplastic material, you can identify wall
thickness and gap width issues before printing the model.

The 3DPrint tool identifies where wall thickness or the distance between two faces in a
groove are below a certain threshold, then highlights the geometry in the model. This
tool is helpful when large models are scaled down or when detailed models are printed
on a 3D printer.
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To evaluate models for 3D printing:

1. Open drive letter:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS
version\whatsnew\model_display\airplane.sldprt.

2. Click Print3D (Standard toolbar) or File > Print3D.
3. In the PropertyManager, click the Settings tab and do the following:

a) Set Bottom plane of model.
b) Set the value for Scale.
c) Click Scale to Fit.

4. In the PropertyManager, click the Preview tab and do the following under Layer
height:
a) Set Layer Height to 0.5.
b) Select Thickness/Gap Analysis and Custom thickness and gap.
c) Set Thickness/Gap to 2.5.
d) Set Angle to 178.
e) Click Calculate.

Areas of the model that are too thin or with too large of gaps are shown.
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PhotoView 360 Network Rendering Supports
Frame-by-Frame Rendering

PhotoView 360 supports “frame-by-frame” network rendering when you save an animation,
which increases rendering performance.

The PhotoView 360 network rendering feature allows you to distribute rendering for an
animation to up to 10 networked client machines running the PhotoView 360 Net Render
Client.

In previous releases several client computers would share the work of rending the same
frame, which requires a significant amount of network intercommunication. In
SOLIDWORKS 2017, each client computer works independently on its own frames. This
reduces the need for communication among the client computers and can dramatically
shorten the time needed to complete rendering. No changes are required in the way the
clients are configured.

To configure frame-by-frame rendering, you only need to set up a network of computers.

The list of available computers displays at the bottom of the PhotoView Network Render
Client interface. You can also view the list by expanding the tab at the bottom of the final
render window.

Note that computers on wireless networks do not interact well when it comes to network
rendering or frame-by-frame animation rendering. The Coordinator computer or the
computer running the PhotoView Network Render Client should not be using a wireless
connection to access the network.

Section Views

Creating Transparent Section Views
While creating section views, you can set individual bodies and components as transparent.

The transparency helps you see through to the internals of the model. The transparent
section view is available in PhotoView 360.
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To create transparent section views:

1. Open drive letter:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS
2017\whatsnew\model_display\gearbox\GEARBOX.sldasm.

2. Click Section View (View toolbar) or View > Display > Section View.
3. In the PropertyManager:

a) Under Section Method, select Zonal.
b) Select Transparently Section Components.

4. In the flyout FeatureManager design tree, select HOUSING - GEARS.
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5. In the PropertyManager, under Transparently Section Components:
a) Select Include selected to make the housing transparent.
b) Set Transparent amount to 0.75.

c) Click .
The section view appears with a transparent housing.
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Keep Cap Color
In the Section View PropertyManager, the Keep cap color option is selected by default.

Additionally, in previous versions, if you selected Graphics-only section, the Keep cap
color option was automatically selected. This no longer occurs. When selected, Keep
Cap Color is always reflected in the model display with a solid color cap or a part colored
cap.
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18
Parts and Features

This chapter includes the following topics:

• Advanced Holes
• Bidirectional Circular Patterns
• Chamfer Enhancements
• Converting Features to Bodies and Surfaces
• Cut List Sorting
• Derived Part References are Retained
• Disabling and Enabling Equations in All Configurations
• Extrude from Any Size Planar Face
• Rebuilding All Configurations
• Running FeatureWorks After Adding Items to Imported Parts
• Select All for Split Features and Save Bodies
• Sweep Profile Selection of Faces, Edges, and Curves
• Thread Enhancements
• What's Wrong Enhancements
• Window Selection for Instances to Skip
• Wrap Creates Geometry on Any Face

Advanced Holes
With the Advanced Hole tool, you can define advanced holes from the near and far side
faces. Hole element flyouts help guide the process. A Favorites group box is available
in the PropertyManager.

Creating Advanced Hole Elements
1. Create a simple extruded block part.

To better visualize the previews, Ctrl +select all faces and click Appearances.
In the Task Pane, under Glass, double-click clear glass to apply this appearance.

2. Click Advanced Hole (Features toolbar) or Insert > Features > Advanced
Hole.

The PropertyManager opens with the Near Side flyout displayed.

3. In the PropertyManager, on the Type tab, under Near And Far Side Faces, select
a face.
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A temporary preview of the hole appears. The location is temporary, based on your
initial selection on the face. You set the position later.

4. In the Near Side flyout, click Insert Element Below Active Element to add a
Near Side element to the advanced hole.

5. In the PropertyManager, under Near and Far Side Faces, select Far Side, then
select the opposite face on the model.

The Near Side flyout now displays two Near Side elements. The Far Side flyout is
active and contains one element. A bar separates the flyouts.

The default element type in flyouts is Counterbore .

Next, you set the element specifications.

Setting Element Specifications
1. In the Near Side flyout, select the top element to activate it. You want to keep

Counterbore as the hole type but modify some settings.
2. Under Element Specification:

a. In Type, select Socket Head Cap Screw.
b. In Size, select 1/4.

The temporary preview of the Near Side element is updated.
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3. In the flyout, click for the second Near Side element, then click Straight .

You want to modify the specifications for this element.

4. Under Element Specification:

a. In Type, select Screw Clearances.
b. In Size, select 1/4.

c. For Custom sizing, set End Condition to Blind and Depth to 1.

The preview updates to show the modified size and depth for the Straight element.
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In the flyouts, you can drag elements to reposition them. If the drag operation
causes a failed element, that element is highlighted. Hover over the element to
display an error message.

The Far Side element is set as Counterbore. You want to modify it to be a tapped
thread element.

5. In the Far Side flyout, click for the Far Side element, then click Thread .
6. Under Element Specification:

a. In Type, select Tapped hole.
b. In Size, select 1/4-20.

The Far Side element updates up to the middle Near Side element because of the
Up to Next Element end condition.

You can save advanced hole features as Favorites to reuse them. In the
PropertyManager, on the Type tab, under Favorite, you can add, update, delete, save,
or load a favorite advanced hole.

Next you create and position instances.

Creating and Positioning Advanced Hole Instances
1. In the PropertyManager, select the Positions tab.

You can select multiple points or use a sketch to create multiple holes.
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If you forget to select the Positions tab and click , the software prompts you to
select a point on the face to locate the hole. Click OK in the prompt to open the
Positions tab and the Sketch toolbar.

2. Click Center Rectangle (Sketch toolbar) and sketch a rectangle, using the sketch

origin on the face as the center.

3. Click to close the Center Rectangle PropertyManager and return to the Hole Position
PropertyManager.

The software creates five instances of the hole, including a sketch point at the selected
origin. You want to remove the center instance.

4. Under Instances to Skip, select the center instance orb to remove only this instance
from the preview.
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Under Sketch Options, you can select Create instances on construction
geometry to create instances using construction geometry.

Bidirectional Circular Patterns
You can create circular patterns symmetrically or asymmetrically in both directions from
the seed geometry. This is useful when the seed is not located at the end of the pattern
arc.

You can adjust the angle, number of instances, and spacing settings for each direction
independently. The Symmetric option applies the same settings to both directions.

To create bidirectional circular patterns:

1. In a part model, click Circular Pattern (Features toolbar) or Insert >
Pattern/Mirror > Circular Pattern.

2. In the PropertyManager, under Features to Pattern , select a seed feature to
pattern.

3. Under Direction 1, select a Pattern Axis.
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4. Set Angle to 25 and Number of Instances to 4.

5. Select Direction 2, then select Symmetric.

Three instances of the same seed appear symmetrically in the reverse direction.

6. Clear Symmetric, and set Angle to 30 and Number of Instances to 6.

The pattern updates in Direction 2 only. The Direction 1 pattern is unchanged.

7. Under Instances to Skip, select instances 2 and 3 in Direction 2.

The instance orbs turn white, indicating the skipped instances.
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8. Click to complete the pattern.

Chamfer Enhancements
The Chamfer PropertyManager has been updated to align with the Fillet tool. There are
two new chamfer types,Offset Face and Face Face, which you can convert from chamfers
to fillets and back.

Offset Face Chamfers
Offset face chamfers are solved by offsetting the faces adjacent to selected edges. The
software calculates the intersection point of the offset faces, then calculates the normal
from that point to each face to create the chamfer.

Chamfer appliedCalculation of chamfer offset

This method yields predictable results when chamfering between non-planar faces. Offset
face chamfers can change direction on an edge-by-edge basis, and they support chamfering
entire features and surface geometry.

Face Face Chamfers
Face face chamfers can create symmetric, asymmetric, hold line, and chord width
chamfers.

There are two ways to convert offset face and face face chamfers to fillets and back.
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• Right-click a chamfer feature and click Edit Feature . In the PropertyManager, for

Feature Type, click Fillet Type or Chamfer Type, and click .

• Right-click a chamfer feature and click Convert Chamfer to Fillet or Convert Fillet
to Chamfer. The PropertyManager opens with the converted Feature Type already

selected. Click .

There are no changes in functionality to the other chamfer types. Their PropertyManagers
have been reorganized.

To access the new chamfer types, click Chamfer (Features toolbar) or Insert >
Features > Chamfer. In the PropertyManager, under Chamfer Type, select Offset

Face or Face Face .

Converting Features to Bodies and Surfaces
For parts, you can convert features to bodies and surfaces which maintaining geometric
references from other parts, assemblies, and drawings. This lets you remove unneeded
feature history, while retaining the bodies and surfaces.

To access this functionality, in the FeatureManager design tree, right-click the part name
and click Convert to Bodies.

To convert features to bodies and surfaces:

1. Open an assembly file, such as the HousingAssy.SLDASM model shown.

The Housing component is part of an assembly. Two components are external
references to Housing. Another component is mated to Housing.
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2. In the FeatureManager design tree, right-click Housing and click Open Part .

The Housing part opens.

3. At the top of the FeatureManager design tree, right-click Housing and click
Convert to Bodies.

4. In the dialog box:
a) Under File Name, change the name to Housing2.SLDPRT.
b) Select Save as.
c) Select Preserve reference geometry and sketches.
d) Click OK.

The converted file retains all the sketches and Plane1 geometry.

5. Click Window > HousingAssy.SLDASM to return to the assembly.

Because the assembly was open in the background, the original Housing component
was replaced with Housing2.

6. In the FeatureManager design tree, expand Mates .
There were no failures to external references or mates, which demonstrates that the
model kept all of its geometric references.
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Cut List Sorting
You can choose sorting options for cut lists from a shortcut menu on the top level of the

Cut list folder and from the Document Properties tab.

You can collect identical bodies and choose faces and features to exclude in sorting. This

option collects all bodies in a Cut-List-Item folder that are geometrically identical,
but are generated by different features. For example, cylinders that are created by extrude
or revolve features, but are identical in volume.

To use cut list sorting:

In this model, Extrude1 and Revolve1 bodies have the same volume, but appear in

separate Cut-List-Item folders.

Do one of the following:

• In the FeatureManager design tree, right-click the top level of the Cut list folder
and click Cut List Sorting Options. Under Sorting Options, select Collect Identical

Bodies and click .
• Click Tools > Options > Document Properties > Weldments. Under Cut list

options, select Collect identical bodies.

To preserve the Collect identical bodies option in the Document Properties dialog
box, create a template with this option selected. When you create new weldment
parts with this template, the software automatically checks for identical bodies in

the Cut-List-Item folders.

Both bodies now appear in the same Cut-List-Item folder.
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To choose faces and features to exclude:

In this model, LPattern1 body was created from Boss-Extrude1 body, then
Cut-Extrude1 was added to one pattern instance. You want to exclude the Cut-Extrude1
feature geometry from the cut list sorting.

1. In the FeatureManager design tree, right-click the top level of the Cut list folder
and click Cut List Sorting Options.

2. In the PropertyManager, under Faces/Features to Exclude, select Cut-Extrude1
from the FeatureManager design tree.
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You can select features from the FeatureManager design tree or faces from bodies
in the graphics area. This option is useful for collecting bodies generated from
identical stock material by ignoring features such as holes, fillets, and chamfers.

3. Click .

The bodies Boss-Extrude1 and Cut-Extrude1 appear in a single Cut-List-Item
folder. The Cut-Extrude1 feature geometry was excluded when comparing bodies in the
cut list sorting process.

Derived Part References are Retained
Derived parts retain their references when you modify the original body using Boolean
operations with features such as combine, cut extrude, split, and core.

Previously you received an error message that the base part had no solid when you
performed Boolean operations in the parent part.

Disabling and Enabling Equations in All Configurations
You can disable and enable equations in the Equation View , Sketch Equation View

, or Ordered View in the Equations, Global Variables, and Dimensions dialog box.

The equations are disabled in all configurations. You can enable the equations if no other
active equation controls the same parameter.
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To disable equations, in Equations, Global Variables, and Dimensions dialog box, in any
view, right-click an equation and click Disable Equation. The equation disappears from

the view. Ordered View retains all equations. The disabled equations are unavailable.

To enable a disabled equation, in the Equations, Global Variables, and Dimensions dialog

box, click Ordered View . Right-click the equation and click Enable Equation. The
equation reappears in all views where it previously appeared.

In Dimension View , you can enable and disable Global Variables and Features,
but not Dimensions.

Extrude from Any Size Planar Face
You can create boss, cut, and surface extrudes from any size surface, face, or plane. The
surface or face must be planar. Previously the From > Surface/Face/Plane selection
needed to encapsulate the entire sketch.

To extrude from any size planar face:

• In parts, click Extruded Boss/Base (Features toolbar) or Insert > Boss-Base

> Extrude. This functionality is also available for Extruded Cut and Extruded

Surface .

• In assemblies, click Insert > Assembly Feature > Cut > Extrude.

Select a sketch. Under From, select Surface/Face/Plane, and select a planar surface
or face, or a plane.

Rebuilding All Configurations
The Rebuild All Configurations tool is available in multiple, more visible locations.

To rebuild all configurations:

Do one of the following:

• In the ConfigurationManager, right-click the file name and click Rebuild All
Configurations.
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• In a file, click Edit > Rebuild All Configurations.
• Press Ctrl + Shift + B.

Rebuild All Configurations is available only when there are multiple configurations
in a file.

Running FeatureWorks After Adding Items to Imported
Parts

You can add various features and references to an imported part and not lose them if
you subsequently run FeatureWorks on the imported part.

The following features and references are supported:

• Drawing views
• Drawing annotations
• Drawing dimensions
• Assembly mates
• Assembly features

Select All for Split Features and Save Bodies
You can use Select All for split features to select all split bodies without saving the
resulting bodies to new parts.

Previously you had to select check boxes individually, or select Auto-assign Names,
which created separate, unnecessary part files for each body.

To select all bodies:

Do one of the following:

• Click Insert > Features > Split. Under Resulting Bodies, click Select All .
• Click Insert > Features > Save Bodies. Under Resulting Parts, click Select All

.

Sweep Profile Selection of Faces, Edges, and Curves

You can select faces, edges, and curves directly from models as sweep profiles. Enhanced
selection is supported with Boss, Base, Cut, Surface, and Assembly cut sweep features.
Previously you needed to create an extra sketch with converted entities as the profile.

You can select:

• Faces from model geometry.
• A single edge or reference geometry curves that contain a smooth, closed loop.
• A group of edges or curves selected as a loop using SelectionManager.
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To access this functionality, click Swept Boss/Base (Features toolbar) or Insert >
Boss/Base > Sweep. In the PropertyManager, under Profile and Path, select Sketch
Profile, then select a face, edge, or curves.

Sweep featureSelect edges using the
SelectionManager for Sketch

Profile

Select face for Sketch
Profile

Thread Enhancements

Trimmed Threads
You can align threads to end faces. A Cut thread is extended and cut to match the end
face. An Extrude thread is cut to match the end face. In the PropertyManager, under
Thread Options, select Trim with start face and Trim with end face.

Before trim
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After trim

Multiple Starts
Threads can have multiple starts. In the PropertyManager, under Thread Options, select
Multiple Start. Set the number of starts to define the number of times the thread is
created in an evenly-spaced circular pattern around the hole or shaft. The image shows
a four-start thread with a different color per thread.

The thread pitch value must permit multiple starts without causing crossing,
self-intersecting threads. In the example, the pitch of the yellow thread is wide enough
to allow the green, blue, and red threads to be nested inside of it.

Favorites
A Favorites group box is available in the PropertyManager.

What's Wrong Enhancements
What's Wrong details and calls to action appear within the FeatureManager design tree,
breadcrumbs, and graphics area. You no longer need to open the What's Wrong dialog
box.

To display a contextual What's Wrong box, select an error or warning in the
FeatureManager design tree, breadcrumbs, or graphics area. The box describes the issue

152

Parts and Features



and offers suggestions to correct it. Links appear to either Edit Feature or Edit Sketch

. Depending on the situation, there may also be links to Preview and Help .

To display a list of all errors and warnings, left-click the top node in the FeatureManager
design tree. Click an item in the list to select the item in the FeatureManager design tree.
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You can still display the What's Wrong dialog box. Right-click the feature with an error
or warning and click What's Wrong.

Window Selection for Instances to Skip
You can use box and lasso selection to add or remove instances to skip in patterns.

To use window selection for instances to skip:

1. Create or edit a pattern feature.

This selection does not work for sketch patterns.

2. In the PropertyManager, expand Instances to Skip.

Selection orbs appear for all instances of the pattern.

3. In the graphics area, right-click and click Lasso Selection, and select instances to
skip.

The orbs change to white, indicating they are skipped from the pattern. The instances
are listed under Instances to Skip.
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4. Click .

• If the selection contains skipped and non-skipped instances, the software toggles
the instances from their current state. Skipped instances become non-skipped
and vice versa.

• Shift + select only adds instances to Instances to Skip.
• Alt + select only removes instances from Instances to Skip.
• Selection orbs for instances must be completely within the selection region to
be added to or removed from Instances to Skip.

Wrap Creates Geometry on Any Face
The Wrap feature lets you create geometry on any face type. Not only can you wrap a
sketch on all face types, you can wrap a sketch on multiple faces. Previously, the Wrap
feature only handled cylindrical and cone shaped faces, and you could only work on a
single face at a time.

You can choose between two methods to create a wrap. The Analyticalmethod preserves
legacy behavior where you can wrap a sketch completely around a cylinder or cone. The
Spline Surface method wraps a sketch on any face type. A limitation with this method
is that it cannot wrap around a model.

Spline Surface methodAnalytical method

The PropertyManager and the preview have also been redesigned. The options in the
PropertyManager are listed in a more logical order with large icons to help you distinguish
between the various wrap types available. The preview displays a dot guide to show where
a wrap starts from on a target face.
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To create wrap geometry on any face:

1. Open drive letter:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS
2017\whatsnew\parts\iron.sldprt.

2. Click Wrap (Features toolbar) or Insert > Features > Wrap.
3. In the graphics area, select the SOLIDWORKS sketch.
4. In the PropertyManager:

a) For Wrap Type, click Emboss .

b) For Wrap Method, click Spline Surface .

5. Select the faces along the top handle of the iron. There are a total of six.

156

Parts and Features



6. In the PropertyManager, under Wrap Parameters, set the Thickness to 2mm

and click .

If you want to make the wrap feature stand out, you can change its appearance by coloring
the decal or turning the edges on or off.
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19
SOLIDWORKS PDM

This chapter includes the following topics:

• Adding Custom Columns
• Changing a Category of a Checked in File
• Controlling the Download Permissions for Users and Groups
• Copying Group Permissions and Group Members
• Generating SOLIDWORKS MBD 3D PDFs
• Latest Version Overwrite
• Preview Enhancements
• Quality Enhancements in SOLIDWORKS PDM
• Reference Tree Display Enhancements
• Rolling Back a File with References
• Searching Local Files
• SOLIDWORKS PDM Client and Server Service Pack Compatibility
• SOLIDWORKS PDF Task Add-in
• SOLIDWORKS PDM Web2 Viewer Enhancements
• Vault Database Replication

SOLIDWORKS® PDM is offered in two versions. SOLIDWORKS PDM Standard is included with
SOLIDWORKS Professional and SOLIDWORKS Premium, and is available as a separately
purchased license for non-SOLIDWORKS users. It offers standard data management capabilities
for a small number of users.

SOLIDWORKS PDM Professional is a full featured data management solution for a small and
large numbers of users, and is available as a separately purchased product.

Adding Custom Columns
The Custom Column functionality has expanded to the Do Transition (Change State) and
Get dialog boxes.

To add custom columns:

1. Do one of the following:

• Right-click any column heading and click More.
• Right-click anywhere in the dialog box and click Columns > More.
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2. Select the columns to display.
The added custom columns appear alphabetically on the right side of the default
columns. You can sort, resize, and reorder the custom columns. SOLIDWORKS PDM
saves these settings per user.

Changing a Category of a Checked in File
Admin login can change a Category of a checked in file doing one of the following:

• Select the file and click Modify > Change Category.
• Right-click the file and click Change Category.

Controlling the Download Permissions for Users and
Groups

In the Web2 client, Administrators can control download permissions for users and groups
by adding and configuring the following settings into the <configuration> node of the
Web.config file:

<vaultSettings>
<vault name="EPDM" defaultDelimiter="|" denyDownloadGroups="Group1">
<user name="admin" denyDownload="false"/></vault>
<user name="User1" denyDownload="true"/></vault>
</vaultSettings>

DescriptionVault setting

Name of the vault. Create a separate <vaultSettings>
section for each vault that needs download permissions
controlled.

name

Delimiter used to separate group names in the
denyDownloadGroups setting. The default delimiter is |.

defaultDelimiter

Groups that have download permissions denied in the
specified vault. You must separate group names by the
delimiter specified in the defaultDelimiter setting.

denyDownloadGroups

DescriptionUser setting

User login name. Create a separate <user> node for each
user.

name

Denies download permissions for users from the specified
vault. If set to false, the user can download files. If set to
true, the user cannot download files.

denyDownload
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A user cannot download files if the user is denied as part of group or as a user.

Copying Group Permissions and Group Members
Administrators can copy group permissions and group members from an existing group
when creating a new group and while importing from Active Directory.

To copy group permissions and group members:

1. Right-click Groups and click New Group.
2. In the dialog box, for Group Name, type a name.
3. In Copy from group, select the source group.
4. Select Copy Permissions and/or Copy Members.
5. Click Next and OK.

Generating SOLIDWORKS MBD 3D PDFs
SOLIDWORKS PDM Professional customers who use SOLIDWORKS MBD functionality, can
automatically generate SOLIDWORKS MBD 3D PDF output using Convert Task.

This helps you define, organize, and publish 3D product and manufacturing information
(PMI), including 3D model data, in industry standard file formats. This functionality
enhances the integration between SOLIDWORKS PDM and SOLIDWORKS MBD.

To generate SOLIDWORKS MBD 3D PDFs:

1. In the Administration tool, on the left pane of the Convert - Properties dialog box,
click Conversion Settings.

2. Set Output file format to 3D PDF - MBD (*.pdf).

Assembly or Part
The Assembly and Part tabs let you define the themes and views to publish in the output.

3D PDF Theme Path

Path of the theme file. If the theme file is in the vault, it must
be cached before the task execution. If the theme file is
outside the vault, it must be accessible to the task host.

Allow the user to change the theme path

Lets users change the path of the theme file during the task
execution.

Theme for SW
Assembly or Theme
for SW Part
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3D Views

(Default.) Includes all captured 3D views except the current
model view in the output file.

Primary Views

Lets you select the primary views like front, top, and back
to include in the output file.

Allow the user to change this setting

Lets users change the setting for the views during the task
execution.

Select Views to
include

Latest Version Overwrite
SOLIDWORKS PDM lets users overwrite the latest file version during check in and change
state operations. This reduces the number of archives significantly.

Previously, SOLIDWORKS PDM created a new file version for any change to a file or its
metadata.

Typical use cases include:

• Day end check in.
• Fixing a typo.
• Updating child references of the referencing file to the latest version.
• Upgrading the latest file version to match the current SOLIDWORKS version.
• Updating metadata through the set variable transition action.
• Any minor changes retaining the revision tag on the latest version.

Administrators can allow users to overwrite the file version by granting the overwrite
folder permission and state permission.

The version overwrite functionality is supported for documents or files. It also supports
transitions that are triggered via Web2 client. It is not supported for:

• Items.
• Named BOMs.
• File versions that have associated items set to Auto Update.
• Files checked in via Web2 client.

User Interface Changes with Version Overwrite
Many of the user interfaces have been changed with version overwrite functionality.

The Check in dialog box displays an Overwrite Latest Version column. This option is
turned off by default. You can select it only if the Check in option is selected. To overwrite
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all files, right-click in the dialog box and click Overwrite Latest Version on All Files
or press Ctrl+R.

When you select Overwrite Latest Version, the New ver. column is updated with the
latest version value.

The transition's Properties dialog box displays Can overwrite latest version during
check in check box. Administrators can set the version overwrite action while running
the transition.

The Check in file dialog box in Dispatch action displays an Overwrite Latest Version
check box. The version overwrite is not supported in the Dispatch action if:

• The logged in user lacks overwrite folder permission or state permission.
• File versions have associated items set to Auto Update.

The History dialog box displays icon followed by Checked in with version overwrite

under Event for the latest version. For the overwritten version, icon is updated to
icon indicating that the file archive associated with its history event is overwritten by the
latest event.

When you have a cached file version and another user overwrites that file version on
another machine the:

• Version Number column in File Explorer displays as -/latest version. When you
select this file, the icon is updated in the Version tab and the Local version status is
updated to Local version has been overwritten.

• Child Quick Info icon in the SOLIDWORKS PDM add-in displays as . The Version
Number column displays -/latest version, with the file name and version number in
bold.

If a named BOM is associated with the overwritten version of the source file, the icon on
the Bill of Materials tab appears as .

In the Administration tool, in the user's Properties dialog box, the Warnings page for
Check In operation displays a warning, Local version has been overwritten.
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Administrators can set this warning to stop check in of a parent file that has overwritten
references.

Preview Enhancements
When previewing SOLIDWORKS files in Windows Explorer (Preview tab), SOLIDWORKS
PDM offers more functionality and controls.

The viewer enhancements let you:

• Toggle the exploded view by clicking Explode.
• Turn off the card details display in the Preview tab of Windows Explorer, Item Explorer,
and File Viewer. This lets you view the eDrawings preview in the entire preview area.

The Card Preview is turned on by default. To turn it off:

• In Windows Explorer, click Display > Card Preview.
• In File Viewer, click View > Show File > Card Preview.
• In Item Explorer, click View > Card Preview.

SOLIDWORKS PDM defaults to the Background color and Highlight color settings
saved in the eDrawings full viewer.

Card Preview on
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Card Preview off

Quality Enhancements in SOLIDWORKS PDM
You can move a file using the Move/Rename file command in the Dispatch action.
Previously, you could only copy, delete, and rename the file.

The Convert task supports using the file data card variables in the output file name.

Input formulas for search card Edit boxes update when you enter new values in the
connected fields in searches in Windows Explorer.

For example: In a Search Card, you add an edit box, connect it to the Project variable,
and add an Input formula as PRJ<Number>. In searches in Windows Explorer, when
you enter a value for the Number variable in the Search Card, the input formula triggers,
and displays PRJ followed by the value of the Number variable.

The Reset All button on the Copy Tree and Move Tree dialog boxes resets all settings to
the defaults. Previously, Reset All used to reset only the Destination Folder Path and
Target File Name to the defaults.

You can turn off the user information pop-up in Windows Explorer when hovering over
the user name in the Checked Out By column. To turn off the display, in the
Administration tool, on the Explorer page of the User’s Settings, clear Show user
information pop-up.
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Reference Tree Display Enhancements
SOLIDWORKS PDM displays an enhanced reference tree with sub-parent relations.

The Get, Set Revision, Do Transition (Change State), Copy Tree, and Move Tree dialog
boxes, and the Contains tab display the reference tree with only one node for the selected
file that is displayed at the top of the tree.

The sub-parent relation is displayed with the file name in blue and an upward arrow.

If the selected drawing file has multiple references, the sub-parent relation is displayed
multiple times in the reference tree.

SOLIDWORKS PDM 2017
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SOLIDWORKS PDM 2016

Rolling Back a File with References
SOLIDWORKS PDM enhances Rollback to handle reference redirection and rollback more
efficiently.

To roll back a file with its references:

• Users must have the Rollback folder permission.
• The selected file and all its parent references must be in checked in state.
• The rollback target version must not be cold stored.

You can roll back a parent file with its child references and files indicated as sub-parents
(such as drawing files) to a previous as built state.

When you roll back a child reference (such as a part file), you can redirect the parent
references of the rolled back versions to the target version.

Previously, you could not roll back a file with all of its references and the parent references
were removed.

After rollback, SOLIDWORKS PDM resets the referenced configurations of the files. If the
same configuration is:

• Available in the target version, the references are retained for that configuration.
• Not available in the target version, the references are redirected to the active (last
saved) configuration of the target version.

Reference redirection and roll back a file with references functionality is not supported
for items.
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Rolling Back a File Structure
To roll back a file structure:

1. In the History dialog box, select the event to roll back to and click Rollback.

SOLIDWORKS PDM selects the parent file and the references that have same events
as the referenced version to roll back.

In the Rollback dialog box, you can select other references to roll back and the
Rollback Point.

SOLIDWORKS PDM selects Yes for Redirect parent references of the file to be
rolled back to redirect the references.

2. For Rollback Comments, type a comment.
3. Click Continue.

The list of the referencing files for which the references are redirected or deleted
appears.

4. Click Rollback to confirm the operation.

Rollback Dialog Box
The Rollback dialog box lets you roll back a file with or without references. You can either
redirect the parent references or delete them.

To open the Rollback dialog box:

1. In the History dialog box, select the event to roll back to and click Rollback.
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Settings

Only shown when warnings
are present in theWarnings
column.

In the file list, changes the
focus to the next file with a
warning or the previous file
with a warning.

Next Warning / Previous
Warning

Displays file references for
the entire file hierarchy
(Show All Levels) or just
the top level of the file
hierarchy (Top Level Only).

Show All Levels

Opens the Select Files dialog
box, where you can specify
a wildcard pattern to select
files.

Select Files

Open All opens a list of files
in Microsoft Excel as a
comma-delimited file.

Open File List

Open Visible opens a list of
visible files in Excel as a
comma-delimited file.

Export All exports the list of
all files as a
comma-delimited .txt file.

Save File List

Export Visible exports the
list of visible files as a
comma-delimited .txt file.

Files to rollback

Displays a thumbnail preview of the file when you hover over the file type
icon.

Type

Displays the file to roll back and its referenced files (if any).File Name

Displays warnings, if any of the rollback conditions are not met.Warnings

Displays the selected parent file and its references that have the same
Revision or Transition or Checked in event. You can select or clear the files
to roll back.

Rollback
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Click any Rollback Point to display the list of Event in the file history for
the target version. The default selected Rollback Point is highlighted in
blue. When you change this setting, the rows are highlighted in yellow.

The Rollback Point is set to:

DescriptionSetting

If the files are not selected for
rollback.

When you select a file for rollback,
SOLIDWORKS PDM sets the
Rollback Point to the highest valid
event in the target version.

No rollback setpoint

If a parent file has an internal
component, it gets selected or
cleared for rollback with its parent
file. You cannot select or clear the
internal component explicitly.

Internal Component

SOLIDWORKS PDM attempts to match child files to Revisions, Transitions,
or Checked in events from the rollback triggered parent file. Any change
to the Rollback Point of the parent file recomputes the default rollback
points for child files in the tree.

Rollback
Point

Displays the local version and the latest version as local version/latest
version of the file.

Local ver.

Displays the referenced version/latest version of the file.

The file is rolled back from the latest version to the referenced version.

Version

Displays the user who checked out the file. This is blank if the file is checked
in.

Checked
Out By

Displays the computer and local folder where the file is checked out, or
blank if not checked out.

Checked
Out In

Displays the vault folder containing the file.Found In

Displays the state of the file.State

Default. Redirects the parent references of
the rolled back versions.

YesRedirect
parent
references
of the file
to be
rolled back

Deletes the parent references of the rolled
back versions.

No
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Lets you type the rollback comment.Rollback
Comments

Lets you see the redirected or deleted referencing files of the rolled back
version.

Continue

Parent Reference Handling
Depending on the selection of Redirect parent references of the file to be rolled
back in the Rollback dialog box, the parent references of the rolled back child versions
are redirected or deleted.

Exports the details in Microsoft Excel as a
comma-delimited file.

Open File List

Saves the details in a text file.Save File List

Lists the file to roll back.File to Rollback

Lists the parent reference file names of the
file to be rolled back.

Parent File

Displays the affected versions of the parent
file separated by semi-colons.

Referencing Version or Versions

Displays the file path to the root vault.Relative File Path

Rolls back the selected files.Rollback

Searching Local Files
You can search local files that are added to the vault in offline mode.

To search local files in File Explorer, right-click inside the folder and click Search Local
Files.

In the Administration tool on the Menus page, administrators can modify the Search
Local Files menu option to appear to a user when they are viewing the files in Windows
Explorer.
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SOLIDWORKS PDM Client and Server Service Pack
Compatibility

SOLIDWORKS PDM allows a service pack mismatch between client and server components
within the same major version.

Previously, the client and server components had to have the same major version and
service pack.

SOLIDWORKS PDF Task Add-in
SOLIDWORKS PDM Professional provides a task add-in that lets users convert Microsoft
Office files and DWG/DXF format files to PDF files.

The SOLIDWORKS PDF Task Add-in provides the following tasks:

DescriptionTask

Converts Microsoft Word, Excel, and PowerPoint files.Office to PDF

Converts DWG/DXF format files.DraftSight to PDF

To convert files to PDF, users must have the following installed on the task host:

• Microsoft Office 2010 or later versions for Microsoft Office files.
• SOLIDWORKS DraftSight Professional/Premium for DWG/DXF format files.

For the DraftSight to PDF task to complete, you must disable SOLIDWORKS PDM
Add-in in DraftSight on the dedicated task host.

Accessing the SOLIDWORKS PDF Task Add-in
To access the SOLIDWORKS PDF Task Add-in:

1. In the Administration tool, load the SWPDFTaskAddIn.
a) Right-click the vault and click Import.
b) In the dialog box, navigate to drive letter:\Default Data.
c) Select the Draftsight_to_PDF_gb.cex and Office_To_PDF_gb.cex files, and

click Open.

2. Verify that execution of SOLIDWORKS PDF Task Add-in is permitted on the client
machine.

3. Configure the tasks.
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Configuring the Office to PDF Task
Administrators can configure the Office to PDF task to convert Microsoft Office files to
PDF files.

To configure the Office to PDF task:

1. In the Administration tool, expand Tasks and double-click Office to PDF.
2. In the dialog box, for Add-in, select SOLIDWORKS PDF Task Add-in.
3. In the left pane, set options:

DescriptionOption

Selects the computers that can execute the task.Execution Method

Specifies whether and how the command appears to
users in the File Explorer.

Menu Command

Maps variables from the source file's data card to the
output file's data card or adds Free Text to the output
file's data card.

File Card

Specifies the name and location of the output PDF file.Output PDF Details

Defines settings for Microsoft Word, Excel, and
PowerPoint files.

Office Options

Lets you select users and groups that are allowed to
initiate the task.

Permissions

Lets you select users and groups to notify.Success Notification and
Error Notification

Office to PDF Properties - File Card
Use the File Card page of the Office to PDF Properties dialog box to specify the mapping
of variables from the source file data card to the output file data card.

To display the Office to PDF Properties - File Card page:

1. Expand the Tasks node and double-click Office to PDF.
2. In the left pane, click File Card.
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DescriptionOption

Source variable

Variable used in source file data card.

Destination variable

Variable in output file data card that maps to Source
variable.

Variable list

Activates the Selected variable section so you can specify
variable mapping.

Add variable

Removes the selected variable mapping.Remove variable

Selected variable
Sets variable mapping.

DescriptionOption

Variable used in source file data card.Source variable

Text to display in the destination variable if you select Free
text as the source.

Free text

Variable in output file data card.Destination variable

Office to PDF Properties - Output PDF Details
Use the Output PDF Details page of the Office to PDF Properties dialog box to set up basic
properties for the PDF file such as the default path and vault log path.

To display the Office to PDF Properties - Output PDF Details page:

1. Expand the Tasks node and double-click Office to PDF.
2. In the left pane, click Output PDF Details.
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DescriptionOption

Default path

Location where converted PDF files are saved.

Build the output file path by typing static text and clicking

to select from the following dynamic variables:

• Source File Name
• Source File Extension
• Source Folder Path
• Vault Root Folder Path
• Source File Revision
• Source File Version
• Source File Workflow State
• Today's Date
• Variables

The example in the dialog box shows the currently selected
file format and path.

Allow the user to change the output path

Lets users change the output path during the task execution.

Primary output path

Second location where converted PDF files are saved.

Build the output file path by typing static text and clicking
to select from dynamic variables.

The example in the dialog box shows the currently selected
file format and path.

Secondary output path

When selected, the destination file contains a reference to the
source file.

To see the reference, select the output file in File Explorer and
view the Contains tab.

Create reference from
the destination file to
the source file

Replace existing files

Overwrites a file if a file of the same name already exists.

Create new version of existing files

Creates a new version of the file if a file of the same name
already exists.

Duplicate file name
handling

174

SOLIDWORKS PDM



DescriptionOption

Vault log path

Click Browse to build the vault log path.

Logging settings

Displays the Advanced Scripting Options dialog box, where
you can:

• Modify the VB script that controls the task.
• Change the user interface type used by the task.

Advanced Scripting
Options

Office to PDF Properties - Office Options
Use the Office Options page of the Office to PDF Properties dialog box to set options for
Microsoft Word, Excel, and PowerPoint files.

To display the Office to PDF Properties - Office Options page:

1. Expand the Tasks node and double-click Office to PDF.
2. In the left pane, click Office Options.

DescriptionOption

Page Selection

• All Pages

Selects all pages for the conversion.

• Page(s) From

Selects pages in the range.

Document Properties

Includes the document properties.

Document showing markup

Includes the document showing markup.

Allow user to change export settings

Lets users change the export settings.

Word
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DescriptionOption

Sheet Selection

• All Sheets/Entire Workbook

Selects all sheets for the conversion.

• Sheet(s) From

Selects sheets in the range.

Document Properties

Includes the document properties.

Ignore Print Areas in sheets if exist

Ignores print areas in sheets to convert the entire sheet.

Allow user to change export settings

Lets users change the export settings.

Excel
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DescriptionOption

Slide Selection

• All Slides

Selects all slides for the conversion.

• Slide(s) From

Selects slides in the range.

• Allow user to change the slide settings

Lets users change the slide settings.

Document Properties

Includes the document properties.

Frame Slides

Includes the frame slides.

Include hidden slides

Includes the hidden slides.

Allow user to change export settings

Lets users change the export settings.

PowerPoint

Configuring the DraftSight to PDF Task
Administrators can configure the DraftSight to PDF task to convert DWG/DXF format
files to PDF files.

To configure the DraftSight to PDF task:

1. Expand Tasks and double-click DraftSight to PDF.
2. In the dialog box, for Add-in, select SOLIDWORKS PDF Task Add-in.
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3. In the left pane, set options:

DescriptionOption

Selects the computers that can execute the task.Execution Method

Specifies whether and how the command appears to users
in the File Explorer.

Menu Command

Maps variables from the source file's data card to the output
file's data card or adds Free Text to the output file's data
card.

File Card

Specifies the name and location of the output PDF file.Output PDF Details

Defines the settings for DWG/DXF format files.Conversion Settings

Lets you select users and groups that are allowed to initiate
the task.

Permissions

Lets you select users and groups to notify.Success Notification
and Error Notification

DraftSight to PDF Properties - File Card
Use the File Card page of the DraftSight to PDF Properties dialog box to specify the
mapping of variables from the source file data card to the output file data card.

To display the DraftSight to PDF Properties - File Card page:

1. Expand the Tasks node and double-click DraftSight To PDF.
2. In the left pane, click File Card.

DescriptionOption

Source variable

Variable used in source file data card.

Destination variable

Variable in output file data card that maps to Source
variable.

Variable list

Activates the Selected variable section so you can specify
variable mapping.

Add variable

Removes the selected variable mapping.Remove variable
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Selected variable
Sets variable mapping.

DescriptionOption

Variable used in source file data card.Source variable

Text to display in the destination variable if you select Free
text as the source.

Free text

Variable in output file data card.Destination variable

DraftSight to PDF Properties - Output PDF Details
Use the Output PDF Details page of the DraftSight to PDF Properties dialog box to set up
properties for the PDF file such as the default path and vault log path.

To display the DraftSight to PDF Properties - Output PDF Details page:

1. Expand the Tasks node and double-click DraftSight to PDF.
2. In the left pane, click Output PDF Details.

DescriptionOption

Default path

Location where converted PDF files are saved.

Build the output file path by typing static text and clicking

to select from the following dynamic variables:

• Source File Name
• Source File Extension
• Source Folder Path
• Vault Root Folder Path
• Source File Revision
• Source File Version
• Source File Workflow State
• Today's Date
• Variables

The example in the dialog box shows the currently selected
file format and path.

Allow the user to change the output path

Lets users change the output path during the task execution.

Primary output path
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DescriptionOption

Second location where converted PDF files are saved.

Build the output file path by typing static text and clicking
to select from dynamic variables.

The example in the dialog box shows the currently selected
file format and path.

Secondary output path

When selected, the destination file contains a reference to the
source file.

To see the reference, select the output file in File Explorer and
view the Contains tab.

Create reference from
the destination file to
the source file

Replace existing files

Overwrites a file if a file of the same name already exists.

Create new version of existing files

Creates a new version of the file if a file of the same name
already exists.

Duplicate file name
handling

Vault log path

Click Browse to build the vault log path.

Logging settings

Displays the Advanced Scripting Options dialog box, where
you can:

• Modify the VB script that controls the task.
• Change the user interface type used by the task.

Advanced Scripting
Options

DraftSight to PDF Properties - Conversion Settings
Use the Conversion Settings page of the DraftSight to PDF Properties dialog box to set
options for DWG/DXF files.

To display the DraftSight to PDF Properties - Conversion Settings page:

1. Expand the Tasks node and double-click DraftSight to PDF.
2. In the left pane, click Conversion Settings.
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DescriptionOption

Overrides the current DraftSight settings and lets users change
settings.

Override current
DraftSight settings

All Sheets

Selects all sheets for the conversion.

Named Sheets

Selects named sheets.

Allow user to change settings

Lets users change the sheet settings.

Sheets

Standard

Lets you select the sheet size from the list.

Custom

Lets you set the Width, Height, and Units.

Paper size

Includes the document properties.Document Properties

Source File references

Uses the referenced version of the referenced files
when the task is triggered.

Use the referenced version of the
referenced files (as built)

Uses the latest version of the referenced files when
the task is triggered.

Use the latest version of the
referenced files

SOLIDWORKS PDM Web2 Viewer Enhancements
SOLIDWORKS PDM Professional enhances the viewing technology in the Web2 client for
SOLIDWORKS files and other common file types.

• SOLIDWORKS files. You can dynamically preview files in supported browsers such as
Microsoft Internet Explorer, Google® Chrome™, Mozilla® Firefox®, and Apple® Safari®
without loading plug-ins.
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Previously, you could dynamically preview files in Microsoft Internet Explorer with an
eDrawings ActiveX® plug-in only.

• Other common file types. The preview quality is more like viewing the file in its native
application.

You can no longer convert various file formats to PDF in the Web2 client.
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Vault Database Replication
SOLIDWORKS PDM Professional supports replicating a vault database that can improve
performance in high latency (typically more than 50 milliseconds) and high usage
environments.

Administrators can use Always On Availability Groups (AOAG) technology from Microsoft
SQL Enterprise edition 2012 or higher. For details, see
https://msdn.microsoft.com/en-us/library/ff878265.aspx.

For each availability group, AOAG maintains a single read-write primary database and
multiple read-only secondary databases. The primary SQL server updates the secondary
SQL servers periodically.

SOLIDWORKS PDM Web2 client and Web client cannot take advantage of the secondary
database.

You can create the secondary SQL servers over LAN and WAN to the primary SQL server.
Using AOAG, SOLIDWORKS PDM Professional can direct the read operations to the
secondary SQL server. This improves the performance in the following ways:

• Read operations are directed to the secondary SQL server, significantly reducing the
load on the primary SQL server so it can respond faster, and handle more load.

• For read operations, users access the secondary SQL database server instead of
accessing the primary SQL database. This speeds up read operations such as browsing
through vault folders, and accessing Data Cards, Contains, and Where Used information.

• In case of high latency between the client and primary SQL Server, having a secondary
SQL server locally to the client improves the performance for read operations.
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It is recommended to use synchronous-commit mode on the secondary SQL servers
that have very little latency to the primary SQL server.

All write operations are directed to the primary SQL server. During login, the user is
connected to the:

• Primary and secondary SQL servers if the secondary SQL server is reachable.
• Primary SQL server if the secondary SQL server is not reachable. In this case, the
primary SQL server handles all database operations for that session.

Configuring the Secondary SQL Servers
Use the Server Configuration dialog box to configure the secondary SQL servers.

To configure the secondary SQL servers:

1. In the Administration tool, expand Replication and double-click Database.
2. In the Database dialog box, click Add Server.
3. In the Server Configuration dialog box, in Server Name, select the secondary SQL

server name.
4. For Max. Lag from Primary, enter a value.
5. Click Add Member to assign users and groups.
6. Click Test Settings and OK.

Server Configuration Dialog Box
The Server Configuration dialog box lets you configure the secondary SQL server.

DescriptionOption

Lists secondary SQL server. Select from the list. This name
must be unique.

Use the IP address if SOLIDWORKS PDM is configured to
communicate using IP address.

Server Name

The maximum permissible lag between the primary and the
secondary SQL servers.

This value can vary from 1 minute to 60 minutes. If the actual
time lag exceeds the maximum value, all read and write
operations are directed to the primary SQL server only.

Decimals, zero, and negative values are not supported.

Max. Lag from
Primary
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DescriptionOption

Assigns users and groups to the secondary SQL server.

If you assign a user to a database through a group and the
user is explicitly assigned to another database, SOLIDWORKS
PDM directs the user to the database to which the user is
explicitly assigned.

If you assign a user to multiple secondary SQL servers through
group assignments or explicitly, SOLIDWORKS PDM directs the
user to the database to which the user is added most recently.

Add Member

Removes the selected users and groups.Remove Member

Verifies the following:

• The secondary SQL server name is unique.
• The vault database on the primary SQL server is replicated
on the secondary SQL servers.

• The username (sa) and the password for the primary and
secondary SQL servers are the same.

Test Settings
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20
SOLIDWORKS Plastics

This chapter includes the following topics:

• Automatic Valve Gates
• Configuration Improvements for PlasticsManager
• Customize Min and Max Values of Plots
• Faster Loading of Parts
• High Accuracy Cooling
• Plot of Part Mass Versus Time
• Solid Mesh Edit
• User Interface Improvements

SOLIDWORKS Plastics Standard, SOLIDWORKS Plastics Professional, and SOLIDWORKS Plastics
Premium are available as separately purchased products that can be used with SOLIDWORKS
Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium.

Automatic Valve Gates
An option automatically defines control valves so you can predict the control valve opening
times based on the melt front arrival.

Valve gates are used with hot runner systems to sequentially inject plastic at several
locations in the cavity. Plastics simulation can help determine the timing sequence for
opening each valve. Two options make these simulations easier.

In the Injection Location PropertyManager, click Automatically Add Valves to let the
program define control valves at the common interfaces between runners and cavities.
You no longer need to select mesh elements manually, when you activate this option.

By selecting Automatic under Valve Open Range, the control valve opens automatically
when the melt front passes the gate. You can then view the predicted opening times of
each control valve in the log file.
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Configuration Improvements for PlasticsManager
The associativity of configurations between the SOLIDWORKS software and SOLIDWORKS
Plastics is improved.

Configuration improvements include:

• Any updates you make in the ConfigurationManager, for example adding a new
configuration or switching between configurations, propagate to the PlasticsManager
tree.

• SOLIDWORKS Plastics supports derived configurations.
• Duplicate Study copies the plastics study settings to a new configuration.

Customize Min and Max Values of Plots
Improvements in plots include editing the Min and Max values outside the range of the
current data, and resetting the Min and Max back to the default values.

When comparing result plots from different simulations, you can set an appropriate plot
range (which could be outside the min and max values of the individual plot) to facilitate
the comparison and interpretation of results.

The default minimum and maximum limits are shown above the plot legend.

In the Results PropertyManager, click to reset the min and max values to their default
values.

Faster Loading of Parts
An option lets you control the loading of plastics analysis data when you open part
documents.

In the Settings PropertyManager, Load plastics data when .sldprt is opened is cleared
by default. Saved plastics simulation data is loaded with the activation of the
PlasticsManager tree.

Selecting Load plastics data when .sldprt is opened results in longer loading time
when opening sldprt files with saved plastic simulation data.

High Accuracy Cooling
The Cool analysis module is enhanced.

A solution option is available for the Cool analysis module which allows simulation of
cooling circuits with multiple inlets and outlets. All side passages without inlets or outlets
are considered dead ends. Select Coolant Flow Field under Boundary Conditions.
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Red arrow: Inlet; Blue arrow: Outlet; X: Dead end

After completion of the Coolant Flow Field analysis, new result plot options are available
for coolant velocity and coolant pressure.

Velocity of coolant system
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Mold Temperature at end of cooling

The mold open time is included in the Cool solver calculations. This accounts for the effect
of coolant circulating while the mold is open. The mold open time is listed under the Cycle
Time summary in the report.

Plot of Part Mass Versus Time
The Part Mass plot shows the part mass changes during the filling and packing processes.

The Part Mass plot includes only the cavity domains. Runner domains are excluded. The
part mass plot helps you determine when the cavity is fully packed so you can shorten
packing time to eliminate unnecessary additional packing of the sprue and runners.

You can also use the Part Mass plot along with the gate temperature plot to determine
the gate freeze and pressure holding time.

The first stage of packing will automatically end if the polymer flow rate
becomes nearly zero, and any remaining Pressure Holding Time will be

Automatic
Packing
Time added to the Pure Cooling Time to determine the new duration of the

second stage of packing. Polymer flow rate is monitored at the interface
between the runner and cavity domains, or at the injection locations if no
runner domain has been defined. The criteria for nearly zero flow rate is
satisfied when the rate of change of part mass falls below 0.01% per
second.

Settings

8 secPressure Holding Time
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Results

16.64 secCycle Time (= Filling Time + Total
time in Pack Stage)

0.62 secFilling Time

16.02 secTotal time in Pack Stage (=
Pressure Holding Time + Pure
Cooling Time)

4.52 secPressure Holding Time

11.50 secPure Cooling Time

Solid Mesh Edit
An option in the Solid Mesh - Manual PropertyManager maintains the previously defined
domain definitions when you create a solid mesh with the Manual method.

In the Solid Mesh - Manual PropertyManager, select Use Previous Design.

The program maintains the previous definitions for Cooling Channels, Runners, and Virtual
Molds, and proceeds to the step of surface mesh creation. This option saves you time as
you can modify the mesh for the cavity only, without redefining the domain assignments
in a model.

User Interface Improvements
Several improvements in the user interface enhance productivity.

• Icons next to the parameters' numeric fields are active, and restore the parameters'
default input values.

• The Polymer dialog box retains the custom size and location settings of the last display.
• Long names of polymer materials are fully displayed in the Polymer dialog box.
• Animation speed control is improved. The speed range is increased by a factor of 2.
• In the Runner Design Wizard PropertyManager, click Use draft angle to define a sprue
geometry with a given diameter dimension (D1) at the beginning of the sprue and a
draft angle to automatically compute the diameter at the end of the sprue geometry.
To reverse the dimensions for a selected sprue, click Flip Dimension.

• A more intuitiveWeld Line contour plot reflects the severity of the plastic melt fronts
intersection. On the Weld Lines contour plot, the locations on the cavity where the
plastic melt fronts meet at small (acute) angles are colored red. The locations where
the angles are large (obtuse) are colored blue.
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21
Routing

This chapter includes the following topics:

• Auto Route Enhancements
• Automatic Zoom to Fit Option on Adding Route Components
• Exploded View Tool
• Flatten Enhancements
• Pipe Nipples
• Quality Enhancements and Fixes for Routing
• Reusing Routes for Tubes and Hoses
• Securing Distinct Routes Through Clips

Available in SOLIDWORKS Premium.

Auto Route Enhancements
For orthogonal and flexible route types, Auto Route failures are automatically corrected
by repositioning the route.

Previously, you received an error message while using Auto Route, when the endpoints
were very close or the radius was too small for the geometry.

The Alternate paths solutions are listed in the Auto Route PropertyManager. A maximum
of seven solutions are provided at a time. You can access the alternate path solutions by
clicking in the Alternate paths box and then clicking in the graphics area to view the
manipulator. In the manipulator, you can right-click to change to the next possible solution
and left-click to accept the current solution offered.

Automatic Zoom to Fit Option on Adding Route
Components

You can set the behavior of the automatic Zoom to Fit tool after adding route components
in Electrical, Piping, and Flexible Tubing.

Previously, the Zoom to Fit tool was automatically enabled while adding route
components in the graphics area.

To set this option, click Tools > Options > Routing and select Automatically zoom
to fit after addition of route components.
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Exploded View Tool
You can create exploded views of Routing assemblies similar to SOLIDWORKS assemblies
using the Exploded View tool.

Previously, while using Exploded View in Routing, the fittings returned to their original
positions, changing the position of other pipe segments in the assembly.

The enhanced functionality covers the following:

• You can create exploded views at the subassembly level.
• You can create exploded views with the following types:

• Regular step
• Radial step

• You no longer receive an error message when you try to select a route part and drag
it while using Exploded View in Electrical, Piping, and Flexible Tubing.

• You can drag or select route parts in subassemblies or components similar to the way
that you can drag them in the top level assembly.

• You cannot use the Exploded View tool with flattened routes.

Flatten Enhancements

Enhancements in Edit Flattened Route
You can edit complex manufacturing-style flattened routes with the enhanced edit tools
in the Edit Flattened Route tool.

You can also access Edit Flattened Route from the shortcut menu of the flattened
configuration in the FeatureManager design tree.

The following aspects are enhanced:

• Temporary graphics.
• Manipulator to change bend angle and bend radius.
• Fixed point selection to determine which side of the route segment is to be edited.
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Flattened Disjointed Routes
The electrical flattening functionality allows disjointed routes in Manufacturing and
Annotation styles.

Previously, you received an error message while trying to flatten disjointed routes.

Display of disjointed routes is supported in flattened drawings.

A route is a disjointed route segment when a route assembly having multiple individual
routes that are not connected to each other, form a circuit-like system.
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Pipe Nipples
You can use Nipples for connecting two fittings in a route assembly.

A Pipe nipple is a short piece of pipe with a male pipe thread at both ends or either end.
Support for five types of pipe nipples is provided in the Routing Library Manager.

Five new types of Nipples are provided in the Design Library.

1. Barrel nipple
2. Hex nipple
3. Close nipple
4. Weld nipple
5. Hose nipple
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Quality Enhancements and Fixes for Routing

General Routing
• You can override the automatic creation of stubs when you Alt + drag-drop connectors
or fittings in the graphics area. You can:

• Insert parts without automatically starting a route.
• Mate or position the part before starting a route.

• The Sketcher Triad tool is available in Piping and Flexible Tubing. Previously, it was
only available in Electrical routes.

• Multiple instances of the same component are numerically referenced in the Wire
From-to List. For example, when a plug is in the top assembly and also in a
subassembly, both instances are uniquely referenced in the Wire From-to List.

Piping
You are notified with an error message that points out the junction, if a penetration is
missing at the junction of pipes.

Reusing Routes for Tubes and Hoses
You can reuse an existing tube route in the same assembly or in other assemblies. The
reused route uses the same part numbers, components, and lengths of hoses as the
original route, but different sketch paths as per the design intent.

To reuse routes for tubes:

1. In the FeatureManager design tree, right-click a flexible tube route assembly and

click Reuse Route or click Tools > Routing > Flexible Tubing > Reuse Route.
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2. In the PropertyManager:
a) Select Search all subassemblies.
b) Click Browse to search for an existing flexible tube route assembly to open the

route document.
c) Select Maintain route segment length.

The lengths of each route segment are assigned to each route segment of the
reused tube route assembly and the fixed length parameter is applied. All
configurations, if more than one exists, are applied to the reused route.

The reused tube route assembly inherits properties from the parent tube route
assembly, including custom properties and part number from configuration
properties. If the part number is blank in the parent, then the reused tube route
assembly uses the assembly name from the parent assembly.

If a reused route is in the same assembly as the original route, they are grouped
together in the BOM as if they are two instances of the same assembly.

Edits do not propagate from the reused route to the parent tube route
assembly. The reused route is a copy. To preserve the design intent
and keep the reused route from deviating from the parent, several
features are disabled. For example, you cannot add fittings or
assembly features to a reused route.

d) Click .

3. To change the design of the reused route from the parent, you can remove the link
between the reused and the parent routes by right-clicking the reused route in the
FeatureManager design tree and clicking Delink Route.
All Routing features are restored, the icon is removed, and the route is not grouped
with its parent in a BOM.

To edit the route paths of the routes, right-click the route and click Edit Route.

Securing Distinct Routes Through Clips
When you pass multiple routes through a clip, the individual wires are not bound together
and are offset from the clip axis.

To secure distinct routes through clips:

1. Open drive Letter:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS
2017\whatsnew\Routing\ClipRoutes\ClipRoutes.sldasm.

2. Right-click the clip and select the configuration 4-01 - 6.4mm Dia from the top
section of the shortcut menu.

3. Click .
4. In the FeatureManager design tree, right-click Route1 and click Edit Route.

5. Click Tools > Routing > Routing Tools > Route/Edit through Clip .
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6. Click any of the route segments and the Clip Axis.

The selected segment and Clip Axis are displayed in Current Selections, in the
PropertyManager.

7. In the PropertyManager:
a) Select Offset from Clip Axis.
b) Set Offset Distance to 10.

8. Click .
9. Repeat steps 6 through 7 for the second route.
10. In the PropertyManager:

a) Select Offset from Clip Axis.
b) Set Offset Distance to 5.

11. Click .
12. Repeat steps 6 through 7 for the third route.
13. In the PropertyManager:

a) Select Offset from Clip Axis.
b) Set Offset Distance to 2.

14. Click Auto Align .

All the routes are placed around the third route.

Auto Align bundles all routes close to the last modified route.

15. Repeat step 6 and click the Clip Axis.

Three routes appear in the PropertyManager, under Routes passing through clip.
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22
Sheet Metal

This chapter includes the following topics:

• Creating Three Bend Corner Reliefs
• Normal Cuts
• Punch Table Support for Mirrored and Derived Parts
• Sheet Metal Options

Creating Three Bend Corner Reliefs
You can create corner reliefs where three bends meet at one common point. The corner
relief is applied at the common intersection point of the bend lines.

To create three bend corner reliefs:

1. Open drive letter:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS
2017\whatsnew\sheet metal\bracket.sldprt.

2. Click Corner Relief (Sheet Metal toolbar) or Insert > Sheet Metal > Corner
Relief.
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3. In the PropertyManager:
a) Under Corner Type, select 3 Bend Corner.

To create a three bend corner, the model must have three bends where the bend
lines meet exactly at one point.

b) Under Corners, click Collect all corners.

c) Under Relief Options, click Circular and set Diameter to 4.
Three bend corner reliefs can have rectangular, circular, tear, or full round reliefs.

d) Click .

Reliefs are added to the corners.
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Normal Cuts
The Normal cut option in the Cut-Extrude PropertyManager is improved and delivers
better results.

For sheet metal parts with extruded cut features created prior to SOLIDWORKS 2017,
select Normal cut and Optimized geometry in the Cut-Extrude PropertyManager to
take advantage of the enhanced functionality.

The geometry now produces smoother results. The following example shows an extruded
cut based on a circular sketch.

SOLIDWORKS 2016SOLIDWORKS 2017

Punch Table Support for Mirrored and Derived Parts
For drawings of mirrored and derived sheet metal parts, punch information is supported
in punch tables.

For example, if you create a drawing view of a mirrored sheet metal part, any forming
tools or library features in the mirrored part are available in punch tables.

When creating a derived part, you must select Sheet metal information in the Insert
Part PropertyManager.

See Retrieval of Sheet Metal Components on Drawings on page 91.

Sheet Metal Options
You can define the default behavior that controls whether sheet metal bodies follow the
parameters defined in the Sheet Metal folder in the FeatureManager design tree.

The Sheet Metal folder in the FeatureManager design tree contains sheet metal
definitions for individual sheet metal bodies. In this folder, you can define common sheet
metal parameters for all bodies or have individual settings for each body. The following
options let you control the default behavior for newly created sheet metal bodies - whether
sheet metal definitions follow the Sheet Metal folder settings or not.

You can save these options in a template because they are document specific.

In Tools > Options > Document Properties > Sheet Metal, under New Sheet Metal
Bodies, select:
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• Override default parameters
• Override bend allowance parameters
• Override auto relief parameters

When selected, these options override the Sheet Metal folder parameters. In the individual
sheet metal body PropertyManagers, the corresponding Override default parameters
check boxes are selected. When all options are cleared, all individual body sheet metal
parameters are driven by the settings in the Sheet Metal folder.
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23
SOLIDWORKS Simulation

This chapter includes the following topics:

• Automatic Update of Beam Joints
• Converting a Static Study to a New Study
• Detecting Stress Hot Spots
• Displaying SOLIDWORKS Simulation Results in the Graphics Area
• Editing Multiple Contact Sets
• Improved Arc Length Control Method for Nonlinear Contact Analysis
• Intelligent Solver Switch
• Managing Dynamic Analysis Results
• Macro Recording in Simulation
• Mass Properties in Simulation
• Offloaded Simulation
• Performance Improvements for SOLIDWORKS Simulation
• Post Processing Improvements for SOLIDWORKS Simulation
• Probing Results at Selected Nodes
• Remote Loads and Mass for Beams
• Self-dismissed Solver Messages

SOLIDWORKS Simulation Standard, SOLIDWORKS Simulation Professional, and SOLIDWORKS
Simulation Premium are available as separately purchased products that can be used with
SOLIDWORKS Standard, SOLIDWORKS Professional, and SOLIDWORKS Premium.

Automatic Update of Beam Joints
When you make design changes to structural members that mesh with beam elements,
you do not need to recalculate the existing definitions of beam joints in a Simulation
study. The program automatically updates the beam joints when you switch to the
Simulation study tab.

In the System Options - General dialog box, select Automatically update beam joints
when study is activated.

During the design process, you can change weldment features in the Model tab such as
profile, length, beam rotation angle, suppress or unsuppress status, and conversion to
solid body.

The program recalculates the beam joint definitions of the updated weldments when you
switch to the Simulation study tab.
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Converting a Static Study to a New Study
You can copy a static study to a new linear dynamic study or nonlinear study. Only
supported boundary conditions are transferred to the new study.

To convert a Static study to a new study:

1. In a static study tree, right-click the top icon, and click Copy Study.
2. Under Source Study, select the source static study to copy to a new target study.
3. Under Study name, type the name of the new study.
4. Under Configuration to use, select the configuration linked to the target study.
5. Under Target Study, select one of the available study types Static, Nonlinear, or

Linear Dynamic.

6. Click .

All admissible loads and boundary conditions are copied to the new target study. The
program issues warning messages when features of the source static study, such as
connectors and loads, are not transferred to the target study due to limitations.

You may still need to define time or frequency dependent loads for the target study
to run the analysis.

Detecting Stress Hot Spots
The Stress Hot Spot diagnostics tool detects regions of the model that exhibit the highest
stresses.

Available for static studies.

Right-click the Results folder and click Stress Hot Spot Diagnostics.

The highest stresses in the areas of concern can be attributed to stress singularities due
to geometry features such as sharp corners, point loads, or fixed boundary conditions.

Stress singularities are divergent in nature, meaning that by reducing the mesh size, you
expect the value of stress singularities to increase to the theoretical value of infinity.
Legitimate stress concentration values are convergent in nature, and they reach a steady
value as you refine the mesh.

When stress hot spots are detected, you can view these areas of the model with a stress
hot spot plot which shows the variation of the von Mises stresses. You can specify a
custom color (default color is gray) for stress values larger than the threshold value that
triggers the hot spot detection.

Click Isolate Stress Hot Spots in the Stress Hot Spot PropertyManager to show only
the areas identified as stress hot spots.

203

SOLIDWORKS Simulation



Displaying SOLIDWORKS Simulation Results in the
Graphics Area

You can display SOLIDWORKS Simulation results in the SOLIDWORKS graphics area along
with other components or bodies in the model that are not part of the simulation.

This way, you do not have to switch between the simulation results and the modeling
environment. It is not ideal to display simulation results on bodies and components. This
display helps with marketing purposes and predictive design. Previously, if you ran a
simulation on a component in an assembly, only the component was shown with the
results and all other components were hidden.

An example of predictive design is making model changes based on simulation results.

Available with SOLIDWORKS Simulation licenses.
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To display SOLIDWORKS Simulation results in the graphics area:

1. Open drive letter:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS
2017\whatsnew\model_display\sunglasses.sldasm.
If the Resolve Lightweight Components dialog box appears, click OK. The assembly
has a simulation study saved with it.

2. Click the Static 1 tab.

3. In the Simulation Study tree, right-click Static 1 and click Run.
4. Click the Model tab.

5. Click Simulation Display (View toolbar) or View > Display > Simulation
Display.

If the Simulation Display dialog box appears, click OK.

6. In the PropertyManager:
a) Under Selected Result, select Displacement1.

b) Click .
The assembly is displayed with the simulation results in the context of the assembly.

The Simulation Display command only lists result plots for the studies for which
you have loaded all simulation data. To load all simulation data, click Simulation >
Options > System Options > General and select Load all Simulation Studies
when opening the model (requires more time to open a model). You can
also load simulation data for a specific study by clicking individual simulation tabs.
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Editing Multiple Contact Sets
You can select multiple contact sets in a single step to modify their common properties.
You can convert multiple contact sets to a common contact type that is different from
their original settings.

The time it takes to edit multiple contact sets is reduced by allowing the selection and
modification of multiple contact sets in one step.

Select more than two contact sets and click Edit Definition. When you select multiple
contact sets of the same type, the properties of the first contact set propagate to the
rest.

When you select contact sets with mixed types, the type of contact you select in the Edit
Multiple Contact Sets PropertyManager applies to all selected contact sets. All contact
sets are converted to a common contact type. The admissible pairs of contact sets for
conversion are referenced below.

Virtual WallShrink FitAllow
Penetration

No
Penetration

Bonded

N/AYesYesYesYesBonded

N/AYesYesYesYesNo
Penetration

N/AYesYesYesYesAllow
Penetration

N/AYesYesYesYesShrink Fit

YesN/AN/AN/AN/AVirtual Wall

Bonded
(Thermal)

Insulated (Thermal)Thermal
Resistance
(Thermal)

YesYesYesThermal Resistance
(Thermal)

YesYesYesInsulated (Thermal)

YesYesYesBonded (Thermal)

If you select mixed contact sets (for example, virtual wall and no penetration contacts)
that are not eligible for a group conversion to another contact type, the software prompts
you for a corrective action.
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Improved Arc Length Control Method for Nonlinear
Contact Analysis

You can analyze the buckling behavior of any structure more accurately with the inclusion
of no penetration contacts between components that may come into contact during the
analysis.

The Arc Length Control method supports nonlinear static studies with no penetration
contact definitions. 2D Simplification Nonlinear studies also support the improved Arc
Length Control Method.

The table lists the features supported by the Direct Sparse and Intel Direct Sparse solvers
for each Control method.

Arc Length ControlDisplacement
Control

Force Control

YesYesYesForce

NoNoYesPrescribed
Displacement

YesNoYesNo Penetration
Contact

NoNoYesForce + Prescribed
Displacement

NoNoYesPrescribed
Displacement + No
Penetration Contact

YesNoYesForce + No
Penetration Contact

NoNoYesForce + Prescribed
Displacement + No
Penetration Contact

Neither the Arc Length nor the Displacement Control method can resolve rigid body
motions that can occur during a nonlinear solution. If you encounter a rigid body motion
during a nonlinear analysis, use the Force Control method with a Prescribed displacement
to improve chances of reaching convergence.

Intelligent Solver Switch
The software can automatically select the most robust solver for Nonlinear studies.

In the Nonlinear - Static dialog box, under Solver, select Automatic Solver Selection.
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The program selects the most robust between two solvers depending on the size of the
model and available RAM:

• Intel Direct Sparse solver. For small and medium size models with slim geometry. The
Intel Direct Sparse solver requires more RAM than the FFEPlus Iterative Solver.

• FFEPlus Iterative Solver. For medium size models with bulky geometry, and large
models.

Managing Dynamic Analysis Results
The management of large result files from Linear Dynamic Studies is improved.

To reduce the file size of analysis results for linear dynamic studies, in the Result Options
PropertyManager, click Nodal von Mises stress only (Faster).

After the analysis completes, only the von Mises stress component is available for plotting.

Improved algorithms allow for a faster retrieval of sensor-tracked results.

Macro Recording in Simulation
You can record operations performed with the SOLIDWORKS Simulation user interface
in a macro script.

With macro recording you can capture these tasks for static and nonlinear studies:

• Create studies
• Define study properties (static studies)
• Apply material
• Apply loads and boundary conditions
• Create Mesh and Mesh Control
• Run the study
• Create Plots

Following is a list of loads and boundary conditions supported for macro recording:

Pressure, Gravity, Centrifugal, Bearing load, Temperature, Convection, Heat flux, Heat
power, Radiation, Distributed mass, Uniform and selected base excitation, Fixtures, Drop
test setup, Manual contact definitions (only with entity selection not automatically detected
contacts), and Component contacts.

Macro operations are accessed from the Macro toolbar or the Tools > Macro menu.
Recorded macros are saved as .swp Visual Basic for Applications (VBA) project files.

Mass Properties in Simulation
You can calculate mass properties of all or selected bodies included in a Simulation study.

Right-click the top icon in the Simulation study tree, and click Mass properties.

The Mass Properties tool considers:

• Solid, beam, and sheet metal bodies with their material definitions assigned in
Simulation.
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• Thicknesses assigned to shell and surface bodies.
• Composite shells with assigned materials.
• Remote masses.
• Masses added with bolt and pin connectors.

These properties are calculated: mass, volume, surface area, center of mass, and principal
moments of inertia (taken at the center of mass).

Offloaded Simulation
You can offload running a simulation to another computer connected on your local network
domain. By offloading a simulation, you can continue working with SOLIDWORKS in the
coordinator computer executing parallel tasks.

Available for SOLIDWORKS Simulation Premium license and for static and nonlinear
studies.

Offloaded simulation distributes the equation solving part of the simulation process to a
worker agent computer that is connected on the same network domain.

To offload a simulation you need:

• A computer running SOLIDWORKS Simulation Premium to act as the coordinator.
• A computer with the SOLIDWORKS Simulation Worker Agent installed and active
to act as the worker agent.

• A network connection between the coordinator and worker agent.

You create a static or nonlinear simulation study on the coordinator. The task of solving
the simulation equations is performed on the worker agent. The contact detection during
the analysis is performed on both worker agent and coordinator computers.

While the worker agent processes the Simulation, you can continue working with
SOLIDWORKS on the coordinator computer. You view and post-process the simulation
results on the coordinator computer.

Only the coordinator computer needs a license of SOLIDWORKS and SOLIDWORKS
Simulation Premium.
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Running an Offloaded Simulation
To run an offloaded Simulation the coordinator and the worker agent machines must be
on the same network domain. The SOLIDWORKS Simulation Worker Agent is installed
and activated on the worker agent computer.

To run offloaded simulation:

1. For the worker agent computer on the network:
a) From the SOLIDWORKS Installation Manager, install the SOLIDWORKS

Simulation Worker Agent client.
The Intel

®
MPI Library Hydra Process Manager (includes Intel’s Message Passing

Interface MPI executables) is installed which establishes communication protocols
between the coordinator and worker agent machines to execute successfully an
offloaded simulation.

b) Run SOLIDWORKS SimulationWorker Agent from the Windows Startmenu.
(SimulationWorker Agent default installation folder: drive letter:/Program
Files\Common Files\SOLIDWORKS Shared\Simulation Worker Agent). Click
Activate Worker Agent. The worker agent computer is now ready to run an
offloaded simulation.

To change the temporary folder location, click Deactivate Worker Agent, and
edit the folder location where temporary files are stored.
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2. For the coordinator computer on the network:
a) Create a static or nonlinear Simulation study.
b) Click Manage Network (Simulation CommandManager). In the User Account

Control dialog box, click Yes to allow SOLIDWORKS Simulation Network Share
to make changes to your computer. Type your Windows log-in password for the
first time you run an offloaded simulation on the coordinator computer.

In the SOLIDWORKS Simulation Network Manager, all worker agent machines
with the SOLIDWORKS Simulation Worker Agent installed and activated are listed.
The coordinator computer is highlighted in green at the top of the list. Click
Refresh to update the list of available worker agents detected in the network.

c) Click Offloaded Simulation (Simulation CommandManager).

The solver switches to Intel Network Sparse.

d) From the list of available worker agents on the network, select one to process
the offloaded simulation, and click OK.
If the SOLIDWORKS Simulation Network Manager does not detect any worker
agents, make sure at least one worker agent computer is on and the worker agent
is active; the coordinator and worker agent machines must be on the same
subnetwork.

Computers highlighted in red are not usable because they are either worker
agents that are running offloaded Simulation jobs, or act as coordinators and
are sharing the Simulation folder for other offloaded simulations that are in
process.

e) Run the study.

Once the offloaded simulation is running, the status of the selected worker agent
computer changes from idle to active. Information about the status of the offloaded
simulation is shown in the SOLIDWORKS Simulation Worker Agent window.

When the offloaded simulation completes, the Simulation Worker Agent client
copies the result files back to the coordinator computer's hard drive.

• You do not need to install SOLIDWORKS or SOLIDWORKS Simulation on the
worker agent computer to run offloaded simulation.

• You do not need to install the SOLIDWORKS Simulation Worker Agent client on
the coordinator computer, unless you plan to use the coordinator computer as
a worker agent.

• To check that both the coordinator and worker agent computers are on the same
network domain, open a Windows Command Processor window, and run the
command net view. This command returns a list of computers on the same
subnetwork with the one being used to run the command. Both computers,
coordinator and worker agent, should appear on the list to run an offloaded
simulation.

• Make sure that the Windows Firewall does not block the executables of offloaded
Simulation: mpiexec.hydra.exe, hydra_service.exe, and pmi_proxy.exe
located in drive letter:\Program Files\Common Files\SOLIDWORKS
Shared\Simulation Worker Agent. If you are still unable to run an offloaded
simulation, consider turning off the Windows Firewall for the network domain.
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Performance Improvements for SOLIDWORKS
Simulation

Several improvements in the areas of graphics, meshing, and contact formulation enhance
the overall performance of the Simulation product.

• The symbols for Pin connectors are redesigned. With the redesigned symbols, you can
identify in the graphics area the type of pin connector (with retaining ring or key)
without opening the pin connector's PropertyManager.

Symbol for pin with key (no rotation)Symbol for pin with retaining ring
(no translation)

• Pre-load symbols for bolts identify the axial or torque applied pre-load.

Symbols for bolts with axial preloadSymbols for bolts with torque
preload
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• Failure indices for the composite shells failure criteria (Tsai-Hill, Tsai-Wu, and Maximum
Stress) are calculated from nodal stresses. Previously, the failure indices were calculated
from elemental stress values.

• The blended curvature based mesher supports h-adaptive and p-adaptive methods.
• Optimized memory allocation and multi-threaded support for the Intel compilers improve
the performance of studies with surface to surface bonding and no penetration contact
definitions. The time spent by the program on the formulation phase for bonding and
no penetration contacts is reduced.

• Notable performance improvement on reducing the FFEPlus iterative solver solution
time for static studies.

Post Processing Improvements for SOLIDWORKS
Simulation

Several improvements in post processing of results and plot viewing enhance productivity.

• With the addition of the Synchronize Views tool in the Compare Results mode,
the synchronization of view orientation and size of the model (pan, zoom, and rotate)
is automatic among all the view panes.

• In the Compare Results dialog box, click Save image as to save the active multi-pane
result plots to a *.png, *.jpg, or *.bmp file format.

• You can set the maximum value of a stress plot to the material's yield stress value.
Click the down arrow of the maximum value box, and select Yield Strength: xxx.

• In a results plot's chart legend, you can: (a) click Reset color above maximum to

default to reset the custom color applied to the results above a given maximum

back to the default color, (b) click Reset color below minimum to default , or
(c) click the top or bottom color swatch outlined by a box to set a custom color.

• You can easily toggle the display of mode shapes in the graphics area. At the bottom
of the mode shape legend, click << to display the previous mode shape, and >> to
display the next mode shape.

• Right-click Results and click Compare Modes to compare selected modes up to
a maximum of four (available for frequency, linear dynamic, and buckling studies).

Click Mode Selection Filter to select the number of modes to compare.
• You can save the deformed geometry of a model as a tesselated body, surfaces only,
or mesh formats. In the Body from Deformed Shape PropertyManager, expand
Advanced Export, and select one the available options.

Probing Results at Selected Nodes
After you run a Simulation, you can probe results at nodes identified by their node number.
The nodes you select from List Result and Probe Result PropertyManagers are highlighted
on the model with their annotations.

To probe results at selected nodes:

1. In the Probe Results PropertyManager, under Options, select At Node number.
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2. Type the number of a single node or a range of nodes, for example 1000-1020.
The locations of the selected nodes with their annotations are visible in the graphics
area.

3. Under Report Options, click Capture Image .
4. Save the active view of the model in *.png , *.jpg or *.bmp file format.

Remote Loads and Mass for Beams
You can define remote loads, remote mass, and distributed mass over beams.

All available options related to remote load, remote mass, and distributed mass in the
Remote Loads/Mass PropertyManager extend to studies with beam elements.

You can convert a solid body to a remote mass and transfer the remote mass to a beam

element. In the Treat as Remote Mass PropertyManager, select Joints or Beams .

Available for Static, Frequency, Buckling, and Linear Dynamics studies.
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Self-dismissed Solver Messages
During a Simulation run, solver messages that prompt you with a choice of action
automatically time out.

Click Simulation > Options > System Options > General and select Automatically
timed out decision solver messages after n seconds.
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24
Sketching

This chapter includes the following topics:

• Creating Sketch Offsets on 3D Geometry Surfaces
• Enhancements to the Segment Tool
• Prevention of Accidental Micro Lines
• Shaded Sketch Contours
• Extruding Shaded Sketch Contours

Creating Sketch Offsets on 3D Geometry Surfaces
You can use the Offset on Surface tool to offset 3D model edges and model faces in a
3D sketch.

Previously, you had to create extra features for offsetting an edge.

To create sketch offsets on 3D geometry surfaces:

1. Open drive Letter:\Users\Public\Public Documents\SOLIDWORKS\SOLIDWORKS
2017\whatsnew\Sketching\CurvedSurface.sldprt.

2. Click Offset on Surface (Sketch toolbar) or Tools > Sketch Tools > Offset on
Surface.

3. In the graphics area, select the edge of Surface-Loft4 as shown.
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4. In the PropertyManager:
a) Set Offset Distance to 10.
b) Select Reverse.

The entity is projected on the opposite face.

You can only use Reverse when the selected edge is connected to faces that
belong to the same body.

5. Select the interior edges of Surface-Loft5 and Surface-Loft3.

6. Click .
7. Double-click the dimension value of the three edges and enter 30 in the dimension

input value box.

8. Click Offset on Surface .
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9. In the PropertyManager:
a) Click Surface-Loft5 in the graphics area.
b) Set Offset Distance to 20.

c) Click .

All edges of Surface-Loft5 are offset.

Enhancements to the Segment Tool
You can use the Segment tool to create equal length segments in splines, parabolas,
ellipses, partial ellipses, and conics.

Previously, the Segment tool was available for circles and arcs only.

When you use the Segment tool for splines, parabolas, ellipses, partial ellipses, and
conics:

• Equidistant relations are created in a single Segment operation.
• The equidistant relation is replaced by a coincident relation after the equidistant relation
is deleted from a single Segment operation.
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Prevention of Accidental Micro Lines
A dynamic buffer zone helps to maintain a consistent zone in which the click-click sketch
mode results in the expected geometry with fewer cases of accidental micro lines.

Previously, the creation of accidental micro lines caused open contours, so you could not
use the sketch for creating a feature.

Shaded Sketch Contours
You can use the Shaded Sketch Contours setting to view closed sketch contours and
sub-contours as shaded entities. You can drag, resize, and apply relations to shaded
sketch contours.

Previously, you had to use the Move tool to drag sketch contours.

When you select the Shaded Sketch Contours setting, only the closed sketch shapes
are shaded. This makes it easier to tell if a shape is fully closed or not.

Contours and sub-contours
Contour. A contour is a closed shape.

Sub-contour. A sub-contour is the contour that is formed when you combine contours
together.

The Shaded Sketch Contours setting lets you:

• Drag the shaded area.
• Apply relations to entities.
• Make blocks of the shaded sketch selections with the Make Block tool on the shortcut
menu.

• Use the Extruded Boss/Base tool on the context toolbar by right-clicking the shaded
sketch.

• Use shaded contours as input for the Mirror Entities and Offset Entities tools.

The Shaded Sketch Contours tool is available only for new sketches in SOLIDWORKS
2017.
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Extruding Shaded Sketch Contours
To extrude shaded sketch contours:

1. In sketch mode, click Shaded Sketch Contours (Sketch Toolbar) or Tools >
Sketch Settings > Shaded Sketch Contours.

Use Shaded Sketch Contours to turn-off the tool.

2. Sketch three concentric circles inside a rectangle.

The outermost circle is the lightest and the innermost circle is the darkest shade of
blue.

3. Click any sub-contour of the sketch entity and drag it.

The whole sketch entity moves.
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4. Press Alt and click a shaded area.

The Extruded Boss/Base tool appears on the context toolbar.

5. Click Extruded Boss/Base.

6. Set options in the PropertyManager and click .

The shaded area is extruded.
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25
SOLIDWORKS Toolbox

This chapter includes the following topics:

• Purging Inactive Toolbox Configuration Data
• Resizing PEM Fasteners
• Updating Toolbox Components in Assemblies

SOLIDWORKS Toolbox is available in SOLIDWORKS Professional and SOLIDWORKS Premium.

Purging Inactive Toolbox Configuration Data
The Toolbox Settings Purge Inactive Data tool lets you purge inactive configuration
data from Toolbox part files.

By removing unused data that increases file size, Purge Inactive Data improves
performance for actions like opening the Insert Component PropertyManager.

Inactive configurations are configurations that are not listed in Toolbox Settings and are
not in the part file. If a configuration existed in the past and was used in an assembly, it
is still considered active even if it is not listed in the configuration list in Toolbox Settings.

Purge Inactive Data purges the following data from inactive configurations:

• Custom properties
• Configuration names
• Designations
• Part numbers
• Descriptions
• Comments

The command does not:

• Purge geometry data or active configuration data.
• Affect custom configurations you create using the Insert Component PropertyManager
when you insert a Toolbox part into an assembly.

It is highly recommended that you back up your data before purging inactive data.

To purge inactive Toolbox configuration data:

1. From Windows, click Start > All Programs > SOLIDWORKS version >
SOLIDWORKS Tools > Toolbox Settings .

2. In the Toolbox dialog box, click 2 Customize your hardware.

222



3. Expand the hardware display to the level where you want to purge inactive data.
You can purge at the folder level or on a part-by-part basis.

4. Click Purge Inactive Data.
5. In the Purge Inactive Data dialog box, expand Options and select from the following:

• Purge inactive configuration data from disabled hardware. Available if you
purge at the folder level. Purges data from enabled and disabled configurations.

• Save Purge Report. Browse to the location to save the report. Generates a purge
report summarizing the results of the data operation. The report is a tab delimited
text file that you can open in Microsoft Excel.

The file name is in the following format:

hierarchical address of the selected component data purge results
date and time stamp

For example:

Ansi Inch_bolts and screws_hex head data purge results
-2016-03-25_01-55-02-PM.txt

6. Click one of the following:

• Yes, purge all inactive configuration data. A progress bar indicates that the
purge is taking place.

Folders or parts containing large numbers of configurations may take a long time
to purge.

• No, do nothing and cancel the operation. The dialog box closes without purging
any data.

Resizing PEM Fasteners
When you insert PEM fasteners, the outer diameter of the collar matches the inner diameter
of the hole.

To resize PEM fasteners:

1. In the Configure Component PropertyManager for a mated fastener, select Autosize
to mated geometry.

2. Rebuild the assembly containing the fastener.

The software updates the fastener size.

If the fastener was correctly sized, the software does not make any changes.

Updating Toolbox Components in Assemblies
You can update all Toolbox components in a single action.

When an assembly contains Toolbox components at the top level or in a subassembly,
the assembly shortcut menu includes an Update Toolbox Components menu item.
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Depending on the assembly structure, a flyout submenu give you options to update:

• Top Level Assembly Only
• Sub-level Assemblies Only
• All Assembly Levels

To see the Update Toolbox Components item, Toolbox components must be present
and you must select the SOLIDWORKS Toolbox Library Add-in.

You can update:

• Toolbox parts that were created using the Toolbox editor.
• User created parts that were added to Toolbox and are driven by a design table,
configured feature, or configured dimension.

• Copied Toolbox standards.

You cannot update:

• Suppressed Toolbox components.
• Parts that were Toolbox components but have had their Toolbox flags removed.
• Toolbox components in a Smart Fasteners folder.

Newly added custom properties are not applied to active configurations. Each component
with a newly added custom property is flagged with a warning. You must manually edit
the component to correct the warning.

To update Toolbox components in assemblies:

1. In the FeatureManager design tree, right-click the top level assembly, click Update
Toolbox Components, and choose a submenu option.

A message warns you that the operation cannot be undone and that the process may
be lengthy.

2. Click OK.

The software copies data and dimensions updates from the Toolbox Settings master
part file and applies them to the active configurations in the appropriate level of the
active assembly.

3. To save the updates, save the assembly.
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26
SOLIDWORKS Visualize

This chapter includes the following topics:

• Installing SOLIDWORKS Visualize
• SOLIDWORKS Visualize Add-in
• SOLIDWORKS Visualize Boost
• Geometry Opacity and Animation Support
• Context Sensitive Help
• Creating Section Views
• Home Screen
• Pivot Point Snapping
• Using SOLIDWORKS Camera Navigation and Shortcuts
• Additional Enhancements

Installing SOLIDWORKS Visualize
SOLIDWORKS Visualize is available from the SOLIDWORKS Installation Manager.

SOLIDWORKS Visualize allows you to render high-quality images from files created in
SOLIDWORKS and other design tools. You can install, update, and remove SOLIDWORKS
Visualize using the Installation Manager. It requires an additional serial number, and is
usually installed on a computer that is running the SOLIDWORKS software.

SOLIDWORKS Visualize now supports SolidNetWork Licensing (SNL) license types (floating),
as well as offline activations.

Previously, you could only install SOLIDWORKS Visualize from a separate installation
package.

SOLIDWORKS Visualize Add-in
The SOLIDWORKS Visualize add-in, which is available in all versions of SOLIDWORKS,
lets you export SOLIDWORKS features directly to SOLIDWORKS Visualize.

You can export the following SOLIDWORKS features:

• Geometry
• Appearances
• HDR lighting
• Decals
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With SOLIDWORKS Professional, you can also export motion studies.

Animation export is limited to rigid body, camera, and appearance animations.

The following commands are available in the add-in:

• Export Simple saves a copy of the model and loads it into SOLIDWORKS Visualize
using Appearance mode part grouping.

• Export Advanced saves a copy of the model and loads it into SOLIDWORKS Visualize
with Automatic mode part grouping and Monitor File enabled. You can also upload
motion studies if you are using Visualize Professional.

• Update exports the latest version of the model and triggers an update in SOLIDWORKS
Visualize. This button is grayed out until you click Export Advanced for the first time.

• Save Advanced saves a copy of the model and motion studies to a specific location,
so you can later import the model into SOLIDWORKS Visualize.

SOLIDWORKS Visualize Boost
SOLIDWORKS Visualize Boost is a service that allows you to distribute rendering from a
computer running SOLIDWORKS Visualize Professional to one or more computers on a
network.

You can perform other tasks on your machine while the rendering is being carried out,
and the final rendered images are available sooner. Images can be rendered on a single
machine, or on a cluster of several machines running Visualize Boost.

One complimentary license of SOLIDWORKS Visualize Boost is included with each
SOLIDWORKS Visualize Professional on active subscription. Additional seats of Visualize
Boost are available for purchase.

Installing Visualize Boost with SLDIM
You install Visualize Boost using the SOLIDWORKS Installation Manager. It requires a
separate serial number.

Because the purpose of Visualize Boost is to offload rendering, you should install Visualize
Boost on computers different from the ones running SOLIDWORKS Visualize Professional.
Rendering performance can be maximized by installing Visualize Boost on computers with
multiple CPU cores and graphics processing units (GPUs).

To install SOLIDWORKS Visualize Boost:

1. Start the SOLIDWORKS Installation Manager.
2. On the Welcome page, select Individual.
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3. Do the following:
a) On the Serial Number page, expand Visualization.
b) Select SOLIDWORKS Visualize Boost and type the serial number.
c) Click Next.

4. Follow instructions for system warnings and click Next.
5. On the Summary page, accept the terms of the SOLIDWORKS License Agreement

and click Install Now.

Double-click the SOLIDWORKS Visualize Boost shortcut icon on the desktop to open the
interface.

Activating the Visualize Boost License
You must activate and configure SOLIDWORKS Visualize Boost through a web interface
before you can use the product for rendering. Chrome, Firefox, or Internet Explorer
browsers are supported.

After you activate and configure Visualize Boost, it launches automatically at system
startup and runs in the background. No further action is required.

To activate the SOLIDWORKS Visualize Boost license:

1. Do one of the following:
a) From your desktop, double click the Visualize Boost shortcut icon.
b) Open a browser and enter the URL: http://localhost:8993/config.html.

2. Enter an email address and click Enable License.

Configuring Visualize Boost
For most networks, the default settings are sufficient to configure a computer for Visualize
Boost, but if your network environment requires other settings, follow these steps to
manually configure a computer.

To configure a computer to be part of a rendering cluster in Visualize Boost:

1. Do one of the following:
a) If your system is running SOLIDWORKS Visualize Boost, double click the Visualize

Boost shortcut icon on your desktop or open a browser and enter the URL:
http://localhost:8993/config.html.

b) If you are on a different system, open a browser and enter the URL: http://<IP
Address>:8993/config.html or http://<DNS name>:8993/config.html.

2. Select your Language from the drop-down list in the upper right corner of the screen.
3. Click the Setup tab to configure the Visualize Boost node.
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4. In the Cluster Name field, specify a computer name, such as Superfast Render,
Presentation Cluster, or 4th Floor Computers.

The cluster name displays in SOLIDWORKS Visualize Professional as a cluster profile.
To render an image, users running SOLIDWORKS Visualize Professional select a cluster
profile from a list of available Boost clusters.

It is recommended that you specify the cluster name on the Visualize Boost
computer, rather than locally on the Visualize Professional computer, so that all
Visualize users have access to the same cluster names in their Visualize Boost
Profiles list.

5. Enter the Cluster Client Access Port.
This is the port that computers running SOLIDWORKS Visualize use to connect to the
Boost cluster. The default cluster client access port is 8998.

6. In the Networking Mode area, select an option based on your network environment:

• Select No Networking to prevent this computer from belonging to any other
cluster. This mode is useful for troubleshooting issues with Visualize Boost.

• Select UDP Multicast Mode if your network supports UDP Multicast. Visualize
Boost will search the network and form a cluster of all computers using UDP
Multicast Mode on the same port. This mode is recommended, if your network
supports it.

• Select TCP Mode with Discovery (Default) if you cannot use UDP Multicast
mode. Visualize Boost will search the network and form a cluster of all computers
using TCP Mode with Discovery on the same port.

• Select TCP Mode if you need to create an explicit list of the computers in the
cluster, because the other modes are not successful in finding the computers you
want to include. This mode requires additional work to configure and is not
recommended if either UDP Multicast or TCP Mode with Discovery are available.

7. If you select UDP Multicast Mode or TCP Mode with Discovery, enter the Cluster
Discovery Address.

This setting must be an IP address and a port above 1024. The default port
varies among the networking modes:

• 8994 for UDP Multicast
• 8995 for TCP Mode with Discovery
• 8996 for TCP

These ports are used for Visualize Boost computers to connect with each other. All
computers configured with the same Cluster Discovery Address and that are on
the same local network will form a cluster.

8. If you select TCP Mode:

• Enter a Cluster Access Port. This is the port that Visualize Boost nodes in the
cluster use to communicate with each other. The default port for TCP Mode is 8996.

• If this machine is going to be the “head node” of the cluster (the machine that
coordinates the work of the cluster), use the Cluster Address List field to list the
IP addresses of other nodes in the cluster. Each IP address (such as
192.168.0.100:8996) must include the Cluster Access Port configured for all
nodes in the cluster. Leave the field blank if this machine is not going to be the
head node of the cluster.
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9. Click Save Configuration. Visualize Boost saves the new configuration, then stops
and restarts the service.

10. Click the Status tab. If the status is Ready, the screen displays the computers
connected in the cluster and the Sessions (jobs) assigned to the cluster.

Selecting a Visualize Boost Cluster for Rendering
Before you can use a Boost cluster for rendering, you must add it to a Profiles list on your
SOLIDWORKS Visualize Professional computer and then, select it.

To add and select a Boost cluster in the Profiles list:

1. In SOLIDWORKS Visualize, click Tools > Options and select the Boost tab.
2. Click Scan to search the network for Boost clusters.
3. Click Add to add a new cluster to the list of cluster profiles. Only select NVIDIA VCA

if you have installed an NVIDIA Quadro VCA on your network.
4. In the Profiles list, highlight the cluster name. The Boost Settings area displays the

status, cluster name, and the cluster discovery address.
5. If needed, adjust PowerBoost settings for real-time ray tracing and click Connect.

Adjusting PowerBoost Settings for Ray Tracing
Ray tracing is a technique for rendering 3D scenes. Ray tracing traces the path of every
ray of light from its source until it either leaves the scene or becomes too weak to have
an effect. The term also applies to the reverse method: tracing the path of every ray of
light from the camera back to the light source.

PowerBoost (available only with SOLIDWORKS Visualize Professional) provides a render
mode that streams ray tracing directly to your Visualize Viewport. An Internet connection
is required, and a multi-GPU machine for a Visualize Boost computer or an NVIDIA Quadro
VCA is recommended for the best performance.

To adjust PowerBoost settings for ray tracing:

1. In SOLIDWORKS Visualize, click Tools > Options and select the Boost tab.
2. In the Profiles list, select a cluster profile with a high performance machine or an

NVIDIA Quadro® VCA.
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3. The default settings for PowerBoost are acceptable for most networks. You can adjust
the following settings as needed:

• Transmission Mode: Streaming is the default and applies to network connections
with low bandwidth and high latency. Select Synchronous if the network connection
has very high bandwidth and low latency, which is common in local area networks.

• Transmission Format: H.264 is the default and uses relatively little bandwidth,
which increases performance. Lossless provides slightly higher image quality, but
consumes much more bandwidth and reduces performance.

• Streaming Bitrate: Higher values increase image quality but consume more
network bandwidth. Lower values save bandwidth but reduce image quality.

• Maximum Framerate: Higher values increase image quality but make the
application less responsive. Lower values increase responsiveness but reduce image
quality.

• Latency: Higher values increase image quality but make the software less
responsive to user input (such as camera movement). Lower values increase
responsiveness but reduce image quality.

Show Log Files
In SOLIDWORKS Visualize, from Tools > Options > Boost tab, click Show Log Files
to review log files for the Boost service, Queue, Visualize Queue Server, Offline Renderer,
and others.

Share Cluster Profiles
You can save a cluster profile and share it with other SOLIDWORKS Visualize Professional
users on your network.

To share a cluster profile:

1. In SOLIDWORKS Visualize, click Tools > Options and select the Boost tab.
2. Click Save to save the profile on your hard drive and send the file to a colleague.
3. Your colleague can then start SOLIDWORKS Visualize Professional, go to Tools >

Options > Boost tab, and click Load to load the file to the Profiles list.
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Rendering Images
To render output to a Visualize Boost cluster:

1. In SOLIDWORKS Visualize Professional, open a model and click Tools > Render, or

in the main toolbar, click Output Tools .
2. In the Output Tools dialog box, under the Render Settings area, click PowerBoost

.

The Cluster name displays.

3. Set the Render Mode. You can set a time limit or select Quality and enter a number
of Passes. The default of 500 passes is adequate for most render jobs.

4. To start rendering at a later time, select Send to Queue.

The job is sent to the SOLIDWORKS Visualize Queue and does not complete until you
click Start Queue in the Queue Client.

5. If you are ready to render, select Show Progress to monitor the rendering process.
Then click Start Render.

You can click Pause, Save Now, or Cancel to stop the rendering.

When using Visualize Boost for rendering, the Visualize Professional computer must
stay online and connected to the network. The computer cannot be turned off or
unplugged from the Internet until Visualize Boost has completed the job.

Geometry Opacity and Animation Support
You can adjust the opacity of parts, groups, and models to help show the inner details
of complex projects.

With the part selected, adjust the Opacity slider in the Models tab to fade the
transparency.

Results are updated in real-time in the Viewport.
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For animations, you can also adjust keyframes using the Opacity slider.

The fading of parts is only supported in Preview and Accurate modes.

Context Sensitive Help
In SOLIDWORKS Visualize dialog boxes, you can display help that is specific to the dialog
boxes by pressing F1.

In other places in the user interface such as on a Palette tab, pressing F1 opens the help
at the Welcome to SOLIDWORKS Visualize topic. Use the Search tab to locate specific
help topics.

Creating Section Views
To display the internal parts of a model, you can create section views by adding cut
planes.

You can manipulate cut planes using the standard move controls. You can use multiple
cut planes to further dissect your model. There is no limit.

In SOLIDWORKS Visualize Professional, you can also animate the effect of cut planes the
same way that you animate a model.
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To create section views:

1. On the Models tab, click New Cutting Plane.

You can also create a cutting plane by clicking Project > Models > New Cutting
Plane.

The cutting plane appears in the Viewport as a faint, mostly transparent plane that
automatically stretches across your entire model.

2. In the model tree, select the cut plane.
The cut plane parameters are listed below the model tree.

3. Type a Name for the plane.
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4. Use the Rotate and Transform options to modify the plane's orientation.

• To reverse the plane, click Flip.

• To rotate the plane 90º, click one of the Rotate options.

• To tip the plane, under Transform, change one or more of the Rotation XYZ
values.

You can also use the transform manipulator to modify the position of the plane. To
enable the manipulator, right-click the cut plane in the Model Set and click
Manipulate > Move.

.
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5. To add an additional cutting plane, click New Cutting Plane.

6. Select the second plane and use the same controls to manipulate it.
7. To hide a cut plane, do one of the following:

• In the Model Set, right-click the cut plane and click Hide Cutting Plane.
• In the cut plane parameters, click Hidden.

8. To remove a cut plane, in the Model Set, right-click the cut plane and click Delete.

You can also animate cut planes as well.

Cut planes affect all geometry in a scene. They cannot be applied to only specific parts,
groups or models.

Home Screen
In Visualize's home screen, you can easily find projects that you opened recently, and
perform other tasks.

You can view thumbnails of recently opened SOLIDWORKS Visualize (*.SVPJ) and
Bunkspeed (*.BIF) projects, open the projects with a click, “pin” projects so they always
appear on the home screen ahead of unpinned projects, and show the folder in which
each project file is stored in Windows Explorer.

In a separate tab, you can view thumbnails of recently opened SOLIDWORKS assemblies
and parts (*.SLDASM, *.SDPRT), open them by clicking on a thumbnail, and show the
folder in which each file is stored in Windows Explorer.

You can find and download sample projects stored in the Visualize cloud library.
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Links on the home screen also make it easy to read tips, watch tutorials, view online help,
and access community forums, where you can share and discuss renderings.

Pivot Point Snapping
Pivot point snapping lets you accurately locate a model's pivot point on the model surface.

To place the pivot point:

1. Click Object Manipulation Tools > Pivot .
2. Hold the Ctrl key.

A small blue dot that appears in the Viewport, overlayed on top of the model, shows
where you can snap the pivot location.

Using SOLIDWORKS Camera Navigation and
Shortcuts

Users familiar with SOLIDWORKS CAD camera navigation can use it instead of the standard
SOLIDWORKS Visualize camera navigation.

To use SOLIDWORKS CAD camera navigation, do the following:

• While running SOLIDWORKS Visualize, click Tools > Options. In the Options dialog
box, on the User Interface tab, for Navigation, select SOLIDWORKS CAD mode.

When you manipulate the camera, the pointer corresponds to the selected tool.

The following navigation behavior is available:
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SOLIDWORKS
keyboard shortcuts

Visualize keyboard
shortcuts

CursorAction

Drag with the middle
mouse button.

Press the arrow keys.
Hold down Shift to
rotate in 90º
increments.

Alt + clickRotate view

Hold down Ctrl and
drag with the middle
mouse button.

Hold down Ctrl and
press the arrow keys.

Alt + middle mouse
button

Pan camera

Hold down Alt and
drag with the middle
mouse button.

Hold down Alt and
press the left-right
arrow keys.

Ctrl + Alt + ScrollRoll view

Hold down Shift and
drag with the middle
mouse button.

Press Z to zoom out
or Shift + Z to zoom
in.

Alt + right-clickZoom in and out

Scroll wheel when
Zoom about screen
center is cleared.

HomeZoom to area

Additional Enhancements
• Smart Control Bar for rendering profiles

A newly designed Smart Control Bar allows you to add frequently used render profiles
to a convenient drop-down menu.

The controls allow you to:
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Copies the current render profile.Duplicate the current item

Lets you name the profile.Add a new item

Displays settings for a profile.Render Profiles

Lets you rename a profile.Rename the current item

Locks profile to prevent changes.Lock the current item

• Duration field to set the time of animations, turntables and sun studies

A new Duration field makes it easy to set the length of animations, turntables and
sun studies. In previous releases, you had to divide the number of total frames in the
animation by FPS (Frames Per Second) to calculate the duration of the movie.

• Improvements for setting size and resolution

Interface improvements make it easier to set the size and resolution of outputs. You
can select from supported units of measure for the size, input a size and resolution,
and see the resulting image and print size in the selected units.

• Improvements in the Import Settings dialog box

• The layout of the Part Grouping mode and settings is clearer.
• A new Snap To Floor check box automatically snaps the lowest point of your model
to the floor of your Visualize scene.

• When you import a project into Visualize from any supported file format, the scene
automatically scales to fit your model. The Auto-Size check box has been removed,
since this setting is no longer needed.

• Rearrangement of commands in menus

Commands, especially in the File and Project menus, have been rearranged and
logically grouped. The redesign reduces menu complexity while still providing access
to all commands that were previously available.

• Support for .jt and CREO 3.0 files was added
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